Makale numarası: 837115 - Son Gözden Geçirme: 02 Kasım 2005 Çarşamba - Gözden geçirme: 3.2

Profil kaldırma sorunlarını giderme

Sistem İpucuBu makale, kullandığınızdan farklı bir işletim sistemine yöneliktir. Sizinle ilgili olmayabilecek makale içeriği devre dışı bırakıldı.
Hepsini aç | Hepsini kapa

Belirtiler

Microsoft Windows Server 2003, Windows XP, Windows 2000 veya Windows NT 4.0 çalışan bir bilgisayarda oturumu kapattığınızda, aşağıdaki belirtilerden bir veya daha fazlasıyla karşılaşabilirsiniz:
  • Bir kullanıcı profili bellekten kaldırılamıyor.
  • Bir gezici profil uyuşmuyor.
  • Kayıt defteri boyut sınırına (RSL) ulaşıyorsunuz.
  • Oturumu kapatmanız uzun zaman alıyor ve aşağıdaki iletiyi alıyorsunuz:
    Ayarlarınız kaydediliyor….
Ayrıca, işletim sisteminize bağlı olarak uygulama olay günlüğünde aşağıdaki hata iletilerinden birini veya daha fazlasını alabilirsiniz.

Windows XP ve Windows Server 2003

Olay Türü: Hata:
Olay Kaynağı: Userenv
Olay Kategorisi: Yok
Olay Kimliği: 1517
Açıklama:
Windows, oturum kapatılması sırasında bir uygulama veya hizmet halen kullanırken, BilgisayarAdı\KullanıcıAdı kullanıcı kayıt defterini kaydetti. Kullanıcı kayıt defterinin kullandığı bellek boşaltılamadı. Kayıt defteri kullanımda olmadığında kaldırılacak. Bu, genellikle kullanıcı hesabıyla çalışan hizmetler nedeniyle oluşur, hizmetleri LocalService veya NetworkService hesabıyla çalışacak şekilde yapılandırmayı deneyin.

Olay Türü: Hata:
Olay Kaynağı: Userenv
Olay Kategorisi: Yok
Olay Kimliği: 1524 Açıklama:
Windows sınıf kayıt defteri dosyasını kaldıramıyor - dosya halen diğer uygulama veya hizmetler tarafından kullanılıyor. Dosya kullanımda olmadığında kaldırılacak.

Olay Türü: Hata:
Olay Kaynağı: Userenv
Olay Kategorisi: Yok
Olay Kimliği: 1500
Açıklama:
Windows size oturum açamaz çünkü profiliniz yüklenemedi. Ağa bağlı olduğunuzu denetleyin veya ağın doğru çalıştığını doğrulayın. Bu sorun devam ederse, ağ yöneticinizle bağlantıya geçin.
Ayrıntılar:
------------------------------
Erişim reddedildi

Windows 2000

Olay Türü: Hata:
Olay Kaynağı: Userenv
Olay Kategorisi: Yok
Olay Kimliği: 1000
Açıklama:
Windows, kayıt defteri dosyanızı kaldıramıyor. Gezici profiliniz varsa, ayarlarınız çoğaltılmaz. Yöneticinize başvurun.
Ayrıntılar:
------------------------------
Erişim reddedildi

Olay Türü: Hata:
Olay Kaynağı: Userenv
Olay Kategorisi: Yok
Olay Kimliği: 1000
Açıklama:
Windows, kayıt defteri sınıf dosyanızı kaldıramıyor. Gezici profiliniz varsa, ayarlarınız çoğaltılmaz. Yöneticinize başvurun.
Ayrıntılar: -
-----------------------------
Erişim reddedildi

Olay Türü: Hata:
Olay Kaynağı: Userenv
Olay Kategorisi: Yok
Olay Kimliği: 1000
Açıklama:
Profil yüklemediği için Windows oturumunuzu açamıyor. Ağ yöneticinize başvurun.

Windows NT 4.0

Olay Türü: Hata:
Olay Kaynağı: Userenv
Olay Kategorisi: Yok
Olay Kimliği: 1000
Açıklama:
İşletim sistemi profilinizi yükleyemedi. Lütfen Ağ Yöneticinize başvurun.
Ayrıntılar:
------------------------------
Erişim reddedildi.

Neden

Bu sorun, bilgisayar oturumunu kapattığınızda Microsoft Windows ya da yazıcı sürücüleri veya virüs tarayıcılar gibi üçüncü taraf programlar durmaz ve kaynakları serbest bırakmazsa oluşur.

Çözüm

Bu sorunu gidermek için, Microsoft User Profile Hive Cleanup Service'i (Kullanıcı Profili Kovan Temizleme Hizmeti, UPHClean) kullanın. UPHClean, Windows'un kullanıcı profillerini kaldırdığı sırada bilgisayarı izler ve açık kaynakların kapatılmasını zorlar. Bu nedenle, bilgisayar kullanıcı profillerini kaldırabilir ve karşılaştırabilir.

UPHClean'i karşıdan yüklemek ve kurmak için aşağıdaki Microsoft Web sitesini ziyaret edin:
http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582 (http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582)

Daha fazla bilgi

UPHClean hakkında ek bilgi için, Readme.txt dosyasına bakın. Dosyayı karşıdan yüklemek için aşağıdaki Microsoft Web sitesini ziyaret edin:
http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582 (http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582)

Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Anahtar Kelimeler: 
kbserviceprocess kbprofiles kbprb kbwinservperf KB837115