You receive a "COMException" error message when you use Revision History to compare two postings in Content Management Server 2002

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Article ID: 837281 - View products that this article applies to.
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SYMPTOMS

In Microsoft Content Management Server 2002, when you use Revision History to compare two postings, you may receive the following error message:
Server Error in '/Your CMS Web' Application.
--------------------------------------------------------------------------------
Exception occurred. Description: An unhandled exception occurred during the execution of the current web request.
Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: Exception occurred.

Source Error:

An unhandled exception was generated during the execution of the current web request.
Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[COMException (0x80020009): Exception occurred.]
Microsoft.ContentManagement.Interop.CompareHtml.CompareClass.CompareBuffers(String bstrOldContent, String bstrNewContent, Boolean bSrcCompare) +0
Microsoft.ContentManagement.WebAuthor.PageRevisionCompareInfo.GetCompareResultHtml() +752
Microsoft.ContentManagement.WebAuthor.PageRevisionCompareInfo.Page_Load(Object sender, EventArgs e) +1264
System.Web.UI.Control.OnLoad(EventArgs e) +67 System.Web.UI.Control.LoadRecursive() +35
System.Web.UI.Page.ProcessRequestMain() +731

CAUSE

Content Management Server uses a buffer when it generates the HTML code to perform a revision comparison. The buffer has a fixed size of 500 kilobytes (KB). This problem occurs if the size of the postings that you want to compare is greater than 500 KB.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size       File name
   --------------------------------------------------------------------------------
   04-Mar-2004  02:04  5.0.2525.0    316,416  Aeinterfaces.dll
   04-Mar-2004  02:05  5.0.2525.0  1,233,408  Aeserverobject.dll
   04-Mar-2004  02:05  5.0.2525.0    101,888  Comparehtml.dll
   04-Mar-2004  02:06  5.0.2525.0    753,152  Serverconfigurationapi.dll
   04-Mar-2004  02:06  5.0.0.2525     24,725  Versioncomparisonbuffersizeconfig.exe

MORE INFORMATION

This hotfix includes a tool that is named Versioncomparisonbuffersizeconfig.exe. You can run this tool on the computer that is running Content Management Server. This tool permits you to change the buffer size for generating HTML code.

Note If you set the buffer size value too high, the process may not be able to allocate the memory for Content Management Server. For example, if you set the buffer size value to 100 megabytes (MB), the process may not be able to allocate that much memory.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 837281 - Last Review: November 15, 2007 - Revision: 1.5
APPLIES TO
  • Microsoft Content Management Server 2002
  • Microsoft Content Management Server 2002 Service Pack 1a
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbhotfixserver kbqfe kbqfe kbbug kbfix kbcontentmgtserv2002presp2fix KB837281

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