Artigo: 837285 - Última revisão: quinta-feira, 25 de Outubro de 2007 - Revisão: 3.4

Os utilizadores poderão receber uma mensagem de erro "503 Serviço indisponível" no Exchange Server 2003 quando tentam utilizar um browser para aceder ao OWA

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Expandir tudo | Reduzir tudo

Sintomas

Quando os utilizadores tentam utiliza um browser para aceder ao Microsoft Office Outlook Web Access para Exchange Server 2003, poderão receber a seguinte mensagem de erro:
503 Serviço indisponível

Causa

Este problema poderá ocorrer quando se verificam as seguintes condições:
  • O computador do Exchange 2003 for actualizado a partir do Microsoft Windows 2000 para o Microsoft Windows Server 2003.
  • O ficheiro do Microsoft Data Access Components (MDAC) que chama Oledb32.dll não foi actualizado para a versão correcta durante a actualização do Windows Server 2003.
Neste cenário, o serviço Microsoft Exchange Information Store poderá não ser iniciado porque a versão do Oledb32.dll está incorrecta.

Resolução

Para resolver este problema, copiar Oledb32.dll de um computador baseado no Windows Server 2003 que não foi actualizado a partir do Windows 2000 e reinicie o serviço Microsoft Exchange Information Store. Para o fazer, siga estes passos:
  1. Clique em Iniciar , aponte para Todos os programas , aponte para Ferramentas administrativas e, em seguida, clique em Serviços .
  2. Pare o serviço Microsoft Exchange Information Store.
  3. Copie o ficheiro Oledb32.dll de um computador baseado no Windows Server 2003 não foi actualizado do Windows 2000 para o computador do Exchange. Para o fazer, utilize um dos seguintes métodos.

    Método 1

    Copie o ficheiro a partir de um computador disponível com base em Windows Server 2003 que não foi actualizado a partir do Windows 2000.

    Método 2

    1. Instale uma nova cópia do Windows Server 2003 numa partição separada no computador através da criação de uma instalação paralela.
    2. Copie o ficheiro Oledb32.dll.
    3. Remova a nova instalação, se desejar.
    Para obter informações adicionais sobre como criar uma instalação paralela, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    266465  (http://support.microsoft.com/kb/266465/ ) Como efectuar uma instalação paralela do Windows 2000 ou Windows 2003
    Nota A localização predefinida de Oledb32.dll é C:\Program Files\Common Files\System\Ole DB\Oledb32.dll.
  4. Copie Oledb32.dll para mesma localização no computador do Exchange onde está a tentar resolver este problema.
  5. No computador do Exchange, escreva os seguintes comandos na linha de comandos:
    • CD Program Files\Common Files\System\ole db
    • regsvr32 oledb32.dll

    Nota A versão do ficheiro Oledb32.dll tem de ser 2.8.1022.0 ou posterior para resolver o problema descrito na secção "Sintomas".
  6. Inicie o serviço Microsoft Exchange Information Store.

Mais Informação

Quando detecta o problema descrito na secção "Sintomas", poderão ser registados os seguintes eventos no registo de eventos de aplicações quando reiniciar os serviços do Exchange 2003:

Tipo de evento: Information
Origem do evento: MSExchangeSA
Categoria do evento: geral
ID do evento: 9014
Descrição: Microsoft Exchange System Attendant foi iniciado para Exchange server nomeservidor com êxito.


Tipo de evento: Information
Origem do evento: MSExchangeSA
Categoria do evento: monitorização
ID do evento: 9095
Descrição: O thread de monitorização MAD está a inicializar.


Tipo de evento: Information
Origem do evento: MSExchangeSA
Categoria do evento: monitorização
ID do evento: 9096
Descrição: O thread de monitorização MAD foi inicializado.


Tipo de evento: Information
Origem do evento: EXOLEDB
ID do evento: 101
Descrição: O OLEDB do Microsoft Exchange com êxito foi encerrado.


Tipo de evento: erro
Origem do evento: MSExchangeIS
ID do evento: 9542
Descrição: A inicialização da interface externa que OLEDB falhou; Erro ecServerOOM.



Além disso, a seguinte mensagem de ID de evento poderão ser registada no registo de eventos aplicação várias vezes:

Tipo de evento: erro
Origem do evento: as funcionalidades EXCDO
Categoria do evento: geral
ID do evento: 8206
Descrição: Calendário Calendaring agente falhou com o erro código 0x800XXXXX ao guardar um compromisso.



A seguinte mensagem de erro de ID de evento poderão ser registada no registo do sistema no Visualizador de eventos várias vezes:

Tipo de evento: erro
Origem do evento: DCOM
Categoria do evento: nenhum
ID do evento: 10002
Descrição: Acesso negado a tentar iniciar um servidor de DCOM. O servidor é: {9DA0E106-86CE-11 11D1-8699-00C04FB98036} O utilizador é SYSTEM/NT AUTHORITY, SID = S-1-5-18


Para obter informações adicionais sobre como resolver a mensagem de erro "503 Serviço indisponível", clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
823159  (http://support.microsoft.com/kb/823159/ ) Como resolver a mensagem de erro "503 Serviço indisponível" no Outlook Web Access no Exchange Server 2003

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition nas seguintes plataformas
    • Microsoft Windows Server 2003 Standard Edition
Palavras-chave: 
kbmt kberrmsg KB837285 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 837285  (http://support.microsoft.com/kb/837285/en-us/ )