0 X eine "80041001 - Generic Fehler" Fehlermeldung beim Abfragen von SMS_Program in Systems Management Server 2003 Fehlermeldung

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 837387 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Wenn Sie die Klasse (Windows Management INSTRUMENTATION) SMS_Program in Systems Management Server (SMS) 2003 Abfragen, erhalten Sie eine Fehlermeldung, die folgenden Fehlermeldung ähnelt:
Fehler
Anzahl: 0 x 80041001
Einrichtung: WMI
Beschreibung: Allgemeiner Fehler
Dieser Fehler tritt auf, wenn Sie ein Visual Basic-Skript (VBS) oder das Tool Wbemtest, zum Abfragen der Klasse verwenden.

Außerdem, wenn Sie versuchen, die SMS-Administratorkonsole zu verwenden, um eine neue Ankündigung erstellen, Programme, die das Paket zugeordnet sind, die Sie ankündigen möchten möglicherweise nicht in das Programm Dropdown-Menü angezeigt und der folgende Fehler auf die Datei smsprov.log protokolliert:
E:\TOPAZ\sdk_provider\nt\smsprov\SspObjectQuery.cpp(4313): Fehlgeschlagen.

Ursache

Dieses Problem kann auftreten, wenn Sie die Instanz die Sicherheitsrechte für eine oder mehrere SMS-Pakete angewendet haben.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
   Date         Time   Version        Size       File name    Platform
   -------------------------------------------------------------------
   25-Dec-2003  10:55  2.50.2726.123  4,444,160  Smsprov.dll  x86
Hinweis: Aufgrund von Dateiabhängigkeiten enthält das aktuellste Update oder Feature, das diese Dateien enthält, möglicherweise auch weitere Dateien.

Informationen zur Installation

Der Hotfix-installer

Hinweis: Dieses Verfahren ist nur für Intel-basierte Computer geeignet.

So verwenden Sie das Hotfix-Installationsprogramm, um diesen Hotfix installieren, gehen Sie folgendermaßen vor:
  1. Erstellen Sie einen Ordner an einem Standort, die SMS-Standortserver verwenden können.
  2. Kopieren Sie die SMS 2003-RTM-KB837387-X 86-DEU.exe Update-Datei in den neuen Ordner.
  3. Verwenden Sie aus allen primären SMS Site Server in Ihrer Umgebung ein Konto, das zur Anmeldung auf Ihrem Siteserver über Administratorberechtigungen verfügt.
  4. Beenden Sie die SMS-Administratorkonsole, falls sie gerade ausgeführt wird.
  5. Führen Sie die SMS 2003-RTM-KB837387-X 86-enu.exe-Datei, und dann folgen Sie die Anweisungen des Assistenten.

Manuelle Installation

Wie Sie den Hotfix manuell auf dem SMS-Standortserver installieren
Gehen Sie folgendermaßen vor um den Hotfix manuell an die SMS-Standortserver zu installieren:
  1. Erstellen Sie einen Ordner an einem Standort, die SMS-Standortserver verwenden können.
  2. Führen Sie den folgenden Befehl aus:
    SMS 2003-RTM-KB837387-X 86-DEU.exe/x
    Extrahieren Sie die Hotfix-Dateien in den Ordner, den Sie erstellt haben.
  3. Verwenden Sie aus allen primären SMS Site Server in Ihrer Umgebung ein Konto, das zur Anmeldung auf Ihrem Siteserver über Administratorberechtigungen verfügt.
  4. Beenden der SMS-Administratorkonsole.
  5. Beenden Sie alle SMS-Dienste.
  6. Beenden Sie den WMI-Dienst.
  7. Führen Sie im Ordner SmsRootFolder \bin\ Platform den folgenden Befehl aus:
    regsvr32/u smsprov.dll
  8. Kopieren Sie die aktualisierte smsprov.dll-Datei von der Festplatte oder Netzwerkfreigabe in den Ordner SmsRootFolder \bin\ Platform.
  9. Führen Sie im Ordner SmsRootFolder \bin\ Platform den folgenden Befehl aus:
    regsvr32 smsprov.dll
  10. Starten Sie den WMI-Dienst neu.
  11. Starten Sie die SMS-Dienste neu.
Manuell die Installation von Hotfixes auf einem Remoteserver SMS-Anbieter
Gehen Sie folgendermaßen vor um den Hotfix manuell zu einem SMS-Anbieter-Remoteserver zu installieren:
  1. Alle SMS-Dienste und den WMI-Dienst auf dem SMS-Anbieter zu beenden.
  2. Führen Sie im Ordner SmsRootFolder \bin\ Platform den folgenden Befehl aus:
    regsvr32/u smsprov.dll
  3. Ersetzen Sie die smsprov.dll-Datei im Ordner SmsRootFolder \bin\ Platform, mit der Version aus dem Hotfix.
  4. Führen Sie im Ordner SmsRootFolder \bin\ Platform den folgenden Befehl aus:
    regsvr32 smsprov.dll
  5. Starten Sie den WMI-Dienst und alle SMS-Dienste auf dem SMS-Anbieter-Server.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Eigenschaften

Artikel-ID: 837387 - Geändert am: Dienstag, 24. Juli 2007 - Version: 2.10
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Systems Management Server 2003 Enterprise Edition
Keywords: 
kbmt kbautohotfix kbhotfixserver kbqfe KB837387 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 837387
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com