Vous recevez 0 x un « 80041001 - Échec générique" message d'erreur quand vous interrogez SMS_Program dans Systems Management Server 2003

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Sommaire

Symptômes

Si vous interrogez la classe WMI (Windows Management Instrumentation) SMS_Program dans Systems Management Server (SMS) 2003, un message d'erreur est similaire à la message d'erreur suivant peut s'afficher :
Erreur
Numéro: 0 x 80041001
Fonction : WMI
Description : Échec générique
Cette erreur se produit si vous utilisez un script Visual Basic (VBS) ou l'outil wbemtest pour interroger la classe.

En outre, si vous essayez d'utiliser le SMS Administrator Console pour créer une nouvelle publication, programmes associés avec le package que vous voulez publier peuvent ne pas apparaissent dans le menu déroulant de programme et l'erreur suivante est consignée dans le fichier Smsprov.log :
E:\TOPAZ\sdk_provider\nt\smsprov\SspObjectQuery.cpp(4313) : la requête a échoué.

Cause

Ce problème peut se produire si vous avez appliqué instance droits de sécurité à un ou plusieurs packages SMS.

Résolution

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'outil Date et heure du Panneau de configuration.
   Date         Time   Version        Size       File name    Platform
   -------------------------------------------------------------------
   25-Dec-2003  10:55  2.50.2726.123  4,444,160  Smsprov.dll  x86
note En raison des dépendances de fichiers, la fonctionnalité qui contient ces fichiers ou correctif plus récent peut également contenir des fichiers supplémentaires.

Informations sur l'installation

Le programme d'installation du correctif

note Cette méthode est uniquement pour les ordinateurs Intel.

Pour utiliser le programme d'installation du correctif pour installer ce correctif, procédez comme suit :
  1. Créez un dossier dans un emplacement qui permet de vos serveurs de site SMS.
  2. Copiez-le SMS2003-RTM-KB837387-X 86-ENU.exe mise à jour vers le nouveau dossier.
  3. De chacune des serveurs de site SMS principales de votre environnement, utiliser un compte qui possède informations d'identification d'administration pour ouvrir une session sur votre serveur de site.
  4. Quittez la console Administrateur SMS si elle est en cours d'exécution.
  5. Exécutez le fichier de 86-ENU.exe SMS2003-RTM-KB837387-X et suivez les instructions de l'Assistant.

Installation manuelle

Comment faire pour manuellement installer le correctif sur le serveur de site SMS
Pour installer manuellement le correctif au serveur de site SMS, procédez comme suit :
  1. Créez un dossier dans un emplacement qui permet de vos serveurs de site SMS.
  2. Exécutez la commande suivante :
    SMS2003-RTM-KB837387-X 86-ENU.exe /x
    Extrayez les fichiers hotfixed dans le dossier que vous avez créé.
  3. De chacune des serveurs de site SMS principales de votre environnement, utiliser un compte qui possède informations d'identification d'administration pour ouvrir une session sur votre serveur de site.
  4. Quittez la console Administrateur SMS.
  5. Arrêtez tous les services SMS.
  6. Arrêtez le service WMI.
  7. Dans le dossier Platform de \bin\ SmsRootFolder, exécutez la commande suivante :
    regsvr32 /u Smsprov.dll
  8. Copiez le fichier Smsprov.dll mis à jour à partir du disque ou réseau partage le dossier SmsRootFolder \bin\ Platform.
  9. Dans le dossier Platform de \bin\ SmsRootFolder, exécutez la commande suivante :
    regsvr32 Smsprov.dll
  10. Redémarrez le service WMI.
  11. Redémarrez les services SMS.
Comment installer manuellement le correctif à un serveur distant fournisseur SMS
Pour installer manuellement le correctif à un serveur distant fournisseur SMS, procédez comme suit :
  1. Sur le serveur fournisseur SMS, arrêtez tous les services SMS et le service WMI.
  2. Dans le dossier Platform de \bin\ SmsRootFolder, exécutez la commande suivante :
    regsvr32 /u Smsprov.dll
  3. Remplacez le fichier Smsprov.dll dans le dossier SmsRootFolder \bin\ Platform avec la version du correctif.
  4. Dans le dossier Platform de \bin\ SmsRootFolder, exécutez la commande suivante :
    regsvr32 Smsprov.dll
  5. Redémarrez le service WMI et tous les services SMS sur le serveur fournisseur SMS.

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Propriétés

Numéro d'article: 837387 - Dernière mise à jour: mardi 24 juillet 2007 - Version: 2.10
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Systems Management Server 2003 Enterprise Edition
Mots-clés : 
kbmt kbautohotfix kbhotfixserver kbqfe KB837387 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 837387
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