Você receberá um "0x80041001 - Falha genérica" mensagem de erro quando você consulta SMS_Program no Systems Management Server 2003

Traduções deste artigo Traduções deste artigo
ID do artigo: 837387 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Se você consultar a classe de WMI (Instrumentação de gerenciamento do Windows) SMS_Program no Systems Management Server (SMS) 2003, você receberá uma mensagem de erro é semelhante a seguinte mensagem de erro:
Erro
Número: 0x80041001
Recurso: WMI
Descrição: Falha genérica
Este erro ocorre se você usar um script do Visual Basic (VBS) ou a ferramenta wbemtest para consultar a classe.

Além disso, se você tentar usar o console SMS Administrator para criar um novo anúncio, programas que estão associados com o pacote que você deseja anunciar podem não aparecer no menu drop-down de programa e o seguinte erro é registrado para o arquivo Smsprov.log:
E:\TOPAZ\sdk_provider\nt\smsprov\SspObjectQuery.cpp(4313): Falha na consulta.

Causa

Esse problema pode ocorrer se você tiver aplicado direitos de instância para um ou mais pacotes SMS.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version        Size       File name    Platform
   -------------------------------------------------------------------
   25-Dec-2003  10:55  2.50.2726.123  4,444,160  Smsprov.dll  x86
Observação Devido às dependências do arquivo, o hotfix mais recente ou o recurso que contém esses arquivos também pode conter arquivos adicionais.

Informações sobre a instalação

O instalador do hotfix

Observação Esse método é somente para computadores baseados no Intel.

Para usar o instalador do hotfix para instalar esse hotfix, execute essas etapas:
  1. Crie uma pasta em um local que seus servidores de site do SMS podem usar.
  2. Copie o arquivo de atualização de 86-enu.exe SMS2003-RTM-KB837387-X para a nova pasta.
  3. De cada um dos servidores de site SMS primários no seu ambiente, use uma conta que tenha credenciais administrativas para fazer logon no seu servidor de site.
  4. Encerre o console SMS Administrator se ele estiver sendo executado.
  5. Execute o SMS2003-RTM-KB837387-X 86-enu.exe arquivo e, em seguida, siga as instruções no assistente.

Instalação manual

Como instalar manualmente o hotfix para o servidor do site do SMS
Para instalar manualmente o hotfix ao servidor de site do SMS, execute estas etapas:
  1. Crie uma pasta em um local que seus servidores de site do SMS podem usar.
  2. Execute o seguinte comando:
    sms2003-RTM-KB837387-X 86-enu.exe /x
    Extraia os arquivos de hotfix para a pasta que você criou.
  3. De cada um dos servidores de site SMS primários no seu ambiente, use uma conta que tenha credenciais administrativas para fazer logon no seu servidor de site.
  4. Feche o console de administrador do SMS.
  5. Interrompa todos os serviços do SMS.
  6. Interrompa o serviço WMI.
  7. Na pasta SmsRootFolder \bin\ Platform, execute o seguinte comando:
    regsvr32 /u Smsprov.dll
  8. Copie o arquivo Smsprov.dll atualizado do compartilhamento de disco ou rede para a pasta de PlatformSmsRootFolder \bin\.
  9. Na pasta SmsRootFolder \bin\ Platform, execute o seguinte comando:
    regsvr32 Smsprov.dll
  10. Reinicie o serviço WMI.
  11. Reinicie os serviços do SMS.
Como instalar manualmente o hotfix em um servidor SMS Provider remoto
Para instalar manualmente o hotfix em um servidor SMS Provider remoto, execute estas etapas:
  1. No servidor SMS Provider, interrompa todos os serviços do SMS e o serviço WMI.
  2. Na pasta SmsRootFolder \bin\ Platform, execute o seguinte comando:
    regsvr32 /u Smsprov.dll
  3. Substitua o arquivo Smsprov.dll na pasta SmsRootFolder \bin\ Platform com a versão do hotfix.
  4. Na pasta SmsRootFolder \bin\ Platform, execute o seguinte comando:
    regsvr32 Smsprov.dll
  5. Reinicie o serviço WMI e todos os serviços do SMS no servidor SMS Provider.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Propriedades

ID do artigo: 837387 - Última revisão: terça-feira, 24 de julho de 2007 - Revisão: 2.10
A informação contida neste artigo aplica-se a:
  • Microsoft Systems Management Server 2003 Enterprise Edition
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe KB837387 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 837387

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com