STOP: 0x00000050 error occurs in Windows Server 2003 when a Terminal Services session is closed

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Article ID: 837583 - View products that this article applies to.
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SYMPTOMS

When you log off from a Terminal Services session on a Microsoft Windows Server 2003-based computer, Windows may stop unexpectedly. You may receive an error message that is similar to the following:
STOP: 0x00000050 (Parameter 1, Parameter 2, Parameter 3, Parameter 4)PAGE_FAULT_IN_NONPAGED_AREA

CAUSE

This problem occurs when the Win32k driver cleans up its internal structure during the Terminal Services session logoff, and the clean up is not completed correctly.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, Itanium-based versions
   Date         Time   Version       Size       File name
   -------------------------------------------------------
   28-Apr-2004  00:29  5.2.3790.168  4,952,064  Win32k.sys
Windows Server 2003, x86-based versions
   Date         Time   Version       Size       File name
   -------------------------------------------------------
   28-Apr-2004  16:36  5.2.3790.168  1,812,480  Win32k.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 837583 - Last Review: July 24, 2007 - Revision: 4.10
APPLIES TO
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwinserv2003presp1fix KB837583

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