Několik osamocených procesů Csrss.exe způsobit problémy s výkonem na terminálový server se systémem Windows 2000 nebo Windows Server 2003

Překlady článku Překlady článku
ID článku: 837585 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

V počítači se systémem Microsoft Windows 2000 Server nebo počítač se systémem Microsoft Windows Server 2003, je spuštěna Terminálová služba, můžete zaznamenat následující příznaky:
  • Server bude pomalý a reagovat. Nakonec je Nelze vytvořit nové relace Terminálové služby.
  • Používáte-li zobrazit spuštěné procesy Správce úloh můžete vidět, že jsou k dispozici několik osamocených procesů Csrss.exe. Neexistují žádné Při zobrazení relací v odpovídající relace klienta Terminálové služby Správce Terminálové služby.
  • Nelze zastavit osamocené procesů Csrss.exe uvolnit prostředky serveru. Proto procesů Csrss.exe může pokračovat ve shromažďování až po restartování serveru uvolnit paměť a zdroje procesoru.
Pokud použijete opravu hotfix, která je popsána v Microsoft Článek znalostní báze 827350, může to pomoci snížit počet Csrss.exe procesy, ale stále dochází k problému.
827350 Klienti nemohou připojit k Terminálový server při Csrss.exe a Termsrv.exe dosahuje na 100 procent procesoru využití

Příčina

K problému dochází z důvodu regrese, která byla zaveden v systému Windows 2000 Service Pack 3 (SP3). Systém Windows 2000 SP3 obsahuje oprava, která zavádí objektu prostředí winstation dočasné proces Csrss.exe. Tato oprava je popsán v následujících Microsoft Knowledge Base článek:
261322 STOP 0x0000001E chybová zpráva při tisknout z klienta služby Terminal Services systému Windows 2000
Pokud nejsou uvolněny prostředí winstation dočasných objektů správně může nastat příznaky, které jsou popsány výše v článek.

Řešení

Informace o opravě hotfix

Systém Windows Server 2003

Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze problém popsaný v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud není přísně tento problém, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix je k dispozici ke stažení, je sekce "Hotfix stažení k dispozici" v horní části tohoto článku. Pokud tento oddíl není uveden, obraťte se na podporu a služby zákazníkům společnosti, jak získat opravu hotfix.

Poznámka: Pokud nastanou další problémy nebo řešení potíží je vyžadován, pravděpodobně vytvořit samostatnou žádost. Výdaje na technickou podporu se bude u dalších otázek a problémů, které nelze vyřešit určitou konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující Web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix je k dispozici. Pokud váš jazyk není uveden, je to, protože oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Neexistují žádné požadavky.

Požadavek na restartování

Po instalaci této opravy hotfix, je nutné restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souboru

Anglická verze této opravy hotfix má atributy souborů (nebo novější), jsou uvedeny v následující tabulce. Data a časy jednotlivých souborů jsou uvedeny v koordinovaný světový čas (UTC). Při zobrazení informací o souboru, je převeden na místní čas. Pomocí vyhledat rozdíl mezi místním časem a časem UTC naleznete Časové pásmo Karta v nástroji datum a čas v okně Ovládací panely.
Windows Server 2003 verze x 86
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Winsrv.dll5.2.3790.170291,8404-Května 2004.23: 28x 86

Windows Server 2003 pro počítače s procesory Itanium
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatforma
Winsrv.dll5.2.3790.170764,9284-Května 2004.08: 22IA-64

Systém Windows 2000

Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze problém popsaný v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud není přísně tento problém, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix je k dispozici ke stažení, je sekce "Hotfix stažení k dispozici" v horní části tohoto článku. Pokud tento oddíl není uveden, obraťte se na podporu a služby zákazníkům společnosti, jak získat opravu hotfix.

Poznámka: Pokud nastanou další problémy nebo řešení potíží je vyžadován, pravděpodobně vytvořit samostatnou žádost. Výdaje na technickou podporu se bude u dalších otázek a problémů, které nelze vyřešit určitou konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující Web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix je k dispozici. Pokud váš jazyk není uveden, je to, protože oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Chcete-li nainstalovat tuto opravu hotfix, musí být v počítači nainstalována aktualizace Windows 2000 Service Pack 3 (SP3).

Požadavek na restartování

Po instalaci této opravy hotfix, je nutné restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souboru

Anglická verze této opravy hotfix má atributy souborů (nebo novější), jsou uvedeny v následující tabulce. Data a časy jednotlivých souborů jsou uvedeny v koordinovaný světový čas (UTC). Při zobrazení informací o souboru, je převeden na místní čas. Pomocí vyhledat rozdíl mezi místním časem a časem UTC naleznete Časové pásmo karty v Datum a čas Chcete-li zobrazit položky v Ovládacích panelech.
Zmenšit tuto tabulkuRozšířit tuto tabulku
Název souboruVerze souboruVelikost souboruDatumČasPlatformaVětev
Basesrv.dll5.0.2195.682442,25624. Března 200402: 17x 86Není k dispozici
Program Cmd.exe5.0.2195.6824236,30421. Září 200300: 45x 86Není k dispozici
Gdi32.dll5.0.2195.6660233,74419. Června 200320: 05x 86Není k dispozici
Kernel32.dll5.0.2195.6897742,16024. Března 200402: 17x 86Není k dispozici
MPR.dll5.0.2195.682454,54424. Března 200402: 17x 86Není k dispozici
Soubor Msgina.dll5.0.2195.6958335,12013. Července 200421: 25x 86Není k dispozici
Rdpwd.sys5.0.2195.689290,26424. Března 200402: 17x 86Není k dispozici
Sp3res.dll5.0.2195.69355,887,4884. Června 200423: 13x 86Není k dispozici
User32.dll5.0.2195.6897403,21624. Března 200402: 17x 86Není k dispozici
Userenv.dll5.0.2195.6794385,80805. Srpna 200322: 14x 86Není k dispozici
Win32k.sys5.0.2195.69581,631,76010. Července 200405: 36x 86Není k dispozici
Winlogon.exe5.0.2195.6898181,52011. Března 200402: 37x 86Není k dispozici
Winsrv.dll5.0.2195.6958244,49613. Července 200421: 25x 86Není k dispozici
Kernel32.dll5.0.2195.6897742,16024. Března 200402: 17x 86UNIPROC
Win32k.sys5.0.2195.69581,631,76010. Července 200405: 36x 86UNIPROC
Winsrv.dll5.0.2195.6958244,49613. Července 200421: 25x 86UNIPROC

Prohlášení

Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro".

Tato funkce byla poprvé zahrnuta v aktualizaci Windows Server 2003 Service Pack 1.

Další informace

Další informace o balíčcích oprav hotfix jsou název, klepněte na tlačítko naleznete v následujících článcích znalostní báze společnosti Microsoft:
816915Nové schéma názvů pro Microsoft Balíčcích oprav hotfix pro systém Windows
824684 Popis standardní terminologie používané při popisu softwaru společnosti Microsoft aktualizace

Technická podpora pro 64bitové verze systému Microsoft Windows

Pokud váš hardware dodán s Microsoft Windows x 64 edition, již nainstalována, výrobce hardwaru poskytuje technickou podporu a odbornou pomoc pro systém Windows x 64 edition. V tomto případě výrobce hardwaru poskytuje podporu, protože systém Windows XP x 64 byl součástí dodaného hardwaru. Výrobce hardwaru mohl upravit instalaci systému Windows x 64 edition pomocí jedinečných součástí. Jedinečné součásti může zahrnout specifické ovladače zařízení a volitelná nastavení, aby maximalizoval výkon hardwaru. Společnost Microsoft poskytne nápomocna v případě, že potřebujete technickou pomoc s Windows x 64 edition. Pravděpodobně však přímo od výrobce. Výrobce je tím nejkvalifikovanějším pro poskytnutí odborné pomoci k softwaru, který instaloval na hardware. Pokud jste zakoupili samostatně systému Windows x 64 edition, jako je například Microsoft Windows Server 2003 x 64 edition, poskytne technickou podporu společnosti Microsoft.

Informace o systému Microsoft Windows XP Professional x 64 Edition navštivte následující Web společnosti Microsoft:
http://www.microsoft.com/windowsxp/64bit/default.mspx
Informace o systému-verze x 64 systému Microsoft Windows Server 2003 navštivte následující Web společnosti Microsoft:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx

Vlastnosti

ID článku: 837585 - Poslední aktualizace: 22. května 2011 - Revize: 6.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Klíčová slova: 
kbautohotfix kbhotfixserver kbbug kbfix kbqfe kbwin2000presp5fix kbmt KB837585 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:837585

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com