Sysprep 映像中未安装的硬件设备

文章翻译 文章翻译
文章编号: 837691 - 查看本文应用于的产品
展开全部 | 关闭全部

症状

当您使用 Microsoft 系统准备工具 (Sysprep) 将 Microsoft Windows XP 的 Sysprep 映像部署到一个计算机某些设备可能会出现在设备管理器中为未安装该设备的驱动程序存在于由该 Sysprep.inf 中 oempnpdriverspath 项设置的路径的甚至时。

如果您双击设备在设备管理器中,您在 常规 选项卡上 设备状态 框中收到以下错误消息:
未安装此设备的驱动程序。(代码 28)
此外,在设备管理器中查看它时,该设备的旁边将出现一个黄色的感叹号。

原因

当您在计算机上创建 Sysprep 映像,然后将该映像部署到具有相同类型的硬件的计算机时,会出现此问题。没有安装其驱动程序的任何设备将 Sysprep 映像的部署后保持此状态。由 Sysprep 使用的 minisetup 程序不会执行所有设备的一个完整插即用重新枚举。

替代方法

运行 Sysprep 准备计算机进行复制之前删除设置为代码 28 的设备管理器中的任何设备。若要去这些设备,请按照下列步骤操作:
  1. 单击 开始,然后单击 控制面板
  2. 双击 管理工具
  3. 双击 计算机管理
  4. 单击 设备管理器
  5. 找到有黄色惊叹号标记旁边的任何设备。
  6. 请验证设备的设备状态有在本文"症状"一节中列出的错误消息。 若要这样做:
    1. 用鼠标右键单击设备图标。
    2. 单击 属性
    3. 设备状态 框列出了错误消息:
      未安装此设备的驱动程序。(代码 28)
  7. 用鼠标右键单击设备图标,单击 卸载,然后单击 确定
对于具有代码 28 错误消息的每个设备重复步骤 5 至 7。

属性

文章编号: 837691 - 最后修改: 2004年3月16日 - 修订: 1.2
这篇文章中的信息适用于:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
关键字:?
kbmt kbprb KB837691 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 837691
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com