Aparece el mensaje de error "No se encontró en el sistema la versión esperada del producto" cuando instala el Service Pack 3 de Office XP

Seleccione idioma Seleccione idioma
Id. de artículo: 837826 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

cuando intenta actualizar Microsoft Office XP a Microsoft Office XP Service Pack 3 (SP3), recibirá un mensaje de error que indica que no se encontró la versión esperada. Para resolver este problema, instale la versión de archivo completo de Office XP SP3.

Síntomas

Cuando intente instalar el Service Pack 3 de Office XP (como un administrador de red) o uno de los usuarios, puede recibir el siguiente mensaje de error:
No se encontró en el sistema la versión del producto que se esperaba.

Causa

Este problema puede ocurrir cuando se cumplen las condiciones siguientes:
  • Si tiene Microsoft Office XP Service Pack 1 o Microsoft Office XP Service Pack 2 instalado y actualizado desde un punto de instalación administrativa.
  • Intenta actualizar la instalación de Office XP desde uno de los siguientes sitios Web de Microsoft: Nota Las actualizaciones de Microsoft Office XP desde estos sitios Web de Microsoft son actualizaciones binarias.

Solución

Para resolver este problema, utilice uno de los métodos siguientes.

Método 1: Utilizar la actualización de archivo completo de Office XP Service Pack 3

Se puede utilizar el archivo completo de Office XP Service Pack 3 actualización para actualizar su punto de instalación administrativa o un equipo individual (cliente) que tiene instalado Office XP.

Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
832671Descripción del Service Pack 3 de Microsoft Office XP

Método 2: Utilizar un nuevo punto instalación administrativa de nivel de base de RTM

Si, como el Administrador de red, ya no desea que mantener el punto de instalación administrativa de Office XP con service Pack actuales y las actualizaciones, crear un nuevo punto de instalación de Office XP en la base de RTM de Office XP nivel.

Después de instalar Office XP en un equipo cliente desde el nuevo punto de instalación administrativa de Office XP RTM de base, puede utilizar luego utilice la actualización binaria de uno de los sitios Web de Microsoft que aparece en la sección "Causa" de este artículo.

Para obtener información adicional acerca de cómo crear un nuevo punto de instalación administrativo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
304953Cómo: Cómo implementar Office XP a través de una red

Más información

Actualizaciones de cliente, como Office XP Service Pack 2 y versiones anteriores, podrían ser instaladas correctamente en una instalación de cliente de Office XP si la actualización administrativa de archivo completo se había instalada en el punto de instalación administrativa y se actualizó el equipo cliente desde el punto de instalación administrativa.

Con Microsoft Office XP Service Pack 3, Microsoft cambió el modo de que actualización binaria se creó para que instale la actualización de cliente (binario) de Office XP Service Pack 3 directamente sobre la versión de nivel de RTM (10.0.2627) de Office XP.

Debido a este cambio de la actualización binaria Pack 3 de Office XP no se instalará correctamente en un equipo que tiene Office XP Service Pack 1 (SP1) o de Office XP Service Pack 2 (SP2) instalado desde un punto de instalación administrativa y recached en el equipo local (cliente). Este problema se produce porque Office XP Service Pack 3 debe tiene versión 10.0.2627 (nivel RTM) de Office XP instalado.

Nota La actualización de archivo completo de Office XP Service Pack 3 (SP3) instalará correctamente a través de un nivel de RTM de Office XP, Office XP Service Pack 1 (SP1) y Office XP Service Pack 2 (SP2) cuando se aplica el SP3 de Office a un punto de instalación administrativa.

Notas acerca de la solución de problemas

El registro de Ohotfix detallado siguiente muestra un error 2749 con un código de error de 1642 al final de la entrada del registro:
MSI (s) (F8:64): Looking for storage transform: 7TTo7U
MSI (s) (F8:64): Validating transform '7TTo7U' with validation bits 0x122
MSI (s) (F8:64): Note: 1: 2749 2: 7TTo7U 3: C:\WINDOWS\Installer\3b569.msi 4: 10.0.2627.01 5: 10.0.4330.0 
MSI (s) (F8:64): 1: 2749 2: 7TTo7U 3: C:\WINDOWS\Installer\3b569.msi 4: 10.0.2627.01 5: 10.0.4330.0 
(Expected version is 10.0.2627, version found is 10.0.4330.0.)
la siguiente entrada del registro Ohotfix muestra código de error 1642 al final del registro:
The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded 
may be missing, or the upgrade patch may update a different version of the program. Verify that the program 
to be upgraded exists on your computer and that you have the correct upgrade patch.
C:\DOCUME~1\username.NOR\LOCALS~1\Temp\IXP000.TMP\MAINSP3op.msp
MSI (s) (F8:64): Attempting to delete file C:\WINDOWS\Installer\22879.msp
MSI (s) (F8:64): MainEngineThread is returning 1642
MSI (c) (50:40): Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  
Counter after decrement: -1
MSI (c) (50:40): MainEngineThread is returning 1642
Para obtener información adicional acerca de cómo utilizar los archivos de registro de instalación de Microsoft Office XP para solucionar problemas de instalación de Office, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
296603Cómo utilizar un archivo de registro del programa de instalación de Office XP para solucionar problemas de instalación en Office XP

Referencias

Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
325671OFFXP: Introducción A Office XP Service Pack 2

307843OFFXP: Introducción A Office XP Service Pack 1

283686OFFXP: Programa de instalación modificadores de línea de comandos de Office XP

Propiedades

Id. de artículo: 837826 - Última revisión: martes, 9 de enero de 2007 - Versión: 1.11
La información de este artículo se refiere a:
  • Microsoft Office XP Professional Edition
  • Microsoft Office XP Small Business Edition
  • Microsoft Office XP Standard Edition
  • Microsoft Office XP Students and Teachers
  • Microsoft Office XP Developer Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft Outlook 2002 Standard
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Palabras clave: 
kbmt kbtshoot kberrmsg kbprb KB837826 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 837826

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com