ข้อผิดพลาด "รุ่นผลิตภัณฑ์ที่คาดไว้ไม่พบบนระบบของคุณ" ข้อความเมื่อคุณติดตั้ง Office XP Service Pack 3

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 837826 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

สรุป

เมื่อคุณพยายามที่จะปรับปรุง Microsoft Office XP ไปยัง Microsoft Office XP Service Pack 3 (SP3), คุณได้รับข้อความแสดงข้อผิดพลาดที่แจ้งว่า ไม่พบรุ่นที่คาดไว้ เมื่อต้องการแก้ไขปัญหานี้ ติดตั้งรุ่นเต็มแฟ้มของ Office XP SP3

อาการ

เมื่อคุณ (เป็นผู้ดูแลเครือข่าย) หรือของผู้ใช้ของคุณพยายามติดตั้ง Office XP SP3 คุณอาจได้รับข้อความแสดงข้อความแสดงข้อผิดพลาดต่อไปนี้:
ไม่พบรุ่นผลิตภัณฑ์ที่คาดไว้บนระบบของคุณ

สาเหตุ

ปัญหานี้จะเกิดขึ้นเมื่อเงื่อนไขต่อไปนี้เป็นจริง::
  • คุณมี Microsoft Office XP Service Pack 1 หรือติดตั้ง Microsoft Office XP Service Pack 2 และจากจุดการจัดการการติดตั้งการปรับปรุง
  • คุณพยายามปรับปรุงการติดตั้ง Office XP ของคุณจากหนึ่งของเว็บไซต์ต่อไปนี้ของ Microsoft:หมายเหตุ:โปรแกรมปรับปรุง Microsoft Office XP จากเหล่านี้เว็บไซต์ของ Microsoft มีการปรับปรุงไบนารี

การแก้ไข

เมื่อต้องการแก้ไขปัญหา ให้ใช้วิธีการอย่างใดอย่างหนึ่งต่อไปนี้

วิธีที่ 1: ใช้การปรับปรุงแฟ้มเต็มของ Office XP Service Pack 3

คุณสามารถใช้ Office XP Service Pack 3 เต็มแฟ้มโปรแกรมปรับปรุงการปรับปรุงจุดการติดตั้งที่ผู้ดูแลระบบของคุณหรือคอมพิวเตอร์แต่ละข้อ (ไคลเอนต์) ที่มีการติดตั้ง Office XP ได้

สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
832671คำอธิบายของชุด XP บริการของ Microsoft Office 3

วิธีที่ 2: ใช้จุดการติดตั้งผู้ดูแลระบบระดับฐาน RTM ใหม่

ถ้าคุณ เป็นผู้ดูแลเครือข่าย ไม่ต้องการเก็บรักษาจุดในการจัดการการติดตั้ง Office XP ของคุณกับเซอร์วิสแพ็คปัจจุบันและการปรับปรุง สร้างจุดการติดตั้ง Office XP ใหม่ใน Office XP RTM-ฐานระดับ

หลังจากที่คุณติดตั้ง Office XP ไปยังคอมพิวเตอร์ไคลเอนต์จากจุดในการจัดการการติดตั้ง Office XP RTM-ฐานใหม่ของคุณ คุณสามารถใช้ นั้นใช้การปรับปรุงไบนารีจากหนึ่งในเว็บไซต์ของ Microsoft ที่แสดงไว้ในส่วน "การทำให้เกิด" ของบทความนี้

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสร้างจุดการติดตั้งการดูแลใหม่ คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
304953HOW TO: การปรับใช้ Office XP ผ่านเครือข่ายได้อย่างไร

ข้อมูลเพิ่มเติม

การปรับปรุงไคลเอ็นต์ เช่น Office XP Service Pack 2 และรุ่นก่อนหน้า นี้ อาจถูกติดเสร็จเรียบร้อยแล้วตั้งในการติดตั้งไคลเอ็นต์ Office XP ถ้าได้รับการติดตั้งการปรับปรุงการดูแลระบบแฟ้มแบบเต็มในจุดการติดตั้งสำหรับผู้ดูแล และได้รับการปรับปรุงคอมพิวเตอร์ไคลเอนต์จากจุดการติดตั้งสำหรับผู้ดูแล

ด้วย Microsoft Office XP Service Pack 3, Microsoft เปลี่ยนแปลงวิธีเขียนโปรแกรมปรับปรุงไบนารีเพื่อให้การปรับปรุงไคลเอ็นต์ (ไบนารี) Office XP Service Pack 3 จะติดตั้งโดยตรงผ่านรุ่น RTM ระดับ (10.0.2627) ของ Office XP

Because of this change, the Office XP Service Pack 3 binary update will not install successfully on a computer that has either Office XP Service Pack 1 (SP1) or Office XP Service Pack 2 (SP2) installed from an administrative installation point and recached on the local computer (client). This problem occurs because Office XP Service Pack 3 must have version 10.0.2627 (RTM-level) of Office XP installed.

หมายเหตุ:The Office XP Service Pack 3 (SP3) full file update will install correctly over an Office XP RTM-level, Office XP Service Pack 1 (SP1), and Office XP Service Pack 2 (SP2) when Office SP3 is applied to an administrative installation point.

Troubleshooting notes

The following Ohotfix verbose log shows an error 2749 with an error code of 1642 at the end of the log entry:
MSI (s) (F8:64): Looking for storage transform: 7TTo7U
MSI (s) (F8:64): Validating transform '7TTo7U' with validation bits 0x122
MSI (s) (F8:64): Note: 1: 2749 2: 7TTo7U 3: C:\WINDOWS\Installer\3b569.msi 4: 10.0.2627.01 5: 10.0.4330.0 
MSI (s) (F8:64): 1: 2749 2: 7TTo7U 3: C:\WINDOWS\Installer\3b569.msi 4: 10.0.2627.01 5: 10.0.4330.0 
(Expected version is 10.0.2627, version found is 10.0.4330.0.)
The following Ohotfix log entry shows error code 1642 at the end of the log:
The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded 
may be missing, or the upgrade patch may update a different version of the program. Verify that the program 
to be upgraded exists on your computer and that you have the correct upgrade patch.
C:\DOCUME~1\username.NOR\LOCALS~1\Temp\IXP000.TMP\MAINSP3op.msp
MSI (s) (F8:64): Attempting to delete file C:\WINDOWS\Installer\22879.msp
MSI (s) (F8:64): MainEngineThread is returning 1642
MSI (c) (50:40): Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  
Counter after decrement: -1
MSI (c) (50:40): MainEngineThread is returning 1642
For additional information about how to use the Microsoft Office XP installation log files to troubleshoot Office Setup issues, click the following article number to view the article in the Microsoft Knowledge Base:
296603วิธีการใช้แฟ้มบันทึกของโปรแกรมติดตั้ง XP Office เป็นการแก้ไขปัญหาการติดตั้งใน Office XP

ข้อมูลอ้างอิง

สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
325671OFFXP: ภาพรวมของ Office XP Service Pack 2

307843OFFXP: ภาพรวมของ Office XP Service Pack 1

283686OFFXP: เซ็ตอัพสวิตช์ที่เกี่ยวกับบรรทัดคำสั่งสำหรับ Office XP

คุณสมบัติ

หมายเลขบทความ (Article ID): 837826 - รีวิวครั้งสุดท้าย: 14 กันยายน 2554 - Revision: 4.0
ใช้กับ
  • Microsoft Office XP Professional Edition
  • Microsoft Office XP Small Business Edition
  • Microsoft Office XP Standard Edition
  • Microsoft Office XP Developer Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Keywords: 
kbtshoot kberrmsg kbprb kbmt KB837826 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:837826

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com