Your Windows 2000 client computer cannot perform a DNS dynamic update

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Article ID: 838151 - View products that this article applies to.
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SYMPTOMS

When a Microsoft Windows 2000 DNS client submits a dynamic update, the update may not be completed successfully.

A Network Monitor trace returns an error message that is similar to the following after the client tries to resolve the IP address of the master DNS server:
Server Failure

CAUSE

This problem occurs if all the following conditions are true:
  • The master DNS server that hosts the Active Directory domain resides in a different DNS domain from the Active Directory directory service.
  • The master DNS server does not host the zone of the domain that it belongs to.
  • Recursion is disabled for the master DNS server.
In this scenario, the DNS server that the client computer sends the update to cannot resolve its own name, and therefore the "Server Failure" error occurs. The client tries to resolve both of the following elements from the DNS server that it is trying to update:
  • The start of authority (SOA) record of the DNS zone.
  • The IP address of the master DNS server.
The client tries to do this even though it has already obtained this information from the DNS server that is configured as its primary DNS server.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version             Size   File name
-----------------------------------------------------------
07-Apr-2004  01:26  5.0.2195.6920     136,464  Dnsapi.dll       
24-Mar-2004  02:17  5.0.2195.6876      92,432  Dnsrslvr.dll    

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The SOA record indicates the DNS server that either originally created it or that is now the primary server for the zone. The SOA record is also used to store other properties, such as version information and timings that affect zone renewal or expiration. These properties affect how frequently transfers of the zone are performed between servers that are authoritative for the zone. For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 838151 - Last Review: October 26, 2013 - Revision: 2.7
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB838151

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