FIX: A blank page is returned when you request a Content Management Server 2002 resource that you do not have permissions to access

Article translations Article translations
Article ID: 838231 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When you try to request a Microsoft Content Management Server resource that you do not have permissions to access, a blank page may be returned instead of the Microsoft Internet Information Services (IIS) custom 401 HTTP error page.

CAUSE

This problem occurs when you configure IIS, and you have Anonymous access enabled and Integrated Authentication access disabled. When these conditions are true, Content Management Server will handle the request and returns a Content Management Server custom 401 HTTP error page. The Content Management Server custom 401 HTTP error page does not have a body and is displayed as a blank page in Microsoft Internet Explorer.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must first install Content Management Server 2002 Service Pack 1 (SP1).

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------  
   25-Feb-2004  23:41  5.0.2523.0         82,944  Reauthfilt.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This hotfix changes the way that Content Management Server returns a 401 HTTP error page when Anonymous access is enabled and Integrated Authentication is disabled. Therefore, when this problem occurs, Content Management Server now lets IIS return the custom 401 HTTP error page that was configured in IIS. This change enables administrators of Content Management Server-based Web sites to create a custom 401 HTTP error page that can redirect the user to a logon page or to display a friendly error message in the body of the page.

For more information about customizing HTTP error messages in IIS, visit the following Microsoft Developer Network (MSDN) Web site:
http://msdn2.microsoft.com/en-us/library/ms525983.aspx

Properties

Article ID: 838231 - Last Review: November 15, 2007 - Revision: 3.3
APPLIES TO
  • Microsoft Content Management Server 2002
  • Microsoft Content Management Server 2002
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbcontentmgtserv2002presp2fix KB838231

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com