Help and Support
 

powered byLive Search
Hotfix Download Available

FIX: The POSIX subsystem for Interix does not start successfully after Windows Server 2003 Service Pack 1 (SP1) is installed

Article ID:838250
Last Review:December 3, 2007
Revision:2.8
On This Page

SYMPTOMS

In Microsoft Windows Server 2003, the Portable Operating System Interface for UNIX (POSIX) subsystem for Interix does not start successfully after you install Windows Server 2003 with Service Pack 1 (SP1) or a later version.

Back to the top

CAUSE

This problem occurs because of a change that was made to Windows Server 2003 that made Windows Server 2003 incompatible with the POSIX subsystem that is included with Microsoft Windows Services for UNIX.

Back to the top

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Services for UNIX 3.0
   Date         Time   Version      Size     File name
   ---------------------------------------------------
   25-Feb-2004  22:26  7.0.1701.33  131,072  Posix.exe        
   25-Feb-2004  22:25  7.0.1701.33  647,168  Psxss.exe        
Windows Services for UNIX 3.5
   Date         Time   Version     Size     File name
   --------------------------------------------------
   04-Mar-2004  18:56  8.0.1969.2  763,904  Psxss.exe        

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

For more information about Windows Services for UNIX, visit the following Microsoft Web site:
http://www.microsoft.com/windows/sfu/ (http://www.microsoft.com/windows/sfu/)
Note The Windows Services for UNIX 3.5 download that is available at this Web site has been updated to contain this hotfix.

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

Back to the top


APPLIES TO
Microsoft Windows Services for UNIX 3.5
Microsoft Windows Services for UNIX 3.0 Standard Edition
Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Microsoft Windows Small Business Server 2003 Standard Edition

Back to the top

Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe KB838250

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.