Menus de aplicação de ambiente de trabalho são apresentados incorrectamente se um processo exceder a quota de objectos GDI no Windows XP ou no Windows 2000

Traduções de Artigos Traduções de Artigos
Artigo: 838283 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Menus de aplicação e os menus de contexto incorrectamente são apresentados para outras aplicações quando um processo exceder a respectiva interface de dispositivos gráficos (GDI) objecto quota. (A quota de objecto predefinida é 10.000.) O problema persistir, mesmo depois do processo termina e é especialmente perceptível com tridimensionais (3D) menus e com sombreado.

Nota Depois do processo excede a quota de objectos GDI, o processo pode apresentar mais do que simplesmente menus incorrectamente. O processo inadvertidamente também pode escrever sobre ambiente de trabalho do Windows. Deve sair do processo antes de tentar resolver estes problemas.

Causa

Quando uma aplicação excede a quota de objectos GDI, a aplicação já não pode atribuir objectos GDI. No entanto, neste cenário, a aplicação continua a funcionar como se pode atribuir objectos e inicia incorrectamente objectos de desenho no ecrã. Um efeito adicional deste comportamento é que os menus do sistema operativo não processam a situação correctamente. Menus para outras aplicações também são afectados.

Resolução

Para recuperar a visualização de ambiente de trabalho do Windows correcta, utilize um dos seguintes métodos:

Método 1

  1. Sair da aplicação que excedeu a quota de objectos GDI.
  2. Prima CTRL + ALT + DELETE ou prima o logótipo do Windows + L para mudar para a janela de início de sessão.
  3. Clique em Cancelar , se tiver sessão iniciada num domínio ou clique o nome de utilizador para regressar ao ambiente de trabalho.

Método 2

  1. Sair da aplicação que excedeu a quota de objectos GDI.
  2. Clique com o botão direito do rato a barra de tarefas e, em seguida, clique em Mostrar o ambiente de trabalho .
  3. Iniciar uma aplicação, tal como o Internet Explorer e, em seguida, mude para a apresentação de ecrã inteiro premindo F11.

Microsoft Windows XP

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente do Windows XP. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322389Como obter o Windows XP service pack mais recente

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.
Pré-requisitos
Existem não pré-requisitos para instalar esta correcção.
Requisito de reinício
Não é necessário reiniciar o computador depois de aplicar esta correcção.
Informações sobre substituição de correcções
Esta correcção não substitui quaisquer outras correcções.
Informações do ficheiro
A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item Data e hora no painel de controlo.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   02-Apr-2004  14:05  5.1.2600.1502  1,797,120  Win32k.sys
   09-Jan-2004  21:11  5.4.1.0          140,800  Spuninst.exe
   09-Jan-2004  14:46  5.4.1.0            6,656  Spmsg.dll

Microsoft Windows 2000

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.
Pré-requisitos
Terá de ter o Microsoft Windows 2000 Service Pack 3 (SP3) ou posterior para instalar esta correcção. Para obter mais informações sobre como obter o Windows 2000 service pack mais recente, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
260910Como obter o Windows 2000 service pack mais recente
Requisito de reinício
Não é necessário reiniciar o computador depois de aplicar esta correcção.
Informações sobre substituição de correcções
Esta correcção não substitui quaisquer outras correcções.
Informações do ficheiro
A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item Data e hora no painel de controlo.
   Date         Time   Version           Size    File name
   ----------------------------------------------------------
   23-Mar-2004  15:17  5.0.2195.6892     90,264  Rdpwd.sys
   05-Apr-2004  23:25  5.0.2195.6922  1,630,640  Win32k.sys
   23-Mar-2004  18:17  5.0.2195.6897    742,160  Kernel32.dll
   23-Mar-2004  18:17  5.0.2195.6898    242,448  Gdi32.dll
   05-Apr-2004  09:26  5.4.15.0           6,656  Spmsg.dll
   05-Aug-2003  14:14  5.0.2195.6794    385,808  Userenv.dll
   10-Mar-2004  18:37  5.0.2195.6898    181,520  Winlogon.exe
   23-Mar-2004  18:17  5.0.2195.6824     42,256  Basesrv.dll
   05-Feb-2004  12:18  5.0.2195.6896  5,869,056  Sp3res.dll
   23-Mar-2004  18:17  5.0.2195.6897    403,216  User32.dll
   23-Mar-2004  18:17  5.0.2195.6895    335,120  Msgina.dll
   15-Nov-2001  15:27                     5,149  Empty.cat
   05-Apr-2004  09:27  5.4.15.0         158,208  Spuninst.exe
   23-Mar-2004  18:17  5.0.2195.6824     54,544  Mpr.dll
   20-Sep-2003  16:45  5.0.2195.6824    236,304  Cmd.exe
   25-Sep-2003  10:08  5.0.2195.6826    243,984  Winsrv.dll 


Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Windows XP Este problema foi corrigido pela primeira vez no Microsoft Windows XP Service Pack 2.

Mais Informação

Pode utilizar o Gestor de tarefas do Windows para monitorizar os objectos GDI de um processo. Para efectuar este procedimento:
  1. Inicie o Gestor de tarefas do Windows.
  2. Clique em Ver , clique em Seleccionar colunas e, em seguida, faça clique sobre Objectos GDI botão.
Também pode monitorizar os objectos GDI com a ferramenta Gdiobj.exe. Para obter esta ferramenta, visite o seguinte Web site:
http://www.fengyuan.com/download.html

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft
Nota Este problema foi corrigido pela primeira vez no Microsoft Windows Server 2003 Service Pack 1 (SP1). As informações neste artigo aplicam-se também para Microsoft Windows Server 2003, Standard Edition (x 86 de 32 bits) e Microsoft Windows Server 2003, Enterprise Edition (x 86 de 32 bits).

Propriedades

Artigo: 838283 - Última revisão: 29 de agosto de 2007 - Revisão: 5.2
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Enterprise Edition
Palavras-chave: 
kbmt kbautohotfix kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug kbqfe kbhotfixserver KB838283 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 838283

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com