Menus de aplicativo de área de trabalho são exibidos incorretamente se um processo exceder sua cota de objeto GDI no Windows XP ou no Windows 2000

Traduções deste artigo Traduções deste artigo
ID do artigo: 838283 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Aplicativo menus e menus de contexto são exibidos incorretamente para outros aplicativos quando um processo exceder sua interface gráfica de dispositivo (GDI) objeto cota. (A cota de objeto padrão é 10.000). O problema persistir mesmo após o processo é encerrado e é especialmente notável com tridimensionais (3D) menus e com sombreamento.

Observação Após o processo excede sua cota de objeto GDI, o processo pode exibir mais do que apenas menus incorretamente. O processo pode também inadvertidamente gravar pela área de trabalho da Windows. Você deve sair do processo antes de tentar resolver esses problemas.

Causa

Quando um aplicativo excede sua cota de objeto GDI, o aplicativo não pode alocar objetos GDI. No entanto, nesse cenário, o aplicativo continuará a operar como se ele pode alocar objetos e começa pintura objetos na tela incorretamente. Um efeito adicional desse comportamento é que os menus do sistema operacional não manipulam a situação corretamente. Menus para outros aplicativos também são afetados.

Resolução

Para obter novamente a exibição da área de trabalho correto do Windows, use um dos seguintes métodos:

Método 1

  1. Sai do aplicativo ultrapassou a cota do objeto GDI.
  2. Pressione CTRL + ALT + DELETE ou pressione logotipo do Windows + L para alternar para a janela de logon.
  3. Clique em Cancelar se você estiver conectado a um domínio, ou clique em seu nome de usuário para retornar a área de trabalho.

Método 2

  1. Sai do aplicativo ultrapassou a cota do objeto GDI.
  2. Clique com o botão direito do mouse a barra de tarefas e clique em Mostrar a área de trabalho .
  3. Iniciar um aplicativo, como o Internet Explorer e em seguida, alterne para a exibição de tela inteira pressionando F11.

Microsoft Windows XP

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows XP. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322389Como obter o service pack mais recente do Windows XP

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Não há nenhum pré-requisito para instalar esse hotfix.
Requisitos de reinicialização
Não é necessário reiniciar o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui outros hotfixes.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   02-Apr-2004  14:05  5.1.2600.1502  1,797,120  Win32k.sys
   09-Jan-2004  21:11  5.4.1.0          140,800  Spuninst.exe
   09-Jan-2004  14:46  5.4.1.0            6,656  Spmsg.dll

Microsoft Windows 2000

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Executando o Microsoft Windows 2000 Service Pack 3 (SP3) ou posterior para instalar esse hotfix. Para obter mais informações sobre como obter o service pack mais recente do Windows 2000, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
260910Como obter o service pack mais recente do Windows 2000
Requisitos de reinicialização
Não é necessário reiniciar o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui outros hotfixes.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
   Date         Time   Version           Size    File name
   ----------------------------------------------------------
   23-Mar-2004  15:17  5.0.2195.6892     90,264  Rdpwd.sys
   05-Apr-2004  23:25  5.0.2195.6922  1,630,640  Win32k.sys
   23-Mar-2004  18:17  5.0.2195.6897    742,160  Kernel32.dll
   23-Mar-2004  18:17  5.0.2195.6898    242,448  Gdi32.dll
   05-Apr-2004  09:26  5.4.15.0           6,656  Spmsg.dll
   05-Aug-2003  14:14  5.0.2195.6794    385,808  Userenv.dll
   10-Mar-2004  18:37  5.0.2195.6898    181,520  Winlogon.exe
   23-Mar-2004  18:17  5.0.2195.6824     42,256  Basesrv.dll
   05-Feb-2004  12:18  5.0.2195.6896  5,869,056  Sp3res.dll
   23-Mar-2004  18:17  5.0.2195.6897    403,216  User32.dll
   23-Mar-2004  18:17  5.0.2195.6895    335,120  Msgina.dll
   15-Nov-2001  15:27                     5,149  Empty.cat
   05-Apr-2004  09:27  5.4.15.0         158,208  Spuninst.exe
   23-Mar-2004  18:17  5.0.2195.6824     54,544  Mpr.dll
   20-Sep-2003  16:45  5.0.2195.6824    236,304  Cmd.exe
   25-Sep-2003  10:08  5.0.2195.6826    243,984  Winsrv.dll 


Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Windows XP Esse problema foi corrigido primeiro no Microsoft Windows XP Service Pack 2.

Mais Informações

Você pode usar o Gerenciador de tarefas para monitorar os objetos GDI de um processo. Para fazer isso:
  1. Inicie o Gerenciador de tarefas do Windows.
  2. Clique em Exibir , clique em Selecionar colunas e, em seguida, clique em Objetos GDI botão.
Você também pode monitorar os objetos GDI com a ferramenta Gdiobj.exe. Para obter essa ferramenta, visite o seguinte site:
http://www.fengyuan.com/download.html

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software
Observação Esse problema foi corrigido primeiro no Microsoft Windows Server 2003 Service Pack 1 (SP1). As informações contidas neste artigo também se aplica a Microsoft Windows Server 2003, Standard Edition (x 86 de 32 bits) e Windows Server 2003, Enterprise Edition (x 86 de 32 bits).

Propriedades

ID do artigo: 838283 - Última revisão: quarta-feira, 29 de agosto de 2007 - Revisão: 5.2
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Palavras-chave: 
kbmt kbautohotfix kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug kbqfe kbhotfixserver KB838283 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 838283

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com