Artigo: 838428 - Última revisão: segunda-feira, 30 de Outubro de 2006 - Revisão: 2.4

"Não conseguiu iniciar serviço do procedimento Call (RPC, Remote Procedure Call) remoto. Erro 1058 "mensagem de erro quando iniciar manualmente o serviço chamada de procedimento remoto

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
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Sintomas

Quando tenta iniciar o serviço chamada de procedimento remoto manualmente, o serviço não é iniciado. Poderá receber uma mensagem de erro semelhante à seguinte:
Não foi possível iniciar o serviço de chamada de procedimento remoto (RPC). Erro 1058: O serviço não pode ser iniciado porque está desactivado ou porque não existem dispositivos activados associados.

Causa

Este comportamento pode ocorrer se o serviço chamada de procedimento remoto é desactivado para o perfil de hardware que está a utilizar actualmente.

Resolução

Para resolver este comportamento, siga estes passos.

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows
  1. Reinicie o computador utilizando a opção de arranque de Modo de segurança . Para o fazer, siga estes passos:
    1. Reinicie o computador e quando o menu de arranque aparecer, prima F8.
    2. Em Menu de opções avançadas do Windows , seleccione Modo de segurança e, em seguida, prima ENTER.
    3. Quando o menu de arranque for novamente apresentado com as palavras "Modo de segurança" apresentadas na parte inferior do menu, seleccione o sistema operativo que pretende iniciar e, em seguida, prima ENTER.
  2. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  3. No painel da esquerda, localize e, em seguida, clique na seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\Current\System\CurrentControlSet\Enum\ROOT\LEGACY_RPCSS
  4. No menu ficheiro , clique em Exportar .
  5. Na caixa nome do ficheiro , escreva um nome para o ficheiro de registo.
  6. Na lista Guardar em , clique na localização onde pretende guardar o ficheiro de registo e, em seguida, clique em Guardar .
  7. Clique com o botão direito do rato LEGACY_RPCSS , clique em Eliminar e, na caixa de diálogo Confirmar eliminação de chaves , clique em Sim .

    Nota Não elimine qualquer uma das seguintes subchaves pode estar sob a subchave raiz:
    • MS_L2TPMINIPORT
    • MS_NDISWANIP
    • MS_PPPOEMINIPORT
    • MS_PPTPMINIPORT
    • MS_PSCHEDMP
    • MS_PTIMINIPORT
  8. Saia do Editor de registo.
  9. Reinicie o computador utilizando a opção de arranque Reiniciar o Windows normalmente .

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Palavras-chave: 
kbmt kbtshoot kbprb KB838428 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 838428  (http://support.microsoft.com/kb/838428/en-us/ )