ID do artigo: 838428 - Última revisão: segunda-feira, 30 de outubro de 2006 - Revisão: 2.4

"Não foi possível iniciar o procedimento Call (RPC) serviço remoto. Erro 1058 "erro mensagem ao iniciar manualmente o serviço chamada de procedimento remoto

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
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Sintomas

Ao tentar iniciar manualmente o serviço Remote Procedure Call, o serviço não inicia. Você receberá uma mensagem de erro semelhante à seguinte:
Não foi possível iniciar o serviço Remote Procedure Call (RPC). Erro 1058: O serviço não pode ser iniciado porque ele está desativado ou porque tem não dispositivos ativados associados a ele.

Causa

Esse comportamento pode ocorrer se o serviço chamada de procedimento remoto é desativado para o perfil de hardware que você está usando no momento.

Resolução

Para resolver esse comportamento, execute essas etapas.

importante Esta seção, método ou tarefa contém etapas que informam sobre como modificar o registro. No entanto, sérios problemas poderão ocorrer se você modificar o registro incorretamente. Por isso, certifique-se que você execute essas etapas cuidadosamente. Para proteção adicional, fazer backup do registro antes de modificá-lo. Em seguida, você pode restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup e restaurar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como fazer backup e restaurar o registro no Windows
  1. Reinicie seu computador usando a opção de inicialização Modo de segurança . Para fazer isso, execute as seguintes etapas:
    1. Reinicie o computador e quando o menu inicialização aparecer, pressione F8.
    2. No Menu Opções avançadas do Windows , selecione Modo de segurança e pressione ENTER.
    3. Quando o menu inicialização aparecer novamente com as palavras "Modo de segurança" exibida na parte inferior do menu, selecione o sistema operacional que você deseja iniciar e, em seguida, pressione ENTER.
  2. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  3. No painel esquerdo, localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles\Current\System\CurrentControlSet\Enum\ROOT\LEGACY_RPCSS
  4. No menu arquivo , clique em Exportar .
  5. Na caixa nome do arquivo , digite um nome para o arquivo de registro.
  6. Na lista Salvar em , clique no local onde você deseja salvar o arquivo de registro e, em seguida, clique em Salvar .
  7. Clique com o botão direito do mouse LEGACY_RPCSS , clique em Excluir e, na caixa de diálogo Confirmar exclusão da chave , clique em Sim .

    Observação Não exclua qualquer uma das seguintes subchaves que pode ser encontrado sob a subchave raiz:
    • MS_L2TPMINIPORT
    • MS_NDISWANIP
    • MS_PPPOEMINIPORT
    • MS_PPTPMINIPORT
    • MS_PSCHEDMP
    • MS_PTIMINIPORT
  8. Feche o Editor do Registro.
  9. Reinicie o computador usando a opção de inicialização Reiniciar o Windows normalmente .

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Palavras-chave: 
kbmt kbtshoot kbprb KB838428 KbMtpt
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