REVISIÓN: Los motores de voz no funcionan y recibe un mensaje de error cuando abrir Panel de control de voz

Seleccione idioma Seleccione idioma
Id. de artículo: 838659 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Resumen

cuando usa los motores de voz para realizar reconocimiento o síntesis, puede guardar el archivo CurrentUserLexicon del disco duro local para almacenar palabras adicionales. A veces, el archivo CurrentUserLexicon puede haberse dañado. Cuando esto ocurre, el motor de reconocimiento (SR) de voz y el motor de texto a voz (TTS) no funcionan. Este artículo describe las causas posibles y corrige el problema con un archivo de revisión.

Síntomas

El motor de reconocimiento (SR) de voz y el motor de texto a voz (TTS) no funcionan en las aplicaciones. Al abrir el panel de control de voz, puede recibir el mensaje siguiente:
No se puede realizar la tarea solicitada porque no se pudo crear el motor de voz necesarios. Seleccione un motor diferente o un dispositivo de audio diferente.

Causa

Actualmente, no se conoce la causa específica del problema. Sin embargo, las siguientes son posibles causas:
  • Un dispositivo de audio está configurado incorrectamente
  • Un perfil de grabación está dañado
  • Una base de datos usuario dañado léxico (CurrentUserLexicon)
Para determinar si CurrentUserLexicon está dañado, utilice un editor hexadecimal para abrir el archivo .dat que se encuentra en la carpeta siguiente:
\Documents and Settings\ UserName \Application Data\Microsoft\Speech\Files\UserLexicons
Si el archivo contiene valores de byte 0 x 00 sólo y no contiene otros datos de valores, es probable que se ha dañado la base de datos de léxico de usuario.

Solución

Para evitar este problema, elimine el archivo de léxico de usuario dañado. El sistema, a continuación, vuelve a crear una versión del archivo vacía. Después de esto, pueden funcionar el motor SR y el motor TTS.

Nota Si elimina el archivo de léxico de usuario, perderá cualquier vocabulario específica del usuario que agregó anteriormente.

Para eliminar el archivo de léxico de usuario, elimine la carpeta siguiente:
\Documents and Settings\ UserName \Application Data\Microsoft\Speech\Files\UserLexicons

Solución

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.


La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Date         Time   Version     Size     File name
   --------------------------------------------------
   09-Mar-2004  22:26  6.0.1518.0  696,320  Sapi.dll

Estado

Microsoft ha confirmado que se trata de un error de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".

Propiedades

Id. de artículo: 838659 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 3.1
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Speech Software Development Kit (SDK) 5.1
Palabras clave: 
kbmt kbautohotfix kbfix kbqfe kbhotfixserver KB838659 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 838659

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com