FIX: 语音引擎不工作,并且您收到一条错误消息,当您打开语音控制面板

文章翻译 文章翻译
文章编号: 838659 - 查看本文应用于的产品
展开全部 | 关闭全部

概要

当您使用语音引擎执行识别或 $ 合成 ,您可以保存 CurrentUserLexicon 文件来存储其他单词到本地硬盘上。有时,CurrentUserLexicon 文件可能会损坏。发生这种情况时,语音识别 (SR) 引擎和文本到语音 (TTS) 引擎不起作用。本文介绍了可能的原因并解决此问题的 修补程序文件。

症状

在任何应用程序中不起作用,语音识别 (SR) 引擎和文本到语音 (TTS) 引擎。当您打开语音控制面板时,您可能会收到以下消息:
因为不能创建必要的语音引擎,所请求的任务不能被执行。请选择一个不同的引擎和/或不同的音频设备。

原因

当前,并不知道问题的特定原因。但是,下面是可能的原因:
  • 配置不正确的音频设备
  • 一个已损坏的录制的配置文件
  • 已损坏的用户辞典数据库 (CurrentUserLexicon)
若要确定是否已损坏 CurrentUserLexicon,使用十六进制编辑器打开在.dat 文件位于以下文件夹中:
\Documents 和 Settings\ UserName \Application Data\Microsoft\Speech\Files\UserLexicons
如果该文件包含唯一 0x00 字节值,并且不包含任何其他数据值,用户辞典数据库可能已损坏。

替代方法

要变通解决此问题,删除已损坏的用户词典文件。系统然后重新创建该文件的空版本。此后,SR 引擎和 TTS 引擎可以正常工作。

注意如果删除了用户词典文件就会丢失任何以前添加的特定于用户的词汇。

若要删除用户词典文件,删除以下文件夹:
\Documents 和 Settings\ UserName \Application Data\Microsoft\Speech\Files\UserLexicons

解决方案

可以从 Microsoft 获得支持的修补程序。但是,此修补程序被用于解决本文所述的此问题。此修补程序仅应用于出现这一特定问题的系统。此修补程序可能会接受进一步的测试。因此,如果此问题没有对您造成严重的影响,我们建议您等待包含此修补程序的下一个软件更新。

是否可供下载此修补程序没有"提供修补程序下载"部分中,在这篇知识库文章的顶部。如果不会显示此部分,请联系 Microsoft 客户服务和支持以获取此修复程序。

注意如果出现其他问题,或者如果需要进行任何故障诊断,则您可能不得不创建单独的服务请求。将正常收取支持费用将应用于其他支持问题和不需要进行此特定的修补程序的问题。有关完整列表的 Microsoft 客户服务和支持的电话号码,或创建一个单独的服务请求,请访问下面的 Microsoft 网站:
http://support.microsoft.com/contactus/?ws=support
注意"提供修补程序下载"窗体所显示的此修复程序是可用的语言。如果您看不到您的语言,则是一个修复程序不能用于该语言。


此修补程序的英文版具有的文件属性 (或更新的文件属性) 在下表中列出。日期和时间对这些文件列出在协调世界时 (UTC)。当您查看文件信息时,将转换为本地时间。若要 UTC 与本地时间之间的时差使用控制面板中的日期和时间工具中的 时区 选项卡。
Date         Time   Version     Size     File name
   --------------------------------------------------
   09-Mar-2004  22:26  6.0.1518.0  696,320  Sapi.dll

状态

Microsoft 已经确认这是在 Microsoft 中的错误本文"适用于"一节中列出的产品。

属性

文章编号: 838659 - 最后修改: 2007年8月29日 - 修订: 3.1
这篇文章中的信息适用于:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Speech Software Development Kit (SDK) 5.1
关键字:?
kbmt kbautohotfix kbfix kbqfe kbhotfixserver KB838659 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 838659
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com