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You receive an error message when you install an Office program or open an Office program or document

Article ID:838687
Last Review:July 5, 2007
Revision:6.6

SYMPTOMS

When you install a Microsoft Office program, you may receive one of the following error messages during or at the end of the installation process:
Error 1401: Setup cannot create Registry Key
Error 1402: Setup cannot open Registry Key
Error 1406: Setup cannot write the value to the registry key
The error message that you receive lists the registry subkey that is causing the error to occur.

After the installation, you may receive the following error message when you try to start your Office program:
Microsoft program has not been installed for the current user. Please run setup to install the application.
Note that program is the name of the Office program that you are trying to start.

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CAUSE

This issue may occur if one of the following scenarios is true:
The user who is installing the program, or the user who is opening the program or file does not have sufficient permissions to modify sections of the registry that is required to perform the action. The permission for the Everyone group of the registry subkey noted in the error message is not set to Full Control.
There is a third-party application on the system that is denying the required access to the registry subkey. In most cases, this behavior is caused by WebRoot Spysweeper.
The non-administrative user accounts on the computer do not have permission to modify specific files that are used by the Office 2003 Setup program or the Office XP Setup program. These files are used by the Office 2003 Setup program or the Office XP Setup program to register different accounts for access to the Office programs. This issue may occur if a Group Policy high-security template was applied to the computer and if the high-security template restricts access to the following file:
Office 2003
C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\Opa11.dat
Office XP
C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\Data.dat
If the non-administrative user accounts cannot modify this file, users cannot start any Office 2003 programs or Office XP programs on the computer. The Opa11.dat file and the Data.dat file are hardware specific. Additionally, these files are compiled during installation of Office.

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RESOLUTION

To resolve this issue, use one of the following methods.

Method 1

Set the permission for the Everyone group of the registry subkeys that are listed in the error message to Full Control.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows


In Microsoft Windows XP or in Windows Server 2003, follow these steps:
1. Click Start, click Run, type regedit in the Open box, and then click OK.
2.In Registry Editor, locate and then click the subkey that is listed by the error message.
3. On the Edit menu, click Permissions.
4. Under Group or user names, click Everyone.
Note You must add the Everyone group if it is not available. To do this, follow these steps:
a. In the Permission for Office dialog box, click Add.
b. In the Select Users, Computers, or Groups dialog box, click Advanced.
c. In the Select Users, Computers, or Groups dialog box, click Find Now.
d. Under Name (RDN), click Everyone, and then click OK.
e. In the Select Users, Computers, or Groups dialog box, click OK.
5. Under Permissions for Everyone, click to select the Full Control check box.
6.Click OK.
7.Quit Registry Editor.
8. Run the Setup program for your Office program.
In Microsoft Windows 2000, follow these steps:
1. Click Start, click Run, type regedt32 in the Open box, and then click OK.
2.In Registry Editor, locate the specific hive, find the subkey that is listed by the error message, and then click Security.
3. On the Security menu, click Permissions.
4. Under Name, click Everyone.

Note You must add the Everyone group if it is not available. To do this, follow these steps:
a. In the Permission for Office dialog box, click Add.
b. In the Select Users, Computers, or Groups dialog box, click the Everyone group, and then click Add.
c. In the Select Users, Computers, or Groups dialog box, click OK.
5. Under Permissions for Everyone, click to select the Full Control check box.
6.Click OK.
7.Quit Registry Editor.
8. Run the Setup program for your Office program.
Note that if you receive one of these error messages for one registry subkey, you are likely to receive error messages for other registry locations because Setup and other programs access many registry keys during the installation and during the use of a program.

Method 2

Disable the third-party application. For example, to disable WebRoot Spysweeper, follow these steps:
1.Right-click the WebRoot Spysweeper icon that is located in the notification area, at the far right of the taskbar.
2.Left-click the Shut Down option.
3.In the Office installation Error 1406 dialog box, click Retry.
4.When the Office setup is completed, restart the computer, and then re-enable WebRoot Spysweeper.

Method 3

Take the system into a "clean boot" state, and then run Office setup. This disables the third-party applications. The third-party application that is denying access to the registry subkey can no longer deny access.

For more information about how to take the system into a "clean boot" state, click the following article number to view the article in the Microsoft Knowledge Base:
310353 (http://support.microsoft.com/kb/310353/) How to configure Windows XP to start in a "clean boot" state
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Method 4

To resolve this problem, follow these steps:
1. Log on to the computer by using an Administrator user account.
2. Start Microsoft Windows Explorer.
3. On the Tools menu, click Folder Options.
4. Click the View tab.
5. Under Hidden files and folders, click Show hidden files and folders.
6. Click to clear the Hide extensions for known file types check box, and then click OK.
7. Open the following folder: C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\
8. If you are running Office 2003, right-click Opa11.dat, and then click Properties. If you are running Office XP, right-click Data.dat, and then click Properties.
9. Click the Security tab.
10. Click Advanced.
11. Click the Permissions tab.
12. Click to select Everyone in the Permission entries list, and then click Edit.
13. Click to select the Full Control check box.
14. Click OK three times. If these steps do not resolve this issue, delete the Opa11.dat file or the Data.dat file from the following folder, and then restart an Office 2003 program or an Office XP program:
C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data

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APPLIES TO
Microsoft Office Access 2003
Microsoft Office Excel 2003
Microsoft Office FrontPage 2003
Microsoft Office Outlook 2003
Microsoft Office PowerPoint 2003
Microsoft Office Publisher 2003
Microsoft Office Visio Professional 2007
Microsoft Office Visio Professional 2003
Microsoft Visio 2002 Professional Edition
Microsoft Office Visio Standard 2007
Microsoft Office Visio Standard 2003
Microsoft Visio 2002 Standard Edition
Microsoft Office Word 2003
Microsoft Office Basic 2007
Microsoft Office Basic Edition 2003
Microsoft Office Enterprise 2007
Microsoft Office Home and Student 2007
Microsoft Office Professional 2007
Microsoft Office Professional Edition 2003
Microsoft Office Small Business 2007
Microsoft Office Small Business Edition 2003
Microsoft Office Standard 2007
Microsoft Office Standard Edition 2003
Microsoft Office Student and Teacher Edition 2003
Microsoft Office Ultimate 2007
Microsoft Office XP, All Editions

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Keywords: 
kbsetup kbtshoot KB838687

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