Article ID: 838687 - Last Review: September 29, 2009 - Revision: 8.0

You receive an error message when you install an Office program or open an Office program or document

Expand all | Collapse all

SYMPTOMS

When you install a Microsoft Office program, you may receive one of the following error messages during or at the end of the installation process:
Error 1401: Setup cannot create Registry Key
Error 1402: Setup cannot open Registry Key
Error 1406: Setup cannot write the value to the registry key
The error message that you receive lists the registry subkey that is causing the error to occur.

After the installation, you may receive the following error message when you try to start your Office program:
Microsoft program has not been installed for the current user. Please run setup to install the application.
Note that program is the name of the Office program that you are trying to start.

CAUSE

This issue may occur if one of the following scenarios is true:
  • The user who is installing the program, or the user who is opening the program or file does not have sufficient permissions to modify sections of the registry that is required to perform the action. The permission for the Everyone group of the registry subkey noted in the error message is not set to Full Control.
  • There is a third-party application on the system that is denying the required access to the registry subkey. In most cases, this behavior is caused by WebRoot Spysweeper.
  • The non-administrative user accounts on the computer do not have permission to modify specific files that are used by the Office 2003 Setup program or the Office XP Setup program. These files are used by the Office 2003 Setup program or the Office XP Setup program to register different accounts for access to the Office programs. This issue may occur if a Group Policy high-security template was applied to the computer and if the high-security template restricts access to the following file:
    • Office 2003
      C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\Opa11.dat
    • Office XP
      C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\Data.dat
    If the non-administrative user accounts cannot modify this file, users cannot start any Office 2003 programs or Office XP programs on the computer. The Opa11.dat file and the Data.dat file are hardware specific. Additionally, these files are compiled during installation of Office.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1

Set the permission for the Everyone group of the registry subkeys that are listed in the error message to Full Control. Use the 'Fix It' and follow the steps provided in the KB article
For more information how to let Microsoft Fix it for you , click the following article number to view the article in the Microsoft Knowledge Base:
313222  (http://support.microsoft.com/kb/313222/ ) How do I restore security settings to the default settings?

Method 2

Disable the third-party application. For example, to disable WebRoot Spysweeper, follow these steps:
  1. Right-click the WebRoot Spysweeper icon that is located in the notification area, at the far right of the taskbar.
  2. Left-click the Shut Down option.
  3. In the Office installation Error 1406 dialog box, click Retry.
  4. When the Office setup is completed, restart the computer, and then re-enable WebRoot Spysweeper.

Method 3

Take the system into a "clean boot" state, and then run Office setup. This disables the third-party applications. The third-party application that is denying access to the registry subkey can no longer deny access.

For more information about how to take the system into a "clean boot" state, click the following article number to view the article in the Microsoft Knowledge Base:
310353  (http://support.microsoft.com/kb/310353/ ) How to configure Windows XP to start in a "clean boot" state
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Method 4

Some activation problems indicate that the license file is corrupted. If the license file is corrupted, you cannot resolve the problem by removing and then reinstalling the Office product. The license file is not removed when you remove the Office product. Additionally, the license file is not overwritten when you reinstall the Office product. Another symptom of a corrupted license file is a failure to successfully pass Office Genuine Advantage validation. If the license file is corrupted, use one of the following methods to delete the license file.

Fix it for me

To delete the corrupted license file automatically, click the Fix it button or link. Click Run in the File Download dialog box, and then follow the steps in the Fix it wizard.

Fix this problem
Microsoft Fix it 50302


Note This wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD, and then you can run it on the computer that has the problem.

Let me Fix it myself

To resolve this problem yourself, follow these steps:
  1. Log on to the computer by using an Administrator user account.
  2. Start Microsoft Windows Explorer.
  3. On the Tools menu, click Folder Options.
  4. Click the View tab.
  5. Under Hidden files and folders, click Show hidden files and folders.
  6. Click to clear the Hide extensions for known file types check box, and then click OK.
  7. Open the following folder: C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\
  8. If you are running Office 2003, right-click Opa11.dat, and then click Properties. If you are running Office XP, right-click Data.dat, and then click Properties.
  9. Click the Security tab.
  10. Click Advanced.
  11. Click the Permissions tab.
  12. Click to select Everyone in the Permission entries list, and then click Edit.
  13. Click to select the Full Control check box.
  14. Click OK three times. If these steps do not resolve this issue, delete the Opa11.dat file or the Data.dat file from the following folder, and then restart an Office 2003 program or an Office XP program:
    C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data

APPLIES TO
  • Microsoft Office Access 2003
  • Microsoft Office Excel 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Visio 2002 Professional Edition
  • Microsoft Office Visio Standard 2007
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Small Business 2007
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
Keywords: 
kbmsifixme kbfixme kbsetup kbtshoot KB838687
 

Article Translations