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Office プログラムをインストールしたときや、Office プログラムまたはドキュメントを開いたときにエラー メッセージが表示される

文書番号:838687
最終更新日:2006年7月25日
リビジョン:6.2
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 (http://support.microsoft.com/kb/256986/) Microsoft Windows レジストリの説明

現象

Microsoft Office プログラムをインストールするときに、インストールの途中または最後に次のいずれかのエラー メッセージが表示される場合があります。
エラー 1401: レジストリ キーを作成できません。
エラー 1402: レジストリ キーを開けません。
エラー 1406: レジストリ キーに値を書き込めません。
エラー メッセージには、エラー発生の原因となったレジストリ サブキーが表示されます。

インストール後に、Office プログラムを起動しようとすると、次のエラー メッセージが表示される場合があります。
Microsoft program は、現在のユーザー用にインストールされていません。セットアップを実行してアプリケーションをインストールしてください。
program は、起動しようとしている Office プログラムの名前です。

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原因

この問題は、次のいずれかの条件に該当する場合に発生することがあります。
? プログラムをインストールしているユーザー、またはプログラムやファイルを開いているユーザーに、処理の実行に必要なレジストリのセクションを変更するためのアクセス許可がありません。エラー メッセージに示されているレジストリ サブキーに対する Everyone グループのアクセス許可が、"フル コントロール" に設定されていません。
? システム上にレジストリ サブキーへの必要なアクセスを拒否するサードパーティのアプリケーションが存在します。ほとんどの場合、この問題は WebRoot Spy Sweeper が原因で発生します。
? Office 2003 セットアップ プログラムまたは Office XP セットアップ プログラムで使用される特定のファイルへのアクセス許可が、コンピュータ上の管理者以外のユーザー アカウントにありません。これらのファイルは、Office プログラムにアクセスするさまざまなアカウントを登録するために、Office 2003 セットアップ プログラムまたは Office XP セットアップ プログラムによって使用されます。この問題は、セキュリティ レベルの高いグループ ポリシー テンプレートがコンピュータに適用されている場合、およびそのセキュリティ レベルの高いテンプレートで以下のファイルへのアクセスが制限されている場合に発生することがあります。
? Office 2003
C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\Opa11.dat
? Office XP
C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\Opa10.dat
管理者以外のユーザー アカウントでこのファイルを変更できない場合、コンピュータ上で Office 2003 プログラムまたは Office XP プログラムを起動できません。Opa11.dat ファイルおよび Opa10.dat ファイルはハードウェア固有です。また、これらのファイルは Office のインストール中にコンパイルされます。

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解決方法

この問題を解決するには、以下のいずれかの方法を使用します。

方法 1

エラー メッセージに表示されているレジストリ サブキーの Everyone グループのアクセス許可を "フル コントロール" に設定します。

警告 : レジストリ エディタまたは別の方法を使用してレジストリを誤って変更すると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリの変更により発生した問題に関しては、一切責任を負わないものとします。レジストリの変更は、自己の責任において行ってください。

Microsoft Windows XP または Windows Server 2003 では、次の手順を実行します。
1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに regedit と入力し、[OK] をクリックします。
2. レジストリ エディタで、エラー メッセージに表示されているサブキーを探してクリックします。
3. [編集] メニューの [アクセス許可] をクリックします。
4. [グループ名またはユーザー名] ボックスの一覧の [Everyone] をクリックします。
: Everyone グループが表示されない場合は、次の手順を実行して、追加する必要があります。
a. [Office のアクセス許可] ダイアログ ボックスで、[追加] をクリックします。
b. [ユーザー または グループ の選択] ダイアログ ボックスで、[詳細設定] をクリックします。
c. [ユーザー または グループ の選択] ダイアログ ボックスで、[今すぐ検索] をクリックします。
d. [名前 (RDN)] で、[Everyone] をクリックし、[OK] をクリックします。
e. [ユーザー または グループ の選択] ダイアログ ボックスで、[OK] をクリックします。
5. Everyone の [アクセス許可] で、[フル コントロール] の [許可] チェック ボックスをオンにします。
6. [OK] をクリックします。
7. レジストリ エディタを終了します。
8. Office プログラムのセットアップ プログラムを実行します。
Microsoft Windows 2000 では、次の手順を実行します。
1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに regedt32 と入力し、[OK] をクリックします。
2. レジストリ エディタで、特定のハイブを探し、エラー メッセージに表示されているサブキーを見つけてクリックし、[セキュリティ] をクリックします。
3. [セキュリティ] メニューの [アクセス許可] をクリックします。
4. [名前] ボックスの一覧の [Everyone] をクリックします。

: Everyone グループが表示されない場合は、次の手順を実行して、追加する必要があります。
a. [Office のアクセス許可] ダイアログ ボックスで、[追加] をクリックします。
b. [ユーザー または グループ の選択] ダイアログ ボックスで、[Everyone] グループをクリックし、[追加] をクリックします。
c. [ユーザー または グループ の選択] ダイアログ ボックスで、[OK] をクリックします。
5. Everyone の [アクセス許可] で、[フル コントロール] の [許可] チェック ボックスをオンにします。
6. [OK] をクリックします。
7. レジストリ エディタを終了します。
8. Office プログラムのセットアップ プログラムを実行します。
1 つのレジストリ サブキーに関していずれかのエラー メッセージが表示される場合は、他のレジストリ キーに関してもエラー メッセージが表示される可能性があります。これは、セットアップやその他のプログラムが、インストール中およびプログラムの使用中に多数のレジストリ キーにアクセスするためです。

方法 2

サードパーティのアプリケーションを無効にします。たとえば、WebRoot Spy Sweeper を無効にするには、以下の手順を実行します。
1. タスク バー右端の通知領域に表示されている WebRoot Spy Sweeper のアイコンを右クリックします。
2. [終了] をクリックします。
3.Office インストール エラー 1406 のダイアログ ボックスで [再試行] をクリックします。
4. Office のセットアップが完了したら、コンピュータを再起動して、WebRoot Spy Sweeper を再度有効にします。

方法 3

システムをクリーン ブート状態にした後、Office のセットアップを実行します。これでサードパーティのアプリケーションが無効になります。これにより、レジストリ サブキーへのアクセスを拒否していたサードパーティのアプリケーションがアクセスを拒否できなくなります。

Windows XP でクリーン ブートを実行する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
310353 (http://support.microsoft.com/kb/310353/) Windows XP でクリーン ブートを実行する方法
この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

方法 4

この問題を解決するには、次の手順を実行します。
1. Administrator ユーザー アカウントを使用して、コンピュータにログオンします。
2. エクスプローラを起動します。
3. [ツール] メニューの [フォルダ オプション] をクリックします。
4. [表示] タブをクリックします。
5. [ファイルとフォルダの表示] の下の [すべてのファイルとフォルダを表示する] をクリックします。
6. [登録されているファイルの拡張子は表示しない] チェック ボックスをオフにし、[OK] をクリックします。
7. C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\ フォルダを開きます。
8. Office 2003 を実行している場合は、[Opa11.dat] を右クリックし、[プロパティ] をクリックします。Office XP を実行している場合は、[Opa10.dat] を右クリックし、[プロパティ] をクリックします。
9. [セキュリティ] タブをクリックします。
10.[詳細設定] をクリックします。
11. [アクセス許可] タブをクリックします。
12. [アクセス許可エントリ] ボックスの一覧の [Everyone] をクリックし、[編集] をクリックします。
13. [フル コントロール] の [許可] チェック ボックスをオンにします。
14. [OK] を 3 回クリックします。上記の手順を実行してもこの問題が解決しない場合は、次のフォルダから Opa11.dat ファイルまたは Opa10.dat ファイルを削除し、Office 2003 プログラムまたは Office XP プログラムを再起動します。
C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data

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この資料は以下の製品について記述したものです。
?Microsoft Office XP, All Editions
?Microsoft Office Visio Professional 2003
?Microsoft Visio Professional Version 2002
?Microsoft Visio Standard Version 2002
?Microsoft Office Professional Edition 2003
?Microsoft Office Small Business Edition 2003
?Microsoft Office Basic Edition 2003
?Microsoft Office PowerPoint 2003
?Microsoft Office Publisher 2003

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キーワード:?
kbsetup kbtshoot KB838687

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