Numer ID artykułu: 838687 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Po zainstalowaniu programu Microsoft z
wyświetlać program, może pojawić się jeden z następujących komunikatów o błędach podczas lub na końcu procesu instalacji:
Błąd 1401: Instalator nie może utworzyć klucza rejestru
Błąd 1402: Instalator nie może otworzyć klucza rejestru
Błąd 1406: Instalator nie może zapisać wartości do klucza rejestru
Pojawi się komunikat o błędzie zawiera listę podklucz rejestru, który powoduje błąd występuje.

Po zakończeniu instalacji może się pojawić następujący komunikat o błędzie podczas próby uruchomienia programu pakietu Office:
Microsoft Program nie została zainstalowana dla bieżącego użytkownika. Uruchom Instalatora, aby zainstalować aplikację.
Należy zauważyć, że Program jest nazwą programu pakietu Office, który chcesz uruchomić.

Przyczyna

Ten problem może wystąpić, jeśli spełniony jest jeden z następujących scenariuszy:
  • Użytkownik, który instaluje program lub użytkownika, który isopening program lub plik nie ma wystarczających uprawnień, aby modifysections z rejestru, które są wymagane do wykonania akcji. Permissionfor, grupa podklucza rejestru wszyscy zauważyć w komunikacie o błędzie jest nieustawiony Pełna kontrola.
  • Istnieje aplikacji innych firm w systemie isdenying, że wymagane prawa dostępu do podklucza rejestru. W większości przypadków thisbehavior jest spowodowane WebRoot Spysweeper.
  • Konta użytkowników którzy nie są administratorami, na komputerze nie masz uprawnień do modyfikowania określonych plików, które są używane przez Instalatora pakietu Office 2003 lub programu Instalatora pakietu Office XP. Te pliki są używane przez Instalatora pakietu Office 2003 lub Office XP Instalator do rejestrowania różnych kont w celu uzyskania dostępu do programów pakietu Office. Ten problem może wystąpić, jeśli do komputera został zastosowany szablon wysokim poziomie zabezpieczeń zasady grupy i szablonu wysokim poziomie zabezpieczeń ogranicza dostęp do następującego pliku:
      Dla systemu Windows XP lub Windows Server 2003
      • Office 2007
        C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\Opa12.dat
      • Office 2003
        C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\Opa11.dat
      • Pakiet Office XP
        C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\Data.dat

      Dla systemu Windows Vista lub Windows 7
      • Office 2007
        C:\Users\All Users\Microsoft\Office\Data\Opa12.dat
      • Office 2003
        C:\Users\All Users\Microsoft\Office\Data\Opa11.dat
      • Pakiet Office XP
        C:\Users\All Users\Microsoft\Office\Data\Data.dat

    Jeśli konta użytkownika niebędącego administratorem nie można zmodyfikować ten plik, użytkownicy nie można uruchomić programy pakietu Office 2007, programach 2003 lub programy pakietu Office XP na komputerze. Opa12.dat, plik Opa11.dat i plik Data.dat są określonego sprzętu. Ponadto te pliki są kompilowane podczas instalacji pakietu Office.

Rozwiązanie

Aby rozwiązać ten problem, użyj jednej z następujących metod.

Metoda 1

Ustawianie uprawnień dla grupy Wszyscy podklucze rejestru, które są wymienione w komunikacie o błędzie Pełna kontrola. Użyj "Fix It" i wykonaj kroki podane w artykule KB
Aby uzyskać więcej informacji jak aby umożliwić Microsoft Fix to dla Ciebie, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
313222 Jak przywrócić ustawienia zabezpieczeń do wartości domyślnych?

Metoda 2

Wyłączanie aplikacji innych firm. Na przykład aby wyłączyć WebRoot Spysweeper, wykonaj następujące kroki:
  1. Kliknij prawym przyciskiem myszy ikonę programu WebRoot Spysweeper, który znajduje się w obszar powiadomień, po prawej stronie paska zadań.
  2. Kliknij lewym przyciskiem myszy opcję Zamknij.
  3. W oknie dialogowym Błąd 1406 instalacji pakietu Officekliknij przycisk Ponów próbę.
  4. Po zakończeniu pracy Instalatora pakietu Office, uruchom ponownie komputer, a następnie włącz ponownie WebRoot Spysweeper.

Metoda 3

Podjąć system w stanie "czystego rozruchu", a następnie uruchom Instalatora pakietu Office. Wyłącza aplikacje innych firm. Aplikacji innych firm, która odmawia dostępu do podklucza rejestru nie można odmówić dostępu.

Aby uzyskać więcej informacji dotyczących sposobu uwzględnienia system stanie "czystego rozruchu" kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
310353 Jak skonfigurować system Windows XP do uruchamiania w stanie "czystego rozruchu"


Aby uzyskać więcej informacji dotyczących sposobu uwzględnienia system stanie "czystego rozruchu" kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
950093 Jak rozwiązywać problemy z błędami konfiguracji w systemie Windows Vista za pomocą narzędzia konfiguracji systemu


Produkty innych firm omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, domyślnych ani żadnego innego rodzaju, odnośnie do wydajności lub niezawodności tych produktów.

Metoda 4

Niektóre problemy z aktywacją wskazują, że jest uszkodzony plik licencji. Jeśli plik licencji jest uszkodzony, nie można rozwiązać problemu poprzez usunięcie i ponowne zainstalowanie produktu pakietu Office. Plik licencji nie jest usuwany podczas usuwania produktu pakietu Office. Ponadto plik licencji nie jest zastępowany, po ponownym zainstalowaniu produktu pakietu Office. Jeśli plik licencji jest uszkodzony, użyj jednej z następujących metod do usunięcia pliku licencji.

Uwaga Metoda 4 stosuje się tylko do pakietu Office 2007, Office 2003 i Office XP. Pakiet Office 2010 nie używa pliku licencjonowania OPA.

Automatyczne rozwiązywanie problemu

Umożliwia automatyczne usuwanie uszkodzonego pliku licencji, kliknij przycisk Napraw lub łącze. Kliknij przycisk Uruchom w oknie dialogowym Pobieranie pliku , a następnie postępuj zgodnie z instrukcjami poprawka kreatora.

Zwiń ten obrazekRozwiń ten obrazek
assets fixit1
Rozwiąż ten problem
Microsoft Napraw 50302
Zwiń ten obrazekRozwiń ten obrazek
assets fixit2


Uwaga Ten kreator może być w języku angielskim Jednak poprawka automatyczna działa również w innych wersjach językowych systemu Windows.

Uwaga Jeśli nie korzystasz właśnie z komputera, którego dotyczy problem, można zapisać tę poprawkę automatyczną na dysku flash lub dysku CD i uruchomić ją później na komputerze docelowym.

Samodzielne rozwiązywanie problemu

Aby samodzielnie rozwiązać ten problem, wykonaj następujące kroki.

Dla systemu Windows XP lub Windows Server 2003
  1. Zaloguj się do komputera przy użyciu konta administratora.
  2. Uruchom Eksploratora Microsoft Windows.
  3. W menu Narzędzia kliknij polecenie Opcje folderów.
  4. Kliknij kartę Widok .
  5. W obszarze ukryte pliki i folderykliknij opcję Pokaż ukryte pliki i foldery.
  6. Kliknij, aby wyczyścić pole wyboru Ukryj rozszerzenia znanych typów plików , a następnie kliknij przycisk OK.
  7. Otwórz następujący folder: C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\
  8. Jeśli używasz pakietu Office 2007, kliknij prawym przyciskiem myszy Opa12.dat, a następnie kliknij Właściwości. Jeśli korzystasz z pakietu Office 2003, kliknij prawym przyciskiem myszy Opa11.dat, a następnie kliknij Właściwości. Jeśli używasz pakietu Office XP, kliknij prawym przyciskiem myszy Data.dat, a następnie kliknij polecenie Właściwości.
  9. Kliknij kartę Zabezpieczenia .
  10. Kliknij przycisk Zaawansowane.
  11. Kliknij kartę uprawnienia .
  12. Kliknij, aby zaznaczyć Każdy z listy wpisów uprawnień , a następnie kliknij przycisk Edytuj.
  13. Kliknij, aby zaznaczyć pole wyboru Pełna kontrola .
  14. Kliknij przycisk OK trzy razy. Jeśli te kroki nie umożliwiają rozwiązania tego problemu, usuń plik Opa11.dat lub Data.dat z następującego folderu, a następnie ponownie uruchom program pakietu Office 2003 lub programu pakietu Office XP:
    C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data
Dla systemu Windows Vista lub Windows 7
  1. Zaloguj się do komputera przy użyciu konta administratora.
  2. Uruchom Eksploratora Microsoft Windows.
  3. W menu Organizuj kliknij polecenie Opcje folderów i wyszukiwania.
  4. Kliknij kartę Widok .
  5. W obszarze ukryte pliki i folderykliknij opcję Pokaż ukryte pliki, foldery i dyski.
  6. Kliknij, aby wyczyścić pole wyboru Ukryj rozszerzenia znanych typów plików .
  7. Kliknij, aby wyczyścić pole wyboru Ukryj pliku chronionego systemu operacyjnego (zalecane) , a następnie kliknij przycisk OK.
  8. W oknie dialogowym Ostrzeżenie kliknij przycisk Tak.
  9. Otwórz następujący folder: C:\Users\All Users\Microsoft\Office\Data\
  10. Jeśli używasz pakietu Office 2007, kliknij prawym przyciskiem myszy Opa12.dat lub jeśli używasz pakietu Office 2003, kliknij prawym przyciskiem myszy Data.dati kliknij polecenie Właściwości.
  11. Kliknij kartę Zabezpieczenia .
  12. Kliknij przycisk Zaawansowane.
  13. Kliknij kartę uprawnienia .
  14. Kliknij, aby zaznaczyć Każdy z listy wpisów uprawnień , a następnie kliknij przycisk Edytuj.
  15. Kliknij, aby zaznaczyć pole wyboru Pełna kontrola .
  16. Kliknij cztery razy przycisk OK . Jeśli te kroki nie umożliwiają rozwiązania tego problemu, Usuń Opa12.dat, plik Opa11.dat lub Data.dat z następującego folderu i ponownym uruchomieniu programu pakietu Office 2007, programu pakietu Office 2003 lub programu pakietu Office XP
    C:\Users\All Users\Microsoft\Office\Data

Właściwości

Numer ID artykułu: 838687 - Ostatnia weryfikacja: 19 kwietnia 2014 - Weryfikacja: 10.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Access 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Visio 2002 Professional Edition
  • Microsoft Office Visio Standard 2007
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Office Basic 2007
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Enterprise 2007
  • Office 2007 dla Uzytkownikow Domowych
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Small Business 2007
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Professional 2010
  • Microsoft Office Standard 2010
  • Microsoft Office Home and Business 2010
  • Microsoft Office Home and Student 2010
  • Microsoft Office Academic 2010
Słowa kluczowe: 
kbmsifixme kbfixme kbsetup kbtshoot kbmt KB838687 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł został przetłumaczony przy użyciu oprogramowania firmy Microsoft do tłumaczenia maszynowego i może być poprawiony przy użyciu technologii Community Translation Framework (CTF). Firma Microsoft udostępnia artykuły tłumaczone maszynowo, poprawione przez społeczność, a także tłumaczone przez tłumaczy profesjonalnych, aby zapewnić dostęp do wszystkich artykułów w bazie wiedzy w wielu językach. Artykuły tłumaczone maszynowo i poprawione mogą zawierać błędy pisowni, składniowe i gramatyczne. Firma Microsoft nie ponosi odpowiedzialności za żadne nieścisłości, błędy ani szkody spowodowane przez niepoprawne tłumaczenia zawartości ani przez korzystanie z niej przez klientów. Więcej o strukturze CTF: http://support.microsoft.com/gp/machine-translation-corrections/pl.
Anglojęzyczna wersja tego artykułu to: 838687

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com