При установке программы Microsoft Office или открытии программы или документа Microsoft Office появляется сообщение об ошибке

Переводы статьи Переводы статьи
Код статьи: 838687 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

Проблема

В процессе или в конце установки Microsoft
Office могут появиться указанные ниже сообщения об ошибках.
Ошибка 1401: Программа установки не может создать раздел реестра
Ошибка 1402: Программа установки не может открыть параметр реестра
Ошибка 1406: Программа установки не может записать значение в параметр реестра
Это сообщение об ошибке отображает подраздел реестра, из-за которого происходит ошибка.

После установки при попытке запуска программы Microsoft Office может появиться следующее сообщение об ошибке:
Microsoft программа не была установлена для текущего пользователя. Для этого запустите программу установки.
Обратите внимание на то, что программа - имя той программы пакета Office, которую вы пытаетесь запустить.

Причина

Данная проблема возникает по одной из следующих причин:
  • Пользователь, устанавливающий или запускающий программу или открывающий файл, не имеет требуемого разрешения на изменение разделов реестра. Группа "Все" не имеет полного доступа к записи реестра, указанной в сообщении об ошибке.
  • В системе установлено приложение стороннего производителя, блокирующее доступ к требуемой записи реестра. В большинстве случаев блокировка вызывается приложением WebRoot Spysweeper.
  • Для учетных записей пользователей без прав администратора отсутствуют разрешения на изменение определенных файлов, используемых программой установки Microsoft Office 2003 или Microsoft Office XP. Эти файлы используются программами установки Microsoft Office 2003 и Microsoft Office XP для регистрации разных учетных записей, имеющих доступ к программам Microsoft Office. Эта проблема может появиться, если на компьютере был применен шаблон повышенной безопасности, ограничивающий доступ к следующему файлу:
      Windows XP и Windows Server 2003
      • Office 2007
        C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\Opa12.dat
      • Office 2003
        C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\Opa11.dat
      • Office XP
        C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\Data.dat

      Windows Vista или Windows 7
      • Office 2007
        C:\Users\All Users\Microsoft\Office\Data\Opa12.dat
      • Office 2003
        C:\Users\All Users\Microsoft\Office\Data\Opa11.dat
      • Office XP
        C:\Users\All Users\Microsoft\Office\Data\Data.dat

    Если учетные записи пользователей, не обладающие правами администрирования, не могут изменять этот файл, пользователь не может запускать приложения Office 2007, Office 2003 или Office XP. Файлы Opa12.dat, Opa11.dat и Data.dat зависят от оборудования. Эти файлы компилируются в процессе установки Office.

Решение

Для решения этой проблемы воспользуйтесь одним из описанных ниже способов.

Способ 1

Для записей реестра, указанных в сообщении об ошибке, установите разрешение "Полный доступ" для группы Все. Воспользуйтесь ссылкой "Решение проблемы" и выполните действия, описанные в статье базы знаний.
Дополнительные сведения о решении проблемы с помощью Майкрософт см. в следующей статье базы знаний Майкрософт:
313222 Восстановление параметров безопасности по умолчанию

Способ 2

Отключите приложения сторонних производителей. Например, для отключения приложения WebRoot Spysweeper выполните следующие действия:
  1. Правой клавишей мыши щелкните значок WebRoot Spysweeper, находящийся в области оповещения в правой части панели задач.
  2. Щелкните пункт меню Отключить.
  3. В диалоговом окне Установка Microsoft Office: Ошибка 1406 выберите команду Обновить.
  4. Если установка Office завершена, перезагрузите компьютер и перезапустите приложение WebRoot Spysweeper.

Способ 3

Выполните "чистую" загрузку системы и запустите программу установки Office. Таким образом будут отключены приложения сторонних производителей. Приложение стороннего производителя, блокирующее доступ к записи реестра, не сможет производить блокировку.

Дополнительные сведения о настройки система на выполнение "чистой загрузки" см. в следующей статье базы знаний Майкрософт:
310353 Как настроить Windows XP на выполнение "чистой" загрузки


Дополнительные сведения о настройки система на выполнение "чистой загрузки" см. в указанной ниже статье базы знаний Майкрософт.
950093 Использование служебной программы конфигурации системы для устранения неполадок конфигурации в Windows Vista


В данной статье упомянуты программные продукты независимых производителей. Корпорация Майкрософт не дает никаких гарантий и обязательств по корректной работе или надежности этих продуктов.

Способ 4

Некоторые проблемы, связанные с активацией, указывают на повреждение файла лицензии. При повреждении файла лицензии проблему не удастся устранить посредством удаления и повторной установки продукта Office. При удалении продукта Office файл лицензии не удаляется. Кроме того, при повторной установке продукта Office замена файла лицензии не производится. Если файл лицензии поврежден, воспользуйтесь одним из указанных ниже способов для его удаления.

Примечание. Способ 4 применим только к Office 2007, Office 2003 и Office XP. Office 2010 не использует файл лицензии OPA.

Помощь в решении проблемы

Чтобы удалить поврежденный файл лицензии автоматически, нажмите кнопку Устранить проблему или щелкните одноименную ссылку. В диалоговом окне Загрузка файла нажмите кнопку Выполнить и следуйте инструкциям мастера устранения проблем.

Свернуть это изображениеРазвернуть это изображение
assets fixit1
Устранить проблему
Microsoft Fix it 50302
Свернуть это изображениеРазвернуть это изображение
assets fixit2


Примечание. Интерфейс этого мастера может быть доступен только на английском языке, однако автоматическое исправление можно выполнить и в других языковых версиях Windows.

Примечание. Если загрузка выполняется не с того компьютера, на котором выявлена проблема, можно сохранить автоматическое исправление на флэш-накопителе или компакт-диске, чтобы запустить его на нужном компьютере.

Самостоятельное решение проблемы

Чтобы решить проблему самостоятельно, выполните указанные ниже действия.

Windows XP и Windows Server 2003
  1. Войдите в систему от имени администратора.
  2. Запустите проводник Windows.
  3. В меню Сервис выберите команду Свойства папки.
  4. Перейдите на вкладку Вид.
  5. Для параметра Скрытые файлы и папки установите флажок Показывать скрытые файлы и папки.
  6. Установите флажок Скрывать расширения для зарегистрированных типов файлов и нажмите кнопку OK.
  7. Откройте следующую папку: C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data\
  8. Если на компьютере установлен Office 2007, щелкните правой кнопкой мыши файла Opa12.dat и выберите пункт меню Свойства. Если на компьютере установлен Office 2003, правой клавишей мыши щелкните имя файла Opa11.dat и выберите пункт меню Свойства. Если на компьютере установлен Office XP, правой клавишей мыши щелкните имя файла Data.dat и выберите пункт меню Свойства.
  9. Перейдите на вкладку Безопасность.
  10. Нажмите кнопку Дополнительно.
  11. Перейдите на вкладку Разрешения.
  12. Выделите запись Все в списке Разрешения и нажмите кнопку Правка.
  13. Установите флажок Полный доступ.
  14. Нажмите кнопку ОК три раза. Если после выполнения описанных действий проблема не решена, удалите файл Opa11.dat или Data.dat из папки, указанной ниже, и перезапустите приложение Office 2003 или Office XP:
    C:\Documents and Settings\All Users\Application Data\Microsoft\Office\Data
Windows Vista или Windows 7
  1. Войдите в систему с учетной записью администратора.
  2. Запустите проводник.
  3. В меню Настройка выберите пункт Свойства папок и поиска.
  4. Откройте вкладку Вид.
  5. Для параметра Скрытые файлы и папки установите флажок Показывать скрытые файлы, папки и диски.
  6. Снимите флажок Скрывать расширения для зарегистрированных типов файлов.
  7. Снимите флажок Скрывать защищенные системные файлы (рекомендуется) и нажмите "ОК".
  8. В диалоговом окне Предупреждение нажмите кнопку Да.
  9. Откройте следующую папку: C:\Users\All Users\Microsoft\Office\Data\
  10. Если используется Office 2007, щелкните правой кнопкой мыши файл Opa12.dat, а если используется Office 2003 — Data.dat, а затем выберите пункт Свойства.
  11. Откройте вкладку Безопасность.
  12. Нажмите кнопку Дополнительно.
  13. Откройте вкладку Разрешения.
  14. Выделите запись Все в списке Разрешения и нажмите кнопку Правка.
  15. Установите флажок Полный доступ.
  16. Нажмите кнопку ОК четыре раза. Если эти действия не помогли решить проблему, удалите файл Opa12.dat, Opa11.dat или Data.dat из указанной ниже папки и перезапустите приложение Office 2007, Office 2003 или Office XP.
    C:\Users\All Users\Microsoft\Office\Data

Свойства

Код статьи: 838687 - Последний отзыв: 9 марта 2014 г. - Revision: 5.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Office Access 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Visio 2002 Professional Edition
  • Microsoft Office Visio Standard 2007
  • Microsoft Visio 2002 Standard Edition
  • Microsoft Office Basic 2007
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Small Business 2007
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Professional 2010
  • Microsoft Office Standard 2010
  • Microsoft Office Home and Business 2010
  • Microsoft Office Home and Student 2010
  • Microsoft Office Academic 2010
Ключевые слова: 
kbmsifixme kbfixme kbsetup kbtshoot KB838687

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com