New network shared folders automatically assign Read permissions to the Everyone group in Windows Server 2003

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Article ID: 838777 - View products that this article applies to.
For more information about the Microsoft Windows XP Service Pack 2 fix for this problem, click the following article number to view the article in the Microsoft Knowledge Base:
836023 Windows ignores the share permissions that the registry specifies after you install Windows XP Service Pack 1
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SYMPTOMS

When you use the
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\DefaultSecurity\SrvsvcDefaultShareInfo
subkey to configure the default share level permissions, the subkey value is ignored. The Everyone group is given Read permissions to any new network shares.

CAUSE

This problem occurs because of a change that was added to Microsoft Windows Server 2003 to make the default permissions for newly created shares more restrictive than in Microsoft Windows XP. In the release version of Windows XP, when you create a new share, the default permission gives all users full access. When you create a new share in Windows Server 2003, the default permission gives everyone Read access. Because of this change, the SrvsvcDefaultShareInfo value is overwritten with Read permissions.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name      Platform
   ----------------------------------------------------------------------
   24-Mar-2004  16:06  6.0.3790.144      240,128  Ntshrui.dll    IA-64
   24-Mar-2004  16:05  6.0.3790.144      139,776  Wntshrui.dll   x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This fix affects only shares that are created by using the Windows graphical user interface. If you create a share programmatically or by using a command-line utility, you still experience the symptom that is described in the "Symptoms" section. For example, if you create a share by using the net share command, the Everyone group is given Read permissions on that share. For more information about standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 838777 - Last Review: July 24, 2007 - Revision: 2.12
APPLIES TO
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbnetwork kbwinserv2003presp1fix kbupgrade kbsyssettings kbsecurity kbfix kbbug KB838777

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