Article ID: 838851 - Last Review: July 24, 2007 - Revision: 2.11

DNS removes a Network Name resource at the end of the default scavenging interval in Windows Server 2003

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SYMPTOMS

After you use the Cluster Administrator Console to bring a Network Name resource online, you notice that the DNS record for the resource is removed after seven days. You must take the Network Name resource offline, and then bring the resource back online to restore the record.

CAUSE

This problem occurs because the 24-hour DNS record update interval is reset after you bring a Network Name resource online. The Cluster service does not update the DNS records on the default 24-hour interval. By default, the DNS scavenging interval is seven days. At the end of the scavenging interval, DNS removes the Network Name record because the Time to Live (TTL) value has expired.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Date         Time   Version            Size    File name
-----------------------------------------------------------------
12-Mar-2004  21:02  5.2.3790.140    1,072,128  Clusres.dll  IA-64
Date         Time   Version            Size    File name
----------------------------------------------------------------
12-Mar-2004  22:01  5.2.3790.140      449,536  Clusres.dll  x86

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Windows Server 2003 Service Pack 1.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbclustering kbdns kbserver kbwinserv2003presp1fix kbfix kbbug KB838851