Você receber uma mensagem de erro "O aplicativo não inicializou corretamente (0xc0000142)" quando você inicia um computador que está executando o ISA Server 2000

Traduções deste artigo Traduções deste artigo
ID do artigo: 838857 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Quando você inicia um computador que está executando o Microsoft Internet Security and Acceleration (ISA) Server 2000, você pode enfrentar um ou mais dos seguintes sintomas:
  • Você receber a seguinte mensagem de erro:
    O aplicativo não inicializou corretamente (0xc0000142). Clique em OK para encerrar o aplicativo.
  • Ambos os seguintes serviços não iniciar:
    Microsoft Proxy
    Microsoft Firewall
  • Não é possível acessar a tabela tabela de endereços local (LAT) a ferramenta Gerenciamento do ISA.
  • Os seguintes eventos aparecem no log do sistema em Visualizar eventos:

    Origem do evento: Popup de aplicativo
    Categoria do evento: nenhum
    IDENTIFICAÇÃO de evento: 26
    Data: date
    Tempo: time
    Tipo: informações
    Usuário: N/d
    Computador: computername
    Descrição: Aplicativo popup: erro de aplicativo mspadmin.exe: O aplicativo não inicializou corretamente (0xc0000142). Clique em OK para encerrar o aplicativo.

    Origem do evento: Service Control Manager
    Categoria do evento: nenhum
    IDENTIFICAÇÃO de evento: 7000
    Data: date
    Tempo: time
    Tipo: erro
    Usuário: N/d
    Computador: computername
    Descrição: O serviço de controle do Microsoft ISA Server falhou ao iniciar devido ao erro a seguir:
    O serviço não respondeu à solicitação de início ou controle em tempo hábil.

    Origem do evento: Service Control Manager
    Categoria do evento: nenhum
    IDENTIFICAÇÃO de evento: 7001
    Data: date
    Tempo: time
    Tipo: erro
    Usuário: N/d
    Computador: computername
    Descrição: O serviço Microsoft Firewall depende do serviço de controle do Microsoft ISA Server que falhou ao iniciar devido ao seguinte erro:
    O serviço não respondeu à solicitação de início ou controle em tempo hábil.

    Origem do evento: Service Control Manager
    Categoria do evento: nenhum
    IDENTIFICAÇÃO de evento: 7009
    Data: date
    Tempo: time
    Tipo: erro
    Usuário: N/d
    Computador: computername
    Descrição: Tempo limite (30000 milissegundos) aguardar o serviço de controle do Microsoft ISA Server para se conectar.

Causa

Esse problema pode ocorrer se um ou mais das seguintes condições forem verdadeiras:
  • O arquivo de tabela (LAT) do endereço local Msplat.txt está ausente ou corrompido.
  • A seguinte pasta tenha sido movida ou removida:
    \Arquivos de programas\Microsoft ISA Server\Clients
  • Permissões de acesso incorreto foram atribuídas para a seguinte pasta:
    Programa de programas\Microsoft ISA Server\Clients

Resolução

Para resolver esse problema, execute essas etapas:
  1. Verifique se a pasta Program Files\Microsoft ISA Server\Clients existe. Serviços do ISA Server requer esta pasta para executar.
  2. Verifique se os seguintes grupos de segurança tem permissões controle total atribuídas para a pasta Program Files\Microsoft ISA Server\Clients:
    Administradores
    SISTEMA
  3. Verifique se o arquivo Msplat.txt existe na pasta clientes. Se esse arquivo estiver faltando, copie-o de outro computador do ISA Server.

    Observação Após você copiar este arquivo de outro computador do ISA Server, exiba a LAT para certificar-se que ele contém o intervalo de endereço IP correto.
Se a pasta clientes está faltando ou danificado, ou se você não pode copiar o arquivo Msplat.txt ausente de outra instalação do ISA Server, reinstale o ISA Server 2000.

Propriedades

ID do artigo: 838857 - Última revisão: quinta-feira, 22 de abril de 2004 - Revisão: 1.2
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Security and Acceleration (ISA) Server 2000 Standard Edition
Palavras-chave: 
kbmt kbeventlog kberrmsg kbfirewall kbprb KB838857 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 838857

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com