"The server returned an invalid or unrecognized response" error message in Internet Explorer 6 Service Pack 1

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Article ID: 838893 - View products that this article applies to.
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SYMPTOMS

When you try to use Microsoft Internet Explorer 6 Service Pack 1 (SP1) to view a Web page, you may receive an error message that is similar to the following error message:
The server returned an invalid or unrecognized response.

CAUSE

This problem may occur if the following conditions are true:
  • You have installed the cumulative security update for Internet Explorer MS04-004.
  • You try to access a Web page that is secured by basic authentication.
This problem occurs after you apply the cumulative security update for Internet Explorer MS04-004. When you access a Web page that uses basic authentication, Internet Explorer sends a HEAD request with an authorization header through the same port that was used to send the first HEAD request. When Internet Explorer sends a HEAD request for a resource that uses basic authentication, the Web server may return a "401 Access Denied" message and a "Connection: close" message. If Internet Explorer then sends the HEAD request with an authorization header that uses the same port that was used for the first HEAD request, an error occurs. The same port must not be used again because the Web server prompted for the connection to be closed when the "401 Access Denied" status message was returned to Internet Explorer.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   05-Apr-2004  09:10  6.0.2800.1415  570,880  Wininet.dll

STATUS

Microsoft has confirmed that this is a problem in Internet Explorer 6 Service Pack 1.

MORE INFORMATION

For additional information about cumulative security update for Internet Explorer MS04-004, click the following article number to view the article in the Microsoft Knowledge Base:
832894 MS04-004: Cumulative security update for Internet Explorer

Properties

Article ID: 838893 - Last Review: October 9, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Internet Explorer 6.0
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbie600sp2fix kbie600presp2fix kbfix kbbug KB838893

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