Article ID: 839003 - Last Review: December 3, 2007 - Revision: 2.8

FIX: "Automation Error, object is not registered" error message when an ASP page calls COM objects that are running in a COM+ package on IIS 6.0

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SYMPTOMS

An Active Server Pages (ASP) page calls Component Object Model (COM) objects that are running in a COM+ package on a computer that is running Microsoft Internet Information Services version 6.0 and Microsoft Windows Server 2003. After the ASP page refreshes many times, you receive the following error message:
2147220997 (0x800401fb - "Automation Error, object is not registered")
However, on Microsoft Windows 2000, the application works as expected.

CAUSE

This problem occurs if object references are stored in ASP Web application variables. This problem is caused by incorrect behavior of the ASP internal session UnInit handler.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name
   ----------------------------------------------------
   31-Mar-2004  04:10  6.0.3790.146  379,904  Asp.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Internet Information Services 6.0
Keywords: 
kbautohotfix kberrmsg kbfix kbbug kbwinserv2003presp1fix kbhotfixserver kbqfe KB839003