Windows XP 서비스 팩 2를 실행하는 컴퓨터에서 NET SEND 명령이 제대로 작동하지 않을 수 있음

기술 자료 번역 기술 자료 번역
기술 자료: 839018 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

현상

컴퓨터에 Microsoft Windows XP SP2(서비스 팩 2)를 설치하면 Windows 운영 체제의 NET SEND 명령을 사용하여 메시지를 보내거나 받지 못할 수 있습니다. 다음 시나리오 중 하나나 모두에서 이러한 문제가 발생할 수 있습니다.
  • NET SEND 알림 방법을 사용하여 SQL Server 운영자에게 SQL Server 인스턴스에서 발생한 이벤트에 대해 알리는 경우
  • xp_cmdshell 확장 시스템 저장 프로시저를 통해 NET SEND 명령을 실행하여 네트워크의 컴퓨터나 사용자에게 메시지를 보내는 경우
또한 NET SEND 명령을 사용하여 메시지를 보내려고 하면 다음과 같은 오류 메시지가 나타날 수 있습니다.
<Computer Name>에게 메시지를 보내는 동안 오류가 발생했습니다.
메시지 별칭이 네트워크에 없습니다.
NET HELPMSG 2273을(를) 입력하면 도움말을 더 볼 수 있습니다.
다음 경우 중 하나에 해당하면 이러한 문제가 발생합니다.
  • 원본 컴퓨터가 Microsoft Windows XP SP2를 실행합니다.
  • 대상 컴퓨터가 Microsoft Windows XP SP2를 실행합니다.
따라서 대상 컴퓨터가 NET SEND 명령으로 보낸 메시지를 받지 못합니다.

원인

이 문제는 메신저 서비스가 해제되어 있기 때문에 발생합니다. NET SEND 명령을 사용하려면 메신저 서비스가 대상 컴퓨터에서 실행되어야 합니다. Microsoft Windows XP SP2를 실행하는 컴퓨터에서는 기본적으로 메신저 서비스가 해제되어 있습니다.

해결 과정

저희가 Messenger 서비스의 시작 유형자동으로 변경하고 Messenger 서비스를 시작하도록 하려면 "해결 지원" 절로 이동하십시오. 이 문제를 직접 해결하려면 "직접 해결" 절로 이동하십시오.

해결 지원



이 문제를 자동으로 해결하려면 Fix it 단추나 링크를 클릭합니다. 파일 다운로드 대화 상자에서 실행을 클릭하고 Fix it 마법사의 단계를 따릅니다.


문제 자동 해결
Microsoft Fix it 50551

참고
  • 이 마법사는 영어로만 제공될 수 있습니다. 그러나 다른 언어 버전의 Windows에서도 자동 해결 기능을 사용할 수 있습니다.
  • 현재 문제가 있는 컴퓨터에서 작업하고 있지 않은 경우 Fix it 솔루션을 플래시 드라이브 또는 CD에 저장한 후 문제가 있는 컴퓨터에서 실행하십시오.

그런 다음 "문제가 해결되었습니까?" 절로 이동하십시오.



직접 해결

이 문제를 해결하려면 메신저 서비스의 시작 유형자동으로 변경한 다음 메신저 서비스를 시작합니다. 이렇게 하려면 다음과 같이 하십시오.
  1. Windows 탐색기를 엽니다.
  2. 왼쪽 창에서 내 컴퓨터를 마우스 오른쪽 단추로 클릭한 다음 관리를 클릭합니다.
  3. 컴퓨터 관리 창의 왼쪽 창에서 서비스 및 응용 프로그램을 확장한 다음 서비스를 클릭합니다.
  4. 오른쪽 창에서 Messenger를 두 번 클릭합니다.
  5. Messenger 속성(로컬 컴퓨터) 대화 상자에서 일반 탭을 클릭합니다.
  6. 일반 탭의 시작 유형 목록에서 자동을 선택한 다음 적용을 클릭합니다.
  7. 서비스 상태에서 시작을 클릭한 다음 확인을 클릭합니다.

현재 상태

이것은 의도적으로 설계된 동작입니다.

추가 정보

NET SEND 명령을 사용하는 대신 전자 메일 메시지를 보내는 방법 등의 다른 방법을 사용하여 Windows 사용자나 컴퓨터와 통신할 수 있습니다.

주의 사용 중인 컴퓨터가 인터넷에 연결되어 있는 경우에는 메신저 서비스를 사용할 수 있도록 설정하지 마십시오.

참조

NET SEND 명령에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
826278 net send 명령을 사용하여 전송된 메시지를 받지 못함

문제가 해결되었습니까?

  • 문제가 해결되었는지 확인합니다. 문제가 해결되었다면 이 절에서 설명한 작업이 끝난 것이지만 문제가 해결되지 않은 경우에는 기술 지원 서비스에 문의할 수 있습니다.
  • 의견을 보내 주셔서 감사합니다. 의견을 보내거나 이 해결 방법에 대한 문제점을 보고하려면 "Fix it for me" 블로그에 의견을 남겨 주시거나 전자 메일을 보내 주십시오.

속성

기술 자료: 839018 - 마지막 검토: 2011년 5월 17일 화요일 - 수정: 4.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft SQL Server 2000 Standard Edition
키워드:?
kbsqlsetup kbquery kbsecurity kbservice kbeventservice kbenable kbnetwork kberrmsg kbprb kbfixme kbmsifixme KB839018

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com