Oprava: Součásti Windows Media úniku paměti při vytváření vlastních aplikací

Překlady článku Překlady článku
ID článku: 839203 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při vytváření vlastních aplikací, které jsou integrovány na Windows Media 9 Series Software Development Kit (SDK) a, které Digitalizovat zvuk a video, (Vývojář) můžete zaznamenat stabilní nárůst využití paměti. Například si všimněte stabilní nárůst využití paměti v virtuálních bajtů, soukromé bajty a pracovní sady.

Příčina

K tomuto problému může dojít z libovolného z následujících důvodů:
  • Zápis souboru ASF DirectShow nevrací při volána metoda SetFileName() bez odebrání souboru jímky filtru z grafu. Nevrací paměť je přidružena řetězec názvu souboru.
  • Windows Media SDK nevrací paměť kvůli způsobu jsou struktur typ média přidělené a uvolněno.

Řešení

Společnost Microsoft má nyní k dispozici podporovanou opravu hotfix, která je však určena pouze k opravě problému popsaného v tomto článku. Tuto opravu použijte pouze u systémů, ve kterých dochází k popsanému problému.

Potřebujete-li odstranit tento problém, obraťte se na služby odborné pomoci společnosti Microsoft, kde můžete tuto opravu hotfix získat. Úplný seznam telefonních čísel služeb technické podpory společnosti Microsoft a informace o cenách technické podpory naleznete na tomto webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Poplatky, které je třeba obvykle zaplatit za telefonní hovory, mohou být stornovány, jestliže pracovník technické podpory společnosti Microsoft zjistí, že oznámený problém lze vyřešit konkrétní aktualizací. Další dotazy a žádosti o odbornou pomoc, které se netýkají této zvláštní opravy, podléhají běžným sazbám za poskytnutí odborné pomoci.

Na webu služby Stažení softwaru je k dispozici ke stažení následující soubor:
Zmenšit tento obrázekZvětšit tento obrázek
Download
Download the WindowsMedia9-KB839203-ENU.exe package now.Další informace o tom, jak stahovat soubory podpory společnosti Microsoft, naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
119591Jak získat soubory podpory společnosti Microsoft ze serverů služeb online
Microsoft tento soubor zkontroloval na výskyt virů. Společnost Microsoft použila aktuální antivirový software, který byl k dispozici v den uveřejnění tohoto článku. Soubor je uložený na zabezpečených serverech neumožňujících neoprávněné změny souborů.

Anglická verze této opravy hotfix má následující nebo vyšší atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-Feb-2004  09:42  9.0.0.3125        241,664  Qasf.dll         
   19-Mar-2004  11:24  9.0.0.3148      2,070,640  Wmvcore.dll

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech společnosti, které jsou uvedeny v části "Platí pro" v tomto článku.

Aktuálně balíčky jsou k dispozici v jazycích, které jsou uvedeny výše v tomto článku. Úplný seznam telefonních čísel podpory pro produkty společnosti Microsoft a informace o cenách podpory naleznete na následujícím webu společnosti Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
Poznámka: Poplatky, které je třeba obvykle zaplatit za telefonní hovory, mohou být stornovány, jestliže pracovník technické podpory společnosti Microsoft zjistí, že oznámený problém lze vyřešit konkrétní aktualizací. Další dotazy a žádosti o odbornou pomoc, které se netýkají této zvláštní opravy, podléhají běžným sazbám za poskytnutí odborné pomoci.

Další informace

Ke zvýšení paměti, které jsou způsobeny problému popsaného v tomto článku určitých aplikací sběr dat může také problémy, které jsou způsobeny fragmentace haldy. Tyto problémy můžete vyřešit povolením možnost Nízká fragmentace haldy (LFH) v podporovaných platformách.

Další informace o haldy pro nízkou fragmentaci na webu služby MSDN:
http://msdn2.microsoft.com/en-us/library/aa366750.aspx

Vlastnosti

ID článku: 839203 - Poslední aktualizace: 23. ledna 2007 - Revize: 3.0
Informace v tomto článku jsou určeny pro produkt:
  • Windows Media 9 Series Software Development Kit
Klíčová slova: 
kbmt kbdownload kbfix kbhotfixserver KB839203 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:839203

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com