REVISIÓN: Los componentes de Windows Media pierden memoria cuando crea aplicaciones personalizadas

Seleccione idioma Seleccione idioma
Id. de artículo: 839203 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Al crear aplicaciones personalizadas que están integradas en el Kit de desarrollo de software (SDK) de Windows Media 9 Series y que capturar audio y vídeo, (programador) puede observar un aumento constante en el uso de memoria. Por ejemplo, observe un aumento constante en el uso de memoria en bytes virtuales, bytes privados y conjuntos de trabajo.

Causa

Este problema puede ocurrir por uno de los siguientes motivos:
  • El escritor de archivo ASF de DirectShow pérdidas cuando se llama al método SetFileName() sin quitar el filtro de receptor de archivo del gráfico. Pérdidas de la memoria que está asociada con la cadena de nombre de archivo.
  • El SDK de Windows Media pérdidas de memoria de la forma que las estructuras de tipo de medios se asignan y liberan.

Solución

Ahora es disponible en Microsoft un hotfix compatible, pero sólo se diseñó para corregir el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Para resolver el problema, póngase en contacto con los Servicios de soporte técnico de Microsoft con el fin de obtener el hotfix. Para obtener una lista completa de los números de teléfono de los servicios de soporte técnico de Microsoft e información acerca de los costos de soporte, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota en casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.

El archivo siguiente está disponible para descargarlo del Centro de descarga de Microsoft:
Contraer esta imagenAmpliar esta imagen
Download
Download the WindowsMedia9-KB839203-ENU.exe package now.Para obtener información adicional acerca de cómo descargar los archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
119591Cómo obtener Archivos de soporte técnico de Microsoft desde los servicios en línea
Microsoft exploró este archivo en busca de virus. con el software de detección de virus más reciente disponible en la fecha de publicación. Asimismo, el archivo se almacenó en servidores seguros que ayudan a impedir la realización de cambios no autorizados.

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-Feb-2004  09:42  9.0.0.3125        241,664  Qasf.dll         
   19-Mar-2004  11:24  9.0.0.3148      2,070,640  Wmvcore.dll

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".

Actualmente, los paquetes están disponibles en los idiomas que aparecen anteriormente en este artículo. Para obtener una lista completa de los números de teléfono de servicios de soporte de técnico de Microsoft e información acerca de los costos de soporte, visite el siguiente sitio Web:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
Nota en casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.

Más información

Además de aumentos de memoria que están provocados por el problema descrito en este artículo, algunas aplicaciones de captura también pueden experimentar problemas ocasionados por la fragmentación del montón. Puede resolver estos problemas habilitando la opción de montón (LFH) de fragmentación baja de plataformas compatibles.

Para obtener más información sobre el montón de fragmentación baja, visite el siguiente sitio Web de MSDN:
http://msdn2.microsoft.com/en-us/library/aa366750.aspx

Propiedades

Id. de artículo: 839203 - Última revisión: martes, 23 de enero de 2007 - Versión: 3.0
La información de este artículo se refiere a:
  • Windows Media 9 Series Software Development Kit
Palabras clave: 
kbmt kbdownload kbfix kbhotfixserver KB839203 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 839203

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com