Un'operazione di backup di stato del sistema ha esito negativo quando tenta di eseguire il backup i nodi di log eventi personalizzato in Windows Server 2003

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Sintomi

Quando si tenta di eseguire il backup di informazioni di stato del sistema su computer basato su Microsoft Windows Server 2003, l'operazione di backup ha esito negativo. L'operazione di backup non riesce quando tenta di nodi di log eventi personalizzato che è stato creato il backup.

Cause

Questo problema si verifica se entrambe le seguenti condizioni sono vere:
  • Esegue il backup le informazioni di stato del sistema utilizzando un programma di backup che non supporta la funzionalità di copia shadow volume Windows.
  • I nodi del log eventi personalizzato presentano nomi che sono 12 o più caratteri in lunghezza.
Quando si crea un nodo log eventi personalizzato, un'estensione evt viene aggiunto al nome del nodo. Tuttavia, se il nome del nodo è più di 8 caratteri, l'estensione del nome di file viene troncato in modo che il nome completo del file non più di 12 caratteri. Se il nome del file è di 12 caratteri o più, non viene aggiunta l'estensione evt. In questo scenario, quando il file non dispone di un'estensione di file, il programma di backup considera il file da un file di hive del Registro di sistema e tenta di eseguire il backup, utilizzando un metodo diverso non viene utilizzata per i file del registro eventi. Di conseguenza, l'operazione di backup è riuscito.

Risoluzione

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

Per installare questo aggiornamento rapido (hotfix) non è richiesto alcun prerequisito.

Necessità di riavvio

Occorre riavviare il computer per applicare le modifiche dopo avere installato questo aggiornamento rapido (hotfix).

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o successivi) elencati nella tabella riportata di seguito. Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   11-Feb-2004  22:20  5.2.3790.1154     158,208  Eventlog.dll   

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a" di questo articolo.

Informazioni

Dopo aver installato questo aggiornamento rapido (hotfix), le seguenti modifiche in Windows:
  • Quando si crea un nuovo nodo log eventi personalizzato creando una nuova chiave del Registro di sistema in
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\EventLog
    il nuovo file registro viene creato con un'estensione di file con estensione evt nella cartella %SystemRoot%System32\Config. Ad esempio, se si crea un log eventi personalizzato denominato "Risorse log personalizzato", il nuovo file registro è denominato, "My Custom Log.evt". In un computer in cui non è installato questo aggiornamento rapido (hotfix), il nuovo file registro viene denominato "My Custom Lo".
  • Quando il servizio Registro eventi crea un nuovo log eventi, il valore del Registro di sistema del file correttamente creato viene popolato per puntare al file corretto.
  • Se è stato creato un file di registro prima di applicare questo aggiornamento rapido (hotfix), e file di log è già associato un valore del Registro di sistema di file, il servizio Registro eventi non lo modifica. Questo comportamento legato alla progettazione, perché il valore di file è possibile che sono state intenzionalmente creato come una preferenza utente. Registri di eventi tipici specificare sempre il valore di registro di sistema di file mentre è in esecuzione il programma di installazione.
  • Se è stato creato un file di registro prima di applicare questo aggiornamento rapido (hotfix), e file di log non è presente un valore del Registro di sistema di file, viene creato un nuovo file con estensione evt quando successivamente si riavvia il computer. Ad esempio, se si dispone di un log eventi personalizzato denominato "Risorse Custom log" e se tale log eventi personalizzato non contiene alcun file valore nel Registro di sistema, quando si riavvia il computer, il servizio Registro eventi lasciando il file di registro "My Custom Lo" sul disco rigido e crea un nuovo file "My Custom Log.evt". In questo scenario, il nuovo file viene utilizzato per registrare gli eventi. Tuttavia, gli eventi precedenti rimangono nel file di registro precedente nella cartella %SystemRoot%System32\Config.
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

Identificativo articolo: 839207 - Ultima modifica: martedì 24 luglio 2007 - Revisione: 2.10
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Chiavi: 
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