La característica Buscar de Outlook y las nuevas notificaciones de correo no funcionan después de aplicar el Service Pack 2 de Windows XP

Seleccione idioma Seleccione idioma
Id. de artículo: 839226 - Ver los productos a los que se aplica este artículo
Importante: este artículo contiene información acerca de cómo modificar el Registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad del mismo y de que sabe cómo restaurarlo si se produce algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986 Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

Síntomas

Después de aplicar Microsoft Windows XP Service Pack 2 (SP2) en un equipo, puede observar que se producen los síntomas siguientes en Microsoft Outlook:
  • Al conectarse a un equipo basado en Microsoft Exchange Server y recibir un mensaje de correo electrónico nuevo, no se le pide confirmación con una notificación y el mensaje no aparece automáticamente en la Bandeja de entrada. Si hace clic en Enviar y recibir o en otra carpeta de Outlook, y a continuación hace clic en la carpeta Bandeja de entrada para actualizar el panel de mensajes de Outlook, aparecerán los mensajes de correo electrónico nuevos que tenga.
  • Al intentar enviar un mensaje de correo electrónico en Outlook, puede permanecer en la carpeta Bandeja de salida más tiempo de lo esperado. O bien, puede producirse un retraso antes de enviar el mensaje de correo electrónico.
  • Al utilizar la característica Buscar, Outlook puede dejar de responder. Por ejemplo, si hace clic en Buscar en el menú Herramientas, escribe una palabra en el cuadro Buscar y, a continuación, presiona ENTRAR, Outlook puede dejar de responder.

    Nota: no experimenta este problema con Microsoft Office Outlook 2007 ni con Microsoft Office Outlook 2003 cuando usa la característica Buscar. La característica Buscar de Outlook 2007 y Outlook 2003 funciona como se esperaba.

Causa

Este problema se debe a que Outlook utiliza el protocolo de datagramas de usuarios (UDP, User Datagram Protocol) para recibir las notificaciones de los nuevos mensajes de correo electrónico, actualizar las vistas de carpetas y realizar búsquedas. De forma predeterminada, al aplicar Windows XP Service Pack 2 se activa Firewall de Windows. Firewall de Windows bloquea los paquetes UDP que Outlook utiliza para las notificaciones de mensajes de correo electrónico nuevos y para la característica Buscar.

Dado que UDP es un protocolo sin conexión y el cliente de Outlook no inicia la comunicación con el servidor, Firewall de Windows interpreta los paquetes UDP como no solicitados y los bloquea.

Solución

Para evitar este problema, debe realizar algunos cambios de configuración en Firewall de Windows para Microsoft Office Outlook 2007, Microsoft Office Outlook 2003, Microsoft Outlook 2002 y Microsoft Outlook 2000 con el fin de agregar el programa Outlook.exe a la lista de excepciones.

En Outlook 2002 y Outlook 2000, también debe crear una clave del Registro para invalidar el conjunto de claves del Registro que Windows XP Service Pack 2 mantiene.

En todas las versiones de Outlook

Siga estos pasos para agregar el programa Outlook.exe a la lista Excepciones de Firewall de Windows:
  1. Haga clic en Inicio y en Ejecutar, escriba firewall.cpl y haga clic en Aceptar.
  2. Haga clic en Excepciones y, a continuación, haga clic en Agregar programa.
  3. Busque, seleccione el programa Outlook.exe y, a continuación, haga clic en Agregar.

Información del Registro para Outlook 2002

Para activar el sondeo RPC en Outlook 2002, se necesita Microsoft Office XP Service Pack 1.

Nota: si no se aplica Microsoft Office 2000 Service Pack 3, Outlook 2000 omitirá la clave del Registro ForcePolling.

Debe crear manualmente las claves siguientes para invalidar el valor del Registro ForcePolling que se establece con Windows XP Service Pack 2. Para ello, siga estos pasos.

Advertencia: pueden producirse problemas graves si modifica incorrectamente el Registro mediante el Editor del Registro o con cualquier otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.
  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  2. En el cuadro Abrir, escriba regedit y haga clic en Aceptar.
  3. Busque la siguiente clave del Registro y haga clic en ella para seleccionarla:
    HKEY_CURRENT_USER\Software\Policies\Microsoft
  4. En el menú Modificar, haga clic en Agregar clave y escriba Office. La clase es None.
  5. Haga clic en la clave Office, haga clic en el menú Modificar, haga clic en Agregar clave y escriba 10.0. La clase es None.
  6. Haga clic en la clave 10.0, haga clic en el menú Modificar, haga clic en Agregar clave y escriba Outlook. La clase es None.
  7. Haga clic en la clave Outlook, haga clic en el menú Modificar, haga clic en Agregar clave y escriba RPC. La clase es None.
  8. En el menú Modificar, haga clic en Agregar valor y escriba ForcePolling. El tipo de datos es REG_DWORD y el valor es 1.

Información del Registro para Outlook 2000

Para activar el sondeo RPC en Outlook 2000, se necesita Microsoft Office 2000 Service Pack 3. Una vez aplicada la actualización en el sistema, debe cambiar el Registro. Para ello, siga estos pasos:
  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  2. En el cuadro Abrir, escriba regedit y haga clic en Aceptar.
  3. Busque la siguiente clave del Registro y haga clic en ella para seleccionarla:
    HKEY_CURRENT_USER\Software\Policies\Microsoft
  4. En el menú Modificar, haga clic en Agregar clave y escriba Office. La clase es None.
  5. Haga clic en la clave Office, haga clic en el menú Modificar, haga clic en Agregar clave y escriba 9.0. La clase es None.
  6. Haga clic en la clave 9.0, haga clic en el menú Modificar, haga clic en Agregar clave y escriba Outlook. La clase es None.
  7. Haga clic en la clave Outlook, haga clic en el menú Modificar, haga clic en Agregar clave y escriba RPC. La clase es None.
  8. En el menú Modificar, haga clic en Agregar valor y escriba ForcePolling. El tipo de datos es REG_DWORD y el valor 0.
Nota: si no se aplica Microsoft Office 2000 Service Pack 3, Outlook 2000 omitirá la clave del Registro ForcePolling.

Más información

No puede abrir un número de puerto externo concreto en el Firewall de Windows para evitar este problema en Outlook 2000 y Outlook 2002, porque ambas versiones de Outlook asignan dinámicamente un número de puerto UDP comprendido entre 1024 y 65535.

Outlook 2007 y Outlook 2003 incluyen una clave del Registro que permite la configuración de un puerto UDP estático para los paquetes de notificación de correo nuevo. Esta clave del Registro sólo está disponible en Outlook 2003 o en versiones de Outlook posteriores. Puede modificar la clave del Registro siguiente para especificar un número de puerto UDP:

Outlook 2007

HKEY_CURRENT_USER\Software\Microsoft\Office\12w.0\Outlook\RPC Key: FixedUDPPort

Outlook 2003

HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\RPC Key: FixedUDPPort

Valor: DWORD

El valor decimal del número de puerto debe estar comprendido entre 1024 y 65535.

Para obtener más información, consulte el siguiente artículo de Microsoft Knowledge Base:

264035 No se puede configurar un puerto para paquetes de notificación de correo nuevo UDP

Al utilizar la característica Buscar en Outlook 2003 o en Outlook 2007, no experimenta los síntomas que se describen en la sección "Síntomas". Outlook 2003 y Outlook 2007 no utilizan UDP para realizar las búsquedas.

Referencias

Para obtener más información acerca de ICF, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
320855 Descripción del Servidor de seguridad de conexión a Internet de Windows XP

Propiedades

Id. de artículo: 839226 - Última revisión: miércoles, 09 de mayo de 2007 - Versión: 13.0
La información de este artículo se refiere a:
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002 Standard
  • Microsoft Outlook 2000 Standard
  • Microsoft Outlook 98 Standard
  • Microsoft Outlook 97 Standard
Palabras clave: 
kbfirewall kbprb KB839226

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com