Es posible que los servicios se detengan repentinamente al cerrar o reiniciar un equipo basado en Windows Small Business Server 2003

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Aviso
Importante
Este artículo contiene información sobre cómo modificar el Registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad de él y de que sabe cómo restaurarlo si ocurre algún problema. Para obtener información sobre cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986 Descripción del Registro de Microsoft Windows
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Síntomas

Cuando cierra o inicia un equipo con Microsoft Windows Small Business Server 2003, los servicios que se ejecutan en el equipo se pueden detener inmediatamente antes de que los servicios se puedan cerrar correctamente. A veces, la finalización repentina de estos servicios puede causar pérdida de datos.

Causa

Este problema se produce porque el programa de instalación de Windows Small Business Server 2003 cambia incorrectamente el valor WaitToKillServiceTimeout del Registro a un tipo REG_DWORD. Este valor debe ser del tipo REG_SZ. Por tanto, el sistema interpreta el valor WaitToKillServiceTimeout como 0 milisegundos de tiempo de espera, por lo que finaliza inmediatamente los servicios que se están ejecutando.

Solución


Para resolver este problema, debe eliminar el valor WaitToKillServiceTimeout del Registro y volver a crearlo como un valor del tipo REG_SZ. Para ello, siga estos pasos:

Advertencia
Si utiliza incorrectamente el Editor del Registro puede tener serios problemas que tal vez requieran volver a instalar el sistema operativo. Microsoft no garantiza que pueda solucionar problemas que resulten del uso incorrecto del Editor del Registro. Utilice el Editor del Registro bajo su responsabilidad.
  1. Haga clic en Inicio y en Ejecutar, en el cuadro Abrir escriba regedit y, a continuación, haga clic en Aceptar.
  2. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
  3. Haga clic con el botón secundario del mouse (ratón) en el valor WaitToKillServiceTimeout, haga clic en Eliminar y, después, haga clic en para confirmar la eliminación del valor del Registro.
  4. En el panel de la izquierda del Editor del Registro, haga clic con el botón secundario del mouse (ratón) en Control, seleccione Nuevo y, después, haga clic en Valor alfanumérico.
  5. Cree el valor de Registro siguiente:
    • Nombre de valor: WaitToKillServiceTimeout
    • Tipo de valor: REG_SZ
    • Información del valor: 120000
  6. Cierre el Editor del Registro y reinicie el equipo.

Estado

Microsoft ha confirmado que se trata de un error de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".

Propiedades

Id. de artículo: 839262 - Última revisión: lunes, 3 de diciembre de 2007 - Versión: 1.1
La información de este artículo se refiere a:
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Palabras clave: 
kbbug kbnofix KB839262

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