Des services peuvent s'arrêter brusquement lorsque vous arrêtez ou redémarrez un ordinateur Windows Small Business Server 2003

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Avertissement
Important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986 Description du Registre de Microsoft Windows
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Symptômes

Lorsque vous arrêtez ou redémarrez un ordinateur Windows Small Business Server 2003, des services qui s'exécutent sur l'ordinateur peuvent s'arrêter immédiatement avant de pouvoir être arrêtés correctement. Parfois, l'arrêt brusque de ces services peut provoquer la perte de données.

Cause

Ce problème se produit car le programme d'installation de Windows Small Business Server 2003 définit de manière incorrecte la valeur de Registre WaitToKillServiceTimeout sur le type REG_DWORD. Cette valeur est censée être du type REG_SZ. Par conséquent, le système interprète la valeur WaitToKillServiceTimeout comme un délai d'attente de 0 milliseconde et il arrête immédiatement les services en cours d'exécution.

Résolution


Pour résoudre ce problème, vous devez supprimer la valeur de Registre WaitToKillServiceTimeout, puis la recréer comme valeur de type REG_SZ. Pour cela, procédez comme suit :

Avertissement Toute mauvaise utilisation de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.
  1. Cliquez sur Démarrer, sur Exécuter, tapez regedit dans la zone Ouvrir, puis cliquez sur OK.
  2. Recherchez la sous-clé de Registre suivante et cliquez dessus :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
  3. Cliquez avec le bouton droit sur la valeur WaitToKillServiceTimeout, cliquez sur Supprimer, puis sur Oui pour confirmer la suppression de la valeur de Registre.
  4. Dans le volet gauche de l'Éditeur du Registre, cliquez avec le bouton droit sur Control, pointez sur Nouveau, puis cliquez sur Valeur chaîne.
  5. Créez la valeur de Registre suivante :
    • Nom de la valeur : WaitToKillServiceTimeout
    • Type de la valeur : REG_SZ
    • Données de la valeur : 120000
  6. Fermez l'Éditeur du Registre, puis redémarrez l'ordinateur.

Statut

Microsoft a confirmé l'existence de ce bogue dans les produits Microsoft répertoriés au début de cet article.

Propriétés

Numéro d'article: 839262 - Dernière mise à jour: lundi 3 décembre 2007 - Version: 1.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Mots-clés : 
kbbug kbnofix KB839262
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