How to create an XSLT Data View of a Windows SharePoint Services document library that is grouped by subfolders in FrontPage 2003

Article translations Article translations
Article ID: 839592 - View products that this article applies to.
Expand all | Collapse all

SUMMARY

This article discusses how to use Microsoft Office FrontPage 2003 to create an XSLT Data View of a document library that is grouped by subfolders.

If a document library that is on your Microsoft Windows SharePoint Services Web site contains subfolders and you convert the List View Web Part of the document library to Extensible Stylesheet Language Transformation (XSLT) Data View, the subfolders are no longer displayed in the view. The contents of the subfolders are listed. However, the contents are not grouped according to the subfolders that store the contents. To display the subfolders of a document library after you convert the document library to XSLT Data View, group the view by the path of the subfolders. This article describes how to configure a document library in XSLT Data View so that the view is grouped by the URL Dir Name option.

MORE INFORMATION

This article includes steps that describe how to do the following:
  • Create a document library that contains subfolders.
  • Convert the List View Web Part of the document library to XLST Data View.
  • Use the URL Dir Name option to group the view by the path of the subfolders.
If you have not yet created a document library that contains subfolders, go to step 1 and then follow the remaining steps in this article. If you already created a document library that contains subfolders, go to step 4 and then follow the remaining steps in this article.
  1. Create a new document library in your Windows SharePoint Services Web site. To do this, follow these steps:
    1. Connect to your Windows SharePoint Services Web site, and then click Documents and Lists.
    2. Click Create, and then click Document Library under Document Libraries.
    3. Specify the settings that you want for the new document library, and then click Create.
  2. Create subfolders in the new document library that you created. To do this, follow these steps:
    1. On the DocumentLibraryName page, click New Folder.
    2. Type a name for the new folder in the Name box, and then click Save and Close.
    3. Repeat steps 2a and 2b for each subfolder that you want to create in the document library.
  3. Upload one or more documents to each subfolder in the document library. To do this, follow these steps:
    1. Click the subfolder that you want to upload documents to.
    2. Click Upload Document.
    3. On the DocumentLibraryName: Upload Document page, use one of the following procedures:
      • To upload one document, click Browse, click the file that you want to upload, click Open, and then click Save and Close.
      • To upload multiple documents at the same time, click Upload Multiple Files. Click to select the check boxes that are next to the files that you want to upload, and then click Save and Close.
    4. Repeat steps 3a through 3c for each subfolder in the document library.
  4. Convert the List View Web Part of the document library to XSLT Data View. To do this, follow these steps:
    1. Start FrontPage 2003, and then open the Windows SharePoint Services Web site.
    2. Open the AllItems.aspx page of the document library that you created.
    3. On the View menu, click Page if it is not already selected, and then at the bottom of the page, click Design.
    4. Right-click the List View Web Part, and then click Convert to XSLT Data View.

      Note The subfolders are not displayed in the view.
  5. To group the view by the path of the folder, click Sort & group in the Data View Details task pane.
  6. In the Available fields list of the Sort and Group dialog box, click URL Dir Name, and then click Add.

    Note If URL Dir Name is not displayed in the Available fields list, add URL Dir Name to the list. To do this, follow these steps:
    1. Close the Sort and Group dialog box.
    2. In the Data View Details task pane, click Data source properties.
    3. Under Query in the Data Source Properties dialog box, click Fields.
    4. In the Available fields list of the Displayed Fields dialog box, click URL Dir Name, click Add, and then click OK two times.
  7. Under Group Properties in the Sort and Group dialog box, click to select the Show group header check box, click Collapse group by default, and then click OK.
  8. On the File menu, click Save.

    The paths of the subfolders are displayed as group headers. When you preview the page in a Web browser, the group headers are collapsed. Expand the group headers to view the contents of the subfolders.

REFERENCES

For additional information about how to work with Data Views in FrontPage 2003, see FrontPage 2003 Help. To do this, click Microsoft Office FrontPage Help on the Help menu, type data views in the Search box, and then press ENTER.

Properties

Article ID: 839592 - Last Review: July 28, 2006 - Revision: 1.4
APPLIES TO
  • Microsoft Office SharePoint Portal Server 2003
  • Microsoft Windows SharePoint Services 2.0
  • Microsoft Office FrontPage 2003
Keywords: 
kbdisplay kbhowto kbinfo KB839592

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com