Comment créer une vue de données d'une bibliothèque de documents de Windows SharePoint Services sont regroupées par sous-dossiers FrontPage 2003 XSLT

Traductions disponibles Traductions disponibles
Numéro d'article: 839592 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Résumé

Cet article explique comment utiliser Microsoft Office FrontPage 2003 pour créer une vue de données XSLT d'une bibliothèque de documents sont regroupées en sous-dossiers.

Si une bibliothèque de documents sur votre site Microsoft Windows SharePoint Services Web contient des sous-dossiers et que vous convertissez le composant WebPart Affichage de liste de la bibliothèque de documents en vue de données XSLT (Extensible Stylesheet Language Transformation), les sous-dossiers ne sont plus affichées dans l'affichage. Le contenu des sous-dossiers sera proposé. Toutefois, le contenu n'est pas regroupé en fonction les sous-dossiers qui stockent le contenu. Pour afficher les sous-dossiers d'une bibliothèque de documents après avoir converti la bibliothèque de documents en vue de données XSLT, groupe de l'affichage par le chemin d'accès des sous-dossiers. Cet article explique comment configurer une bibliothèque de documents de vue de données XSLT afin que l'affichage est regroupée par l'option nom de répertoire l'URL .

Plus d'informations

Cet article contient des étapes qui décrivent comment effectuer les opérations suivantes :
  • Créer une bibliothèque de documents contient des sous-dossiers.
  • Convertir le composant WebPart Affichage de liste de la bibliothèque de documents en vue de données XLST.
  • Utiliser l'option nom de répertoire l'URL pour regrouper l'affichage par le chemin d'accès des sous-dossiers.
Si vous n'avez pas encore créé une bibliothèque de documents qui contient des sous-dossiers, passez à étape 1 et suivez les étapes restantes de cet article. Si vous avez déjà créé une bibliothèque de documents contient des sous-dossiers, passez à étape 4 et suivez les étapes restantes de cet article.
  1. Créer une nouvelle bibliothèque de documents dans votre site Web Windows SharePoint Services. Pour ce faire, procédez comme suit :
    1. Connexion au site Web Windows SharePoint Services, puis cliquez sur Documents et listes .
    2. Cliquez sur Créer , puis cliquez sur bibliothèque de documents sous bibliothèques de documents .
    3. Spécifiez les paramètres souhaités pour la nouvelle bibliothèque de document, puis cliquez sur Créer .
  2. Créer des sous-dossiers dans la nouvelle bibliothèque de document que vous avez créé. Pour ce faire, procédez comme suit :
    1. Dans la page DocumentLibraryName, cliquez sur Nouveau dossier .
    2. Tapez un nom pour le nouveau dossier dans la zone Nom , puis cliquez sur Enregistrer et fermer .
    3. Répétez les étapes 2 a et 2 b pour chaque sous-dossier que vous souhaitez créer dans la bibliothèque de documents.
  3. Télécharger un ou plusieurs documents dans chaque sous-dossier dans la bibliothèque de documents. Pour ce faire, procédez comme suit :
    1. Cliquez sur le sous-dossier que vous souhaitez télécharger des documents à.
    2. Cliquez sur Télécharger le document .
    3. Sur la DocumentLibraryName : télécharger un document page, appliquez l'une des procédures suivantes :
      • Pour télécharger un document, cliquez sur Parcourir , cliquez sur le fichier que vous souhaitez télécharger, cliquez sur Ouvrir , puis cliquez sur Enregistrer et fermer .
      • Pour télécharger plusieurs documents en même temps, cliquez sur Télécharger plusieurs fichiers . Activez les cases à cocher qui se trouvent à côté les fichiers que vous souhaitez télécharger, puis cliquez sur Enregistrer et fermer .
    4. Répétez les étapes 3 a à 3c pour chaque sous-dossier dans la bibliothèque de documents.
  4. Convertir le composant WebPart Affichage de liste de la bibliothèque de documents en vue de données XSLT. Pour ce faire, procédez comme suit :
    1. Démarrez FrontPage 2003 et ouvrez le site Web Windows SharePoint Services.
    2. Ouvrez la page AllItems.aspx de la bibliothèque de documents que vous avez créé.
    3. Dans le menu Affichage , cliquez sur page si elle n'est pas déjà sélectionnée et puis en bas de la page, cliquez sur Création .
    4. Cliquez avec le bouton droit sur le composant WebPart Affichage de liste, puis cliquez sur Convertir en vue de données XSLT .

      note Les sous-dossiers ne sont pas affichés dans l'affichage.
  5. Pour regrouper l'affichage par le chemin d'accès du dossier, cliquez sur tri et groupeDans le volet Office Détails d'affichage de données .
  6. Dans la liste Champs disponibles de la boîte de dialogue Trier et regrouper , cliquez sur URL le nom de répertoire , puis cliquez sur Ajouter .

    note Si nom de répertoire l'URL n'est pas affichée dans la liste Champs disponibles , ajoutez le nom de répertoire l'URL à la liste. Pour ce faire, procédez comme suit :
    1. Fermez la boîte de dialogue Trier et regrouper .
    2. Dans le volet de tâches Détails de vue de données , cliquez sur Propriétés de la source de données .
    3. Sous la requête dans la boîte de dialogue Propriétés de la source de données , cliquez sur champs .
    4. Dans la liste Champs disponibles de la boîte de dialogue Champs affichés , cliquez sur le nom de répertoire l'URL , cliquez sur Ajouter et puis cliquez sur OK à deux reprises.
  7. Sous Propriétés du regroupement dans la boîte de dialogue Trier et regrouper , cliquez sur Pour activez la case à cocher Afficher en-tête de groupe , cliquez sur Réduire le groupe par défaut , puis cliquez sur OK .
  8. Dans le menu Fichier , cliquez sur Enregistrer .

    Les chemins des sous-dossiers sont affichées comme des en-têtes de groupe. Lors de l'aperçu de la page dans un navigateur Web, les en-têtes de groupe sont réduits. Développez les en-têtes de groupe pour afficher le contenu des sous-dossiers.

Références

Pour plus d'informations sur l'utilisation des vues de données dans FrontPage 2003, consultez l'aide de Microsoft FrontPage 2003. Pour ce faire, cliquez sur l'aide de Microsoft Office FrontPage dans le menu Aide , tapez les vues de données dans la zone de recherche et appuyez sur ENTRÉE.

Propriétés

Numéro d'article: 839592 - Dernière mise à jour: vendredi 28 juillet 2006 - Version: 1.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office SharePoint Portal Server 2003
  • Microsoft Windows SharePoint Services
  • Microsoft Office FrontPage 2003
Mots-clés : 
kbmt kbdisplay kbhowto kbinfo KB839592 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 839592
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com