Procházení složky Dokumenty v síťové sdílené položce trvá při použití Průzkumníka Windows v počítači se systémem Windows XP déle, než by se dalo očekávat

Překlady článku Překlady článku
ID článku: 840309 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při otevření složky Dokumenty v Průzkumníkovi Windows může zobrazení obsahu složky Dokumenty trvat déle, než by se dalo očekávat.

Příčina

K tomuto problému může docházet v případě, že je složka Dokumenty uložena ve sdílené síťové složce a že používáte počítač se systémem Microsoft Windows XP.

Řešení

Informace o aktualizaci Service Pack

Problém vyřešíte instalací nejnovější aktualizace Service Pack pro systém Microsoft Windows XP. Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
322389 Jak získat nejnovější aktualizaci Service Pack pro systém Windows XP

Informace o kumulativní aktualizaci

Důležité: Tato část, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. V případě úpravy registru nesprávným způsobem však mohou nastat závažné problémy. Proto vždy pečlivě kontrolujte, zda postupujete přesně podle těchto kroků. Jako dodatečnou ochranu registr před úpravami zazálohujte. Potom můžete v případě problému registr obnovit. Další informace o zálohování a obnovení registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
322756 Zálohování, úpravy a obnovení registru v systémech Windows XP a Windows Server 2003


30. července 2004: Tento problém vyřešíte instalací kumulativní aktualizace 871260.

Další informace o kumulativní aktualizaci 871260 získáte v následujícím článku znalostní báze společnosti Microsoft:
871260 Je k dispozici kumulativní aktualizace pro aplikaci Internet Explorer verzí 5.x a 6.0


Důležité informace: Pokud nainstalujete opravu Hotfix 840309, může po nainstalování aktualizace zabezpečení 867801 docházet k potížím. Je možné se jim vyhnout nainstalováním kumulativní aktualizace 871260 místo aktualizace zabezpečení 867801. Další informace o tomto problému získáte v části Známé problémy.

K dispozici je podporovaná oprava hotfix dodávaná společností Microsoft. Tato oprava hotfix je však určená pouze k odstranění problému popsaného v tomto článku. Instalujte ji pouze v systémech, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud vás tedy uvedené potíže příliš neobtěžují, doporučujeme, abyste počkali na další aktualizaci softwaru, která bude tuto opravu obsahovat.

Pokud je k dispozici oprava hotfix ke stažení, na začátku tohoto článku znalostní báze Knowledge Base naleznete oddíl Hotfix download available (Oprava hotfix ke stažení). Pokud zde tento oddíl není uveden, požádejte o poskytnutí opravy hotfix středisko technické podpory a péče o zákazníky společnosti Microsoft.

Poznámka: Máte-li jakékoli další dotazy nebo je-li třeba vyřešit nějaké potíže, je možné, že pro ně bude nutné vytvořit samostatný požadavek na služby. Další dotazy a žádosti o podporu, které se netýkají této konkrétní opravy hotfix, podléhají běžným sazbám za poskytnutí podpory. Úplný seznam telefonních čísel služeb technické podpory a péče o zákazníky společnosti Microsoft a možnost vytvoření samostatného požadavku na služby naleznete na tomto webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Ve formuláři Hotfix download available (Oprava hotfix ke stažení) jsou uvedeny jazyky, v nichž je oprava hotfix k dispozici. Pokud seznam neobsahuje váš jazyk, znamená to, že daná oprava hotfix v tomto jazyku není k dispozici.

Anglická verze této opravy hotfix má následující nebo vyšší atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Při zobrazení informací o souboru jsou data a čas převedeny na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo na ovládacím panelu Datum a čas.

Windows XP

   Datum        Čas    Verze          Velikost   Název souboru
   ----------------------------------------------------------
    8. 4. 2004  20:12  6.0.2800.1514  8 349 184  Shell32.dll
    8. 4. 2004  20:12  6.0.2800.1514    406 528  Shlwapi.dll
    8. 4. 2004  20:12  5.1.2600.1363    676 864  Sxs.dll
   10. 3. 2004  17:59  5.1.2600.1363    593 408  Xpsp2res.dll
    8. 4. 2004  20:12  6.0.2800.1514    921 600  Comctl32.dll
    8. 4. 2004  20:12                     1 812  Controls.man
    8. 4. 2004  20:12                       621  Comctl.man

Systém Windows XP 64-Bit Edition

   Datum        Čas    Verze              Velikost Název souboru  Platforma
   ----------------------------------------------------------------------
    8. 4. 2004  20:05  6.0.2800.1514  14 377 984   Shell32.dll    IA-64
    8. 4. 2004  20:05  6.0.2800.1514   1 112 576   Shlwapi.dll    IA-64
    8. 4. 2004  20:05  5.1.2600.1363   2 018 816   Sxs.dll        IA-64
    8. 4. 2004  20:12  6.0.2800.1514   8 349 184   Wshell32.dll   x86
    8. 4. 2004  20:12  6.0.2800.1514     406 528   Wshlwapi.dll   x86
    8. 4. 2004  20:12  5.1.2600.1363     676 864   Wsxs.dll       x86
   10. 3. 2004  17:59  5.1.2600.1363     593 408   Wxpsp2res.dll  x86
   10. 3. 2004  17:59  5.1.2600.1363     592 896   Xpsp2res.dll   IA-64
    8. 4. 2004  18:47  6.0.2800.1514   2 639 360   Comctl32.dll   IA-64
    8. 4. 2004  20:05                      1 813   Controls.man
    8. 4. 2004  20:05                        623   Comctl.man
Po nainstalování kumulativní aktualizace 871260 nebo opravy hotfix 840309 je nutné přidat novou položku pro následující podklíč registru:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\policies\Explorer

Název položky: UseDesktopIniCache
Typ: DWORD
Hodnota: 1

Proveďte následující kroky a pak ukončete program Editor registru:
  1. V nabídce Start klikněte na příkaz Spustit, zadejte příkaz regedit a potom klikněte na tlačítko OK.
  2. Vyhledejte následující klíč registru a klikněte na něj:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\policies\Explorer
  3. V nabídce Úpravy přejděte na příkaz Nový a pak klikněte na položku Hodnota DWORD.
  4. Zadejte název UseDesktopIniCache a pak stiskněte klávesu ENTER.
  5. V nabídce Úpravy klikněte na příkaz Změnit.
  6. Zadejte hodnotu 1 a klikněte na tlačítko OK.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt. Tento problém byl poprvé opraven aktualizací Microsoft Windows XP Service Pack 2.

Další informace

Známé problémy

Pokud je nainstalována oprava hotfix 840309, může v Průzkumníkovi Windows (Explorer.exe) po nainstalování aktualizace zabezpečení 867801 docházet k neodstranitelným chybám.

Další informace o aktualizaci zabezpečení 867801 získáte v následujícím článku znalostní báze společnosti Microsoft:
867801 MS04-025: Kumulativní aktualizace zabezpečení pro aplikaci Internet Explorer

Pokud jste dosud nenainstalovali aktualizaci zabezpečení 867801, můžete tomuto problému zabránit pomocí jedné z následujících metod:
  • Nainstalujte místo aktualizace zabezpečení 867801 kumulativní aktualizaci 871260.

    Další informace o kumulativní aktualizaci 871260 získáte v následujícím článku znalostní báze společnosti Microsoft:
    871260 Je k dispozici kumulativní aktualizace pro aplikaci Internet Explorer verzí 5.x a 6.0
  • Před nainstalováním aktualizace zabezpečení 867801 odeberte opravu hotfix 840309.
  • Nastavte položku UseDesktopIniCache typu DWORD na hodnotu 0. Postupujte takto:
    1. V nabídce Start klikněte na příkaz Spustit, zadejte příkaz regedit a potom klikněte na tlačítko OK.
    2. Vyhledejte následující podklíč registru a klikněte na něj:
      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\policies\Explorer
    3. Pravým tlačítkem myši klikněte na hodnotu DWORD UseDesktopIniCache a potom klikněte na příkaz Změnit.
    4. Do pole Údaj hodnoty zadejte hodnotu 0 a klikněte na tlačítko OK.
    5. V nabídce Soubor klikněte na příkaz Konec a restartujte počítač.
V případě, že jste již aktualizaci zabezpečení 867801 nainstalovali, je možné se tomuto problému vyhnout tak, že položku DWORD UseDesktopIniCache nastavíte na hodnotu 0 a restartujete počítač. Postupujte následujícím způsobem:
  1. Stiskněte kombinaci kláves CTRL+ALT+DEL a potom klikněte na tlačítko Správce úloh.
  2. V nabídce Soubor klikněte na příkaz Nová úloha (Spustit...).
  3. Do pole Otevřít zadejte příkaz regedit a klikněte na tlačítko OK.
  4. Vyhledejte následující podklíč registru a klikněte na něj:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\policies\Explorer
  5. Pravým tlačítkem myši klikněte na hodnotu DWORD UseDesktopIniCache a potom klikněte na příkaz Změnit.
  6. Do pole Údaj hodnoty zadejte hodnotu 0 a klikněte na tlačítko OK.
  7. V nabídce Soubor klikněte na příkaz Konec a restartujte počítač.
Další informace získáte v následujícím článku znalostní báze společnosti Microsoft:
824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 840309 - Poslední aktualizace: 1. prosince 2008 - Revize: 5.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP 64-Bit Edition Version 2003
Klíčová slova: 
kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB840309

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com