Uso del procesador alto de la cola de impresión se produce cuando un usuario cierra una sesión en un servidor Terminal Server que ejecuta Windows Server 2003 o Windows 2000

Seleccione idioma Seleccione idioma
Id. de artículo: 840371 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando un usuario cierra sesión en una sesión en un servidor de terminal (un servidor que tenga habilitado Terminal Server) que está ejecutando Microsoft Windows 2000 o Microsoft Windows Server 2003, el archivo Spoolsv.exe consume un gran porcentaje de tiempo de procesador durante un breve período de tiempo.

Causa

Este problema se produce cuando un usuario obtiene acceso al servidor de Terminal Server de Windows mediante un cliente de Citrix MetaFrame y ha redirigido a las impresoras del cliente. Cuando el usuario cierra el servidor de terminal server, el servicio de cola se notifica que se purgan las impresoras redirigidas. El servicio de cola, a continuación, notifica al servicio Winlogon de cada sesión que una impresora tiene que estar desactivada. Cada servicio Winlogon, a continuación, consulta el servicio de cola de impresión para una actualización y esto hace que el uso de procesador alta del servicio de cola de impresión.

Solución

Información sobre hotfix de Windows Server 2003

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Windows Server 2003
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   09-Apr-2004  20:11  5.2.3790.159      311,296  Localspl.dll     
   09-Apr-2004  20:11  5.2.3790.121       80,896  Spoolss.dll      
Windows Server 2003, ediciones de 64 bits
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   09-Apr-2004  20:13  5.2.3790.159      857,600  Localspl.dll     
   09-Apr-2004  20:13  5.2.3790.121      233,472  Spoolss.dll      

Información sobre hotfix de Windows 2000

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Mar-2004  02:17  5.0.2195.6824      42,256  Basesrv.dll      
   21-Sep-2003  00:45  5.0.2195.6824     236,304  Cmd.exe          
   07-Apr-2004  20:19  0.2.0.1           138,000  Faxui.dll        
   24-Mar-2004  02:17  5.0.2195.6898     242,448  Gdi32.dll        
   24-Mar-2004  02:17  5.0.2195.6897     742,160  Kernel32.dll     
   07-Apr-2004  20:19  5.0.2195.6920     252,688  Localspl.dll     
   24-Mar-2004  02:17  5.0.2195.6824      54,544  Mpr.dll          
   24-Mar-2004  02:17  5.0.2195.6895     335,120  Msgina.dll       
   24-Mar-2004  02:17  5.0.2195.6892      90,264  Rdpwd.sys
   05-Feb-2004  20:18  5.0.2195.6896   5,869,056  Sp3res.dll       
   07-Apr-2004  20:19  5.0.2195.6876      80,144  Spoolss.dll      
   24-Mar-2004  02:17  5.0.2195.6897     403,216  User32.dll       
   05-Aug-2003  22:14  5.0.2195.6794     385,808  Userenv.dll      
   11-Mar-2004  02:37  5.0.2195.6897   1,720,368  Win32k.sys
   19-Jun-2003  20:05  5.0.2195.6681      97,040  Win32spl.dll     
   11-Mar-2004  02:37  5.0.2195.6898     181,520  Winlogon.exe     
   07-Apr-2004  20:19  5.0.2195.6920     243,984  Winsrv.dll       
   24-Mar-2004  02:17  5.0.2195.6897     742,160  Kernel32.dll     
   11-Mar-2004  02:37  5.0.2195.6897   1,720,368  Win32k.sys
   07-Apr-2004  20:19  5.0.2195.6920     243,984  Winsrv.dll       

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener información adicional, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura de archivos para los paquetes de actualización de software de Microsoft Windows
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft
Los productos de terceros que se analizan en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, respecto al rendimiento o confiabilidad de estos productos.

Propiedades

Id. de artículo: 840371 - Última revisión: martes, 24 de julio de 2007 - Versión: 1.11
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Palabras clave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbwinserv2003presp1fix KB840371 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 840371

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com