Intenso utilizzo del processore da parte dello spooler quando un utente si disconnette da una sessione su un server Terminal basato su Windows Server 2003 o su Windows 2000

Traduzione articoli Traduzione articoli
Identificativo articolo: 840371 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando un utente si disconnette da una sessione su un server Terminal, ovvero un server in cui è abilitato il servizio Terminal Server, basato su Microsoft Windows 2000 o su Microsoft Windows Server 2003, per un breve periodo il file Spoolsv.exe utilizza un'ampia percentuale del tempo processore.

Cause

Questo problema si verifica quando un utente accede al server Windows Terminal Server utilizzando un client Citrix Metaframe e sono presenti delle stampanti client reindirizzate. Quando l'utente si disconnette dal server, al servizio Spooler viene notificato che è necessario rimuovere le stampanti reindirizzate. Il servizio Spooler notifica quindi al servizio Winlogon di ogni sessione che una stampante deve essere rimossa. A sua volta, ogni servizio Winlogon interroga il servizio Spooler alla ricerca di un aggiornamento, determinando in tal modo un utilizzo elevato del processore da parte del servizio Spooler.

Risoluzione

Informazioni sull'hotfix per Windows Server 2003

È disponibile un hotfix supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. È possibile che su questo hotfix vengano eseguiti ulteriori test. Se dunque questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows Server 2003 contenente tale hotfix.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

Prerequisiti

Non è richiesto alcun prerequisito.

Richiesta di riavvio

È necessario riavviare il computer una volta applicato l'hotfix.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
Windows Server 2003
   Data        Ora    Versione       Dimensione  Nome file
   ----------------------------------------------------------
   09/04/2004  20.11  5.2.3790.159      311.296  Localspl.dll     
   09/04/2004  20.11  5.2.3790.121       80.896  Spoolss.dll
Windows Server 2003, edizioni a 64 bit
   Data        Ora    Versione       Dimensione  Nome file
   ----------------------------------------------------------
   09/04/2004  20.13  5.2.3790.159      857.600  Localspl.dll     
   09/04/2004  20.13  5.2.3790.121      233.472  Spoolss.dll

Informazioni sull'hotfix per Windows 2000

È disponibile un hotfix supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. È possibile che su questo hotfix vengano eseguiti ulteriori test. Se pertanto questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows 2000 contenente tale hotfix.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix. Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

Prerequisiti

Non è richiesto alcun prerequisito.

Richiesta di riavvio

È necessario riavviare il computer una volta applicato l'hotfix.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione in lingua inglese di questo hotfix presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data        Ora    Versione       Dimensione  Nome file
   ----------------------------------------------------------
   24/03/2004  02.17  5.0.2195.6824      42.256  Basesrv.dll      
   21/09/2003  00.45  5.0.2195.6824     236.304  Cmd.exe          
   07/04/2004  20.19  0.2.0.1           138.000  Faxui.dll        
   24/03/2004  02.17  5.0.2195.6898     242.448  Gdi32.dll        
   24/03/2004  02.17  5.0.2195.6897     742.160  Kernel32.dll     
   07/04/2004  20.19  5.0.2195.6920     252.688  Localspl.dll     
   24/03/2004  02.17  5.0.2195.6824      54.544  Mpr.dll          
   24/03/2004  02.17  5.0.2195.6895     335.120  Msgina.dll       
   24/03/2004  02.17  5.0.2195.6892      90.264  Rdpwd.sys
   05/02/2004  20.18   5.0.2195.6896  5.869.056  Sp3res.dll
   07/04/2004  20.19  5.0.2195.6876      80.144  Spoolss.dll      
   24/03/2004  02.17  5.0.2195.6897     403.216  User32.dll       
   05/08/2003  22.14  5.0.2195.6794     385.808  Userenv.dll      
   11/03/2004  02.37  5.0.2195.6897   1.720.368  Win32k.sys
   19/06/2003  20.05  5.0.2195.6681      97.040  Win32spl.dll     
   11/03/2004  02.37  5.0.2195.6898     181.520  Winlogon.exe     
   07/04/2004  20.19  5.0.2195.6920     243.984  Winsrv.dll       
   24/03/2004  02.17  5.0.2195.6897     742.160  Kernel32.dll     
   11/03/2004  02.37  5.0.2195.6897   1.720.368  Win32k.sys
   07/04/2004  20.19  5.0.2195.6920     243.984  Winsrv.dll

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine del presente articolo.

Informazioni

Per ulteriori informazioni, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
816915 Nuovo schema di assegnazione dei nomi per i pacchetti di soluzioni rapide di Microsoft Windows
824684 Descrizione della terminologia standard utilizzata per illustrare gli aggiornamenti software Microsoft
I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilità di tali prodotti.

Proprietà

Identificativo articolo: 840371 - Ultima modifica: venerdì 31 marzo 2006 - Revisione: 1.5
Le informazioni in questo articolo si applicano a
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Chiavi: 
kbbug kbfix kbqfe kbwinserv2003presp1fix kbhotfixserver KB840371
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com