Daten werden nicht dekomprimiert, wenn Sie Verhalten mit komprimierten Daten in Internet Explorer 6 verwenden

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Artikel-ID: 840388 - Produkte anzeigen, auf die sich dieser Artikel bezieht
wichtig Dieser Artikel enthält Informationen zum Ändern der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie in folgendem Artikel der Microsoft Knowledge Base:
256986Beschreibung der Microsoft Windows-Registrierung
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Problembeschreibung

Wenn Sie Verhaltensweisen, verwenden um Informationen aus einer Datei an ein HTML-Dokument zu downloaden und statische Komprimierung in Microsoft Internet Information Services (IIS aktiviert ist), nicht die Daten, die zum HTML-Dokument heruntergeladen wird immer angezeigt. In der Regel lädt das Dokument wie beim ersten Versuch erwartet. Dynamische Daten können jedoch nicht angezeigt, wenn Sie versuchen, es erneut downloaden.

Ursache

Dieses Problem, da Microsoft Internet Explorer immer komprimierte Daten als zwischengespeichert wird,, liest auch wenn die Cache-Control-Einstellung auf einen anderen Wert angibt.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time () angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   16-Apr-2004  01:58  6.0.2800.1421  485,888  Urlmon.dll       
   16-Apr-2004  01:59  6.0.2800.1421  589,824  Wininet.dll
				

Informationen zur Installation

Warnung Fehlerhafte Verwendung des Registrierungseditors kann schwerwiegende Probleme verursachen, die eine Neuinstallation Ihres Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die Verwendung des Registrierungseditors entstehen, behoben werden können. Benutzen Sie den Registrierungseditor auf eigene Verantwortung.

Nachdem Sie diesen Hotfix installiert haben, gehen Sie folgendermaßen vor:
  1. Beenden Sie Internet Explorer.
  2. Klicken Sie auf Start , und klicken Sie dann auf Ausführen .
  3. Geben Sie in das Feld Öffnen regedit ein und klicken Sie dann auf OK .
  4. Klicken Sie auf folgenden Unterschlüssel in der Registrierung:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_TEMPORARYFILES_FOR_NOCACHE_840387
  5. Klicken Sie auf Bearbeiten , zeigen Sie auf neu und klicken Sie dann auf DWORD-Wert .
  6. Geben Sie Iexplore.exe , und drücken Sie anschließend die [EINGABETASTE].
  7. Klicken Sie mit der rechten Maustaste auf Iexplore.exe , und klicken Sie dann auf Ändern .
  8. Geben Sie in das Feld Wertdaten 00000001 und klicken Sie dann auf OK .
  9. Klicken Sie im Menü Datei auf Beenden , um den Registrierungseditor zu beenden.

Abhilfe

Dieses Verhalten zu für dynamisches HTML (DHTML) umgehen Funktionalität, statische Komprimierung unter IIS für maximale Kompatibilität deaktivieren.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft Internet Explorer 6 handelt.

Informationsquellen

Weitere Informationen finden Sie die folgende KB-Artikelnummer:
255801Wie Sie bestimmen Wenn HTTP-Komprimierung in Gebrauch ist
Informationen zum Entwickeln von webbasierten Lösungen für Microsoft Internet Explorer finden Sie auf folgenden Websites:

http://msdn2.microsoft.com/en-us/ie/default.aspx

http://msdn2.microsoft.com/en-us/library/aa286532.aspx

Eigenschaften

Artikel-ID: 840388 - Geändert am: Mittwoch, 29. August 2007 - Version: 4.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Internet Explorer (Programming) 6.0
Keywords: 
kbmt kbautohotfix kbhotfixserver kbqfe kbie600sp2fix kbie600presp2fix kbfix kbbug KB840388 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 840388
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