文書番号: 840634 - 最終更新日: 2007年12月27日 - リビジョン: 6.1

Windows XP Service Pack 2 の Windows ファイアウォールを構成して、WMI、RPC、または DCOM を使用するリモート管理ツールを利用可能にする方法

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この資料は、上級レベルのコンピュータ ユーザーを対象としています。高度なトラブルシューティングに慣れていない場合には、サポート担当者にお問い合わせください。お問い合わせ方法については、以下のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)

重要 : 以下の手順を実行すると、セキュリティ リスクが高まるおそれがあります。また、悪意のあるユーザーやウイルスなど悪意のあるソフトウェアによる攻撃をコンピュータまたはネットワークが受けやすくなる場合もあります。この資料の手順は、プログラムの設計どおりの動作を可能にする場合、または特定のプログラム機能を実装する場合にお勧めします。これらの変更を行う前に、記載された回避策を現在の環境に適用した場合の危険性を評価することをお勧めします。この手順の使用を選択した場合は、記載されている手順以外にも、システムを保護するための適切な手順を実行してください。この手順はどうしても必要な場合にのみ実行することをお勧めします。

目次

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現象

Windows XP Service Pack 2 (SP2) が実行されているコンピュータをリモート管理する場合に、次のいずれかのようなエラー メッセージが表示されることがあります。
コンピュータ \\COMPUTERNAME.EXAMPLE.COM を管理できません。ネットワークパスが見つかりません。

[別のコンピュータへ接続] を [操作] メニューから選んで別のコンピュータを管理してください。
ComputerName にアクセスできません。
アクセスが拒否されました。
ComputerName にアクセスできません。
ネットワーク パスが見つかりません。
ComputerName のグループ ポリシー オブジェクトを開くことができませんでした。適切な権利がない可能性があります。
詳細 : ネットワーク パスが見つかりません。
Computer という名前のオブジェクトが見つかりません。選択したオブジェクトの種類と場所が正確で、入力したオブジェクト名が正しいことを確認してください。または選択した項目からこのオブジェクトを削除してください。
システム エラー 53 が発生しました。ネットワーク パスが見つかりません。

原因

この問題は、次のいずれかの Microsoft 管理コンソール (MMC) スナップインを使用してリモート コンピュータを管理する場合に、発生することがあります。
  • 証明書
  • コンピュータの管理
  • デバイス マネージャ
  • ディスクの管理
  • イベント ビューア
  • グループ ポリシー
  • インデックス サービス
  • IP セキュリティ モニタ
  • IP セキュリティ ポリシー
  • ローカル ユーザーとグループ
  • リムーバブル記憶域の管理
  • ポリシーの結果セット
  • サービス
  • 共有フォルダ
  • WMI コントロール
また、この問題は、Net.exe ツールを使用してリモート コンピュータを管理する場合、または次のダイアログ ボックスからリモート コンピュータにアクセスする場合に、発生することがあります。
  • ユーザー、コンピュータ、またはグループの選択
  • ユーザー、連絡先およびグループの検索
  • Net.exe
この問題は、Windows XP SP2 の Windows ファイアウォール プログラムのデフォルトの構成では、TCP (Transmission Control Protocol) ポート 445 の着信ネットワーク トラフィックがブロックされることが原因で発生します。この資料に記載されている管理ツールを使用してリモート コンピュータに接続するには、対象のリモート コンピュータで TCP ポート 445 の着信ネットワーク トラフィックが許可されている必要があります。

解決方法

この問題を解決するには、以下のいずれかの手順を実行します。

方法 1 と方法 2 では、それぞれのコンピュータでの問題の解決方法を説明します。方法 3 では、グループ ポリシーを使用して複数のコンピュータで問題を解決する方法を説明します。

上級レベルのユーザー

これらの方法は、上級レベルのコンピュータ ユーザーを対象としています。高度なトラブルシューティングに慣れていない場合には、サポート担当者にお問い合わせください。お問い合わせ方法については、以下のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)

方法 1 : Netsh コマンド ライン ツールを使用する

Windows XP SP2 ベースのリモート コンピュータで netsh コマンドを実行して、TCP ポート 445 のトラフィックが Windows ファイアウォールを通過できるようにします。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに cmd と入力し、[OK] をクリックします。
  2. 次のコマンドを入力し、Enter キーを押します。
    netsh firewall set portopening tcp 445 smb enable
    次のメッセージが表示されます。
    OK
  3. コマンド プロンプトを閉じます。
組織全体にこの変更を適用するには、この netsh コマンド ラインをバッチファイルかスクリプトから実行します。

方法 2 : グラフィカル ユーザー インターフェイスを使用する

Windows XP SP2 ベースのリモート コンピュータで、Windows ファイアウォールの構成を変更して、TCP ポート 445 の着信トラフィックを許可します。
  1. [スタート] ボタンをクリックし、[コントロール パネル] をクリックします。
  2. [セキュリティ センター] をクリックし、[Windows ファイアウォール] をクリックします。
  3. [例外] タブをクリックし、[ファイルとプリンタの共有] チェック ボックスをオンにし、[編集] をクリックします。
  4. [TCP 445] チェック ボックスをオンにし、[スコープの変更] をクリックし、次のいずれかの操作を行います。
    • [ユーザーのネットワーク (サブネット) のみ] をクリックします。
    • [カスタムの一覧] をクリックし、このコンピュータを管理する IP アドレスを入力します。
  5. [OK] を 3 回クリックします。

方法 3 : グループ ポリシーを使用して "リモート管理の例外を許可する" ポリシーを設定する

: この手順では、このポリシーを使用して管理するコンピュータがすべて同じ組織単位に属していることが前提となっています。グループ ポリシーの使用方法の詳細については、次のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/japan/windowsserver2003/technologies/management/grouppolicy/default.mspx (http://www.microsoft.com/japan/windowsserver2003/technologies/management/grouppolicy/default.mspx)
この手順では、Windows ファイアウォールがドメイン プロファイルを使用するように構成されていることが前提となっています (ドメイン プロファイルを使用する方法が最も一般的です)。Windows ファイアウォールのプロファイルの詳細、および Windows で読み込まれるプロファイルが決定されるしくみについては、『Microsoft Windows XP Service Pack 2 向け Windows ファイアウォール設定の導入』を参照してください。このドキュメントを入手するには、次のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/downloads/details.aspx?displaylang=ja&FamilyID=4454e0e1-61fa-447a-bdcd-499f73a637d1 (http://www.microsoft.com/downloads/details.aspx?displaylang=ja&FamilyID=4454e0e1-61fa-447a-bdcd-499f73a637d1)
グループ ポリシーを構成してコンピュータのリモート管理を許可するには、次の手順を実行します。
  1. 管理対象の Windows XP SP2 ベースのコンピュータを含む組織単位のグループ ポリシー オブジェクトを作成します。
    1. ドメイン コントローラにログオンします。
    2. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに dsa.msc と入力し、[OK] をクリックします。
    3. ドメインを展開し、グループ ポリシーを作成する組織単位を右クリックし、[プロパティ] をクリックします。
    4. [グループ ポリシー] タブをクリックし、[新規] をクリックします。
    5. グループ ポリシー オブジェクトの名前を入力し、Enter キーを押します。
    6. [閉じる] をクリックします。
  2. Windows XP SP2 が実行されているドメイン メンバ コンピュータに、次のいずれかのセキュリティ グループのメンバとなっているユーザーでログオンします。
    • Domain Admins
    • Enterprise Admins
    • Group Policy Creator Owners
  3. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに mmc と入力し、[OK] をクリックします。
  4. [ファイル] メニューの [スナップインの追加と削除] をクリックします。
  5. [スタンドアロン] タブで、[追加] をクリックします。
  6. [スタンドアロン スナップインの追加] ダイアログ ボックスで、[グループ ポリシー オブジェクト エディタ] をクリックし、[追加] をクリックします。
  7. [グループ ポリシー オブジェクトの選択] ダイアログ ボックスで、[参照] をクリックします。
  8. 新しい Windows ファイアウォールの設定に更新するグループ ポリシー オブジェクトをクリックします。たとえば、Windows XP SP2 を実行するコンピュータを含む組織単位をクリックし、[OK] をクリックし、手順 1. で作成したグループ ポリシー オブジェクトをクリックします。
  9. [OK] をクリックし、[完了] をクリックします。
  10. [閉じる] をクリックし、[OK] をクリックします。
  11. [コンソール ルート] の下にある、手順 8. で選択したグループ ポリシー オブジェクトを展開し、[コンピュータの構成]、[管理用テンプレート]、[ネットワーク]、[ネットワーク接続]、[Windows ファイアウォール] を順に展開し、[ドメイン プロファイル] をクリックします。
  12. 右側のウィンドウで、[Windows ファイアウォール : リモート管理の例外を許可する] をダブルクリックします。
  13. [有効] をクリックし、[要請されない着信メッセージを許可するアドレス] ボックスで管理スコープを指定します。たとえば、特定の IP アドレスからのリモート管理を許可するには、[要請されない着信メッセージを許可するアドレス] ボックスに、その IP アドレスを入力します。

    特定のサブネットからのリモート管理を許可するには、CIDR (Classless Internet Domain Routing) 形式で、そのサブネットを入力します。この場合、24 ビットのサブネット マスク 255.255.255.0 を持つネットワーク 192.168.1.0 を指定するには、192.168.1.0/24 と入力します。有効な管理スコープの指定方法の詳細については、このポリシーの [設定] タブの [構文] の箇所を参照してください。
  14. [OK] をクリックし、[ファイル] メニューの [終了] をクリックします。

詳細

クライアント管理ツールは、Microsoft 管理コンソール (MMC) スナップインがセットになったものであり、これらのツールを使用して、ローカル コンピュータおよびリモート コンピュータのユーザー、コンピュータ、サービス、その他のシステム コンポーネントを管理することができます。

関連情報

Windows ファイアウォールを介して接続する方法の詳細については、次のマイクロソフト Web サイトを参照してください。
http://msdn2.microsoft.com/en-us/library/aa389286.aspx (http://msdn2.microsoft.com/en-us/library/aa389286.aspx)
リモート管理の例外を有効または無効にする方法の詳細については、次のマイクロソフト Web サイトを参照してください。
http://technet2.microsoft.com/windowsserver/en/library/b8057a7a-a0d3-40b5-8224-ea6a4f5e17231033.mspx?mfr=true (http://technet2.microsoft.com/windowsserver/en/library/b8057a7a-a0d3-40b5-8224-ea6a4f5e17231033.mspx?mfr=true)
関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
832578? (http://support.microsoft.com/kb/832578/ ) Delprof.exe を使用してリモート コンピュータのアクティブでないプロファイルを削除すると、エラー メッセージ "ネットワークパスが見つかりません" が表示される
上記の資料で問題が解決しなかった場合、または、この資料に記載されている現象とは異なる現象が発生する場合に、関連情報を参照するには、「サポート技術情報」 (Microsoft Knowledge Base) を検索してください。「サポート技術情報」を検索するには、次のマイクロソフト Web サイトにアクセスします。
http://support.microsoft.com (http://support.microsoft.com/)
[サポート技術情報の検索] ボックスに、表示されるエラー メッセージを入力するか、問題の詳細を入力してください。

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
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