Код статьи: 840634 - Последнее изменение :: 28 декабря 2007 г. - Редакция: 6.1

Настройка брандмауэра Windows в Windows XP с пакетом обновления 2 (SP2) для работы со средствами удаленного администрирования, использующими инструментарий WMI, RPC или DCOM

Совет по использованию системыЭта статья относится к операционной системе, отличной от установленной на вашем компьютере. Содержимое, не относящееся к используемой системе, отключено.
Внимание
Эта статья предназначена для опытных пользователей. Если нет уверенности в правильности своих действий при устранении неполадок дополнительными способами, обратитесь за помощью к другому пользователю или свяжитесь со службой поддержки. Сведения о том, как обратиться в службу технической поддержки, см. на следующем веб-узле корпорации Майкрософт:
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)

Внимание! Выполнение приведенных инструкций понижает уровень безопасности и повышает степень уязвимости компьютера или сети перед атаками злоумышленников или проникновением вирусов и других вредоносных программ. Чтобы используемые приложения функционировали надлежащим образом, рекомендуется следовать указаниям, приведенным в данной статье. Однако предварительно следует оценить влияние этих действий на безопасность существующего окружения. В случае использования описанного способа устранения неполадки примите все необходимые меры для обеспечения безопасности системы. Данный способ следует использовать только в случае крайней необходимости.

На этой странице

Развернуть все | Свернуть все

Проблема

При попытке удаленного управления компьютером с системой Windows XP с пакетом обновления 2 (SP2) может появиться сообщение об ошибке, подобное одному из перечисленных ниже.
Управлять компьютером \\ИМЯ_КОМПЬЮТЕРА.EXAMPLE.COM невозможно. Не найден сетевой путь.

Выберите команду "Подключиться к другому компьютеру" в меню "Действие" для управления другим компьютером.
Нет доступа к компьютеру Имя_компьютера.
Ошибка: Отказано в доступе.
Нет доступа к компьютеру Имя_компьютера.
Ошибка: Не найден сетевой путь.
Не удалось открыть объект групповой политики на компьютере Имя_компьютера. Возможно, вы не имеете достаточных прав.
Сведения: Не найден сетевой путь.
Не удалось найти объект (компьютер) с именем: "Имя_компьютера. Проверьте правильность и размещение выбранных типов объектов, а также правильность введенного имени объекта, или удалите его из списка выбранных.
Системная ошибка 53. Не найден сетевой путь.

Причина

Проблема связана с управлением удаленным компьютером с помощью одного из следующих средств консоли управления (MMC).
  • Сертификаты
  • Управление компьютером
  • Диспетчер устройств
  • Управление дисками
  • Просмотр событий
  • Групповая политика
  • Служба индексирования
  • Монитор IP-безопасности
  • Политика IP-безопасности
  • Локальные пользователи и группы
  • Управление съемными носителями
  • Результирующая политика
  • Службы
  • Общие папки
  • Управляющий элемент WMI
Кроме того, эта проблема может возникать при управлении удаленным компьютером с помощью средства Net.exe или при попытке получить доступ к удаленному компьютеру с помощью указанных ниже окон.
  • Выбор: пользователи, компьютеры или группы
  • Поиск пользователей, контактов и групп
  • Net.exe
Причина этой проблемы заключается в блокировании входящего сетевого трафика TCP-порта 445 при стандартной конфигурации брандмауэра Windows на компьютере с системой Windows XP с пакетом обновления 2 (SP2). Чтобы использовать перечисленные средства администрирования для подключения к удаленному компьютеру, в его системе должен быть разрешен входящий сетевой трафик по TCP-порту 445.

Решение

Для решения этой проблемы воспользуйтесь одним из предлагаемых способов.

Два первых способа предназначены для решения проблемы на отдельных компьютерах. Способ 3 предназначен для устранения проблемы на нескольких компьютерах с помощью групповой политики.

Для опытных пользователей

Эти способы предназначены для опытных пользователей. Если нет уверенности в правильности своих действий при устранении неполадок дополнительными способами, обратитесь за помощью к другому пользователю или свяжитесь со службой поддержки. Сведения о том, как обратиться в службу технической поддержки, см. на следующем веб-узле корпорации Майкрософт:
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)

Способ 1. Использование программы командной строки Netsh

Чтобы разрешить трафик через брандмауэр Windows по TCP-порту 445 запустите на удаленном компьютере с Windows XP с пакетом обновления 2 (SP2) команду netsh.
  1. В меню Пуск выберите пункт Выполнить, введите в поле Открыть команду cmd и нажмите кнопку ОК.
  2. Введите следующую команду и нажмите клавишу ВВОД:
    netsh firewall set portopening tcp 445 smb enable
    Появится следующее сообщение:
    Ok.
  3. Закройте окно командной строки.
Чтобы применить это изменение для всей организации, выполните команду netsh с помощью пакетного файла или сценария.

Способ 2. Использование графического интерфейса пользователя

Чтобы разрешить трафик через брандмауэр Windows по TCP-порту 445 на удаленном компьютере с Windows XP с пакетом обновления 2 (SP2), измените настройки брандмауэра.
  1. Нажмите кнопку Пуск и выберите пункт Панель управления.
  2. Выберите элемент Центр обеспечения безопасности, а затем — Брандмауэр Windows.
  3. На вкладке Исключения установите флажок Общий доступ к файлам и принтерам, а затем выберите команду Изменить.
  4. Установите флажок TCP 445, нажмите кнопку Изменить область, а затем выполните одно из указанных ниже действий.
    • Выберите вариант Только локальная сеть (подсеть).
    • Выберите вариант Особый список, а затем введите IP-адреса компьютеров, с помощью которых требуется управлять этим компьютером.
  5. Нажмите кнопку ОК четыре раза.

Способ 3. Назначение групповой политики "Разрешать исключения для удаленного управления"

Примечание. Этот способ применим для управления совокупностью компьютеров в рамках одного подразделения. Дополнительные сведения об использовании групповой политики см. на следующем веб-узле корпорации Майкрософт:
http://www.microsoft.com/windowsserver2003/technologies/management/grouppolicy/default.mspx (http://www.microsoft.com/windowsserver2003/technologies/management/grouppolicy/default.mspx)
Брандмауэр Windows должен быть настроен на использование профиля домена. Использование профиля домена является одним из самых распространенных способов. Дополнительные сведения о профилях брандмауэра Windows и выборе системой Windows профиля для загрузки см. в руководстве Развертывание параметров брандмауэра Windows в Microsoft Windows XP с пакетом обновления 2 (SP2). Загрузить руководство можно со следующего веб-узла корпорации Майкрософт:
http://www.microsoft.com/downloads/details.aspx?FamilyID=4454e0e1-61fa-447a-bdcd-499f73a637d1&DisplayLang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=4454e0e1-61fa-447a-bdcd-499f73a637d1&DisplayLang=en)
Чтобы настроить групповую политику на разрешение удаленного администрирования компьютеров, выполните указанные ниже действия.
  1. Создайте объект групповой политики для подразделения с компьютерами под управлением Windows XP с пакетом обновления 2 (SP2), которыми необходимо управлять.
    1. Войдите в контроллер домена.
    2. В меню Пуск выберите пункт Выполнить, введите в поле Открыть команду dsa.msc и нажмите кнопку ОК.
    3. Разверните домен, щелкните правой кнопкой мыши подразделение, для которого необходимо создать групповую политику, и выберите пункт Свойства.
    4. Откройте вкладку Групповая политика и нажмите кнопку Создать.
    5. Введите имя объекта групповой политики и нажмите клавишу ВВОД.
    6. Нажмите кнопку Закрыть.
  2. Войдите в компьютер с системой Windows XP с пакетом обновления 2 (SP2), который является членом домена, как участник одной или нескольких из следующих групп безопасности:
    • администраторы домена;
    • администраторы предприятия;
    • владельцы-создатели групповой политики.
  3. В меню Пуск выберите пункт Выполнить, введите в поле Открыть команду mmc и нажмите кнопку ОК.
  4. В меню Файл выберите команду Добавить или удалить оснастку.
  5. На вкладке Изолированная оснастка нажмите кнопку Добавить.
  6. В диалоговом окне Добавить изолированную оснастку выберите вариант Редактор объектов групповой политики и нажмите кнопку Добавить.
  7. В диалоговом окне Выбор объекта групповой политики нажмите кнопку Обзор.
  8. Выберите объект групповой политики, для которого требуется обновить настройки брандмауэра Windows. Например, выберите подразделение с компьютерами под управлением Windows XP с пакетом обновления 2 (SP2) и нажмите кнопку ОК, а затем выберите объект групповой политики, созданный на этапе 1.
  9. Нажмите кнопку ОК, а затем — Готово.
  10. Нажмите кнопку Закрыть, а затем — ОК.
  11. В разделе Корень консоли разверните объект групповой политики, выбранный на этапе 8, разверните последовательно элементы Конфигурация компьютера, Административные шаблоны, Сеть, Сетевые подключения и Брандмауэр Windows, а затем — выберите элемент Профиль домена.
  12. Дважды щелкните расположенный справа элемент Брандмауэр Windows: Разрешать исключения для удаленного управления.
  13. Выберите вариант Включено, а затем укажите область администрирования в поле Разрешать незапрошенные входящие сообщения от. Например, чтобы разрешить удаленное администрирование с конкретного IP-адреса, укажите этот IP-адрес в поле Разрешать незапрошенные входящие сообщения от.

    Чтобы разрешить удаленное администрирование из определенной подсети, укажите эту подсеть в формате CIDR. Чтобы выбрать сеть 192.168.1.0, введите IP-адрес 192.168.1.0/24 с 24-разрядной маской подсети 255.255.255.0. Дополнительные сведения о способе выбора допустимой области администрирования см. в разделе синтаксиса на вкладке Параметры для этой политики.
  14. Нажмите кнопку ОК, а затем в меню Файл выберите команду Выход.

Дополнительная информация

Средства администрирования клиентских компьютеров представляют совокупность оснасток консоли управления (MMC), которые позволяют выполнять администрирование пользователей, компьютеров, служб и других компонентов системы на локальных и удаленных компьютерах.

Ссылки

Дополнительные сведения о подключении с использованием брандмауэра Windows см. на следующем веб-узле корпорации Майкрософт:
http://msdn2.microsoft.com/en-us/library/aa389286.aspx (http://msdn2.microsoft.com/en-us/library/aa389286.aspx)
Дополнительные сведения о включении и отключении исключений для удаленного администрирования см. на следующем веб-узле корпорации Майкрософт:
http://technet2.microsoft.com/windowsserver/en/library/b8057a7a-a0d3-40b5-8224-ea6a4f5e17231033.mspx?mfr=true (http://technet2.microsoft.com/windowsserver/en/library/b8057a7a-a0d3-40b5-8224-ea6a4f5e17231033.mspx?mfr=true)
Дополнительные сведения по этой теме см. в следующей статье базы знаний Майкрософт:
832578  (http://support.microsoft.com/kb/832578/ ) При использовании программы Delprof.exe для удаления неактивных профилей на удаленном компьютере возникает сообщение об ошибке "Не найден сетевой путь" (Эта ссылка может указывать на содержимое полностью или частично на английском языке)
Если с помощью этих статей разрешить проблему не удается или возникают неполадки, отличные от описанных в данной статье, дополнительные сведения можно получить с помощью поиска по базе знаний Майкрософт. Для этого обратитесь на следующий веб-узел корпорации Майкрософт:
http://support.microsoft.com/ (http://support.microsoft.com/?ln=ru)
. Введите в поле Поиск страниц поддержки (в базе знаний) текст полученного сообщения об ошибке или описание проблемы.

Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
Ключевые слова: 
kbexpertiseadvanced kbresolve kbsecurity kbpermissions kbadmin kbnetwork kbtshoot kberrmsg kbprb KB840634