Artigo: 840634 - Última revisão: sexta-feira, 28 de Dezembro de 2007 - Revisão: 6.1

Como configurar a Firewall do Windows no Windows XP Service Pack 2 para permitir ferramentas de administração remota que utilizam WMI, RPC ou DCOM

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Importante
Este artigo destina-se a utilizadores de computadores avançados. Se não estiver familiarizado com operações avançadas de resolução de problemas, poderá pretender contactar alguém para o ajudar ou contactar o suporte. Para obter informações sobre como contactar o suporte, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)

Importante: estes passos podem aumentar o risco de segurança. Estes passos podem também tornar o computador ou a rede mais vulnerável a ataques de utilizadores maliciosos ou de software malicioso como vírus. Recomendamos o processo descrito neste artigo para permitir que os programas funcionem do modo previsto na respectiva concepção ou para implementar capacidades específicas de programa. Antes de efectuar estas alterações, recomendamos que avalie os riscos associados à implementação deste processo no seu ambiente específico. Se decidir implementar este processo, efectue todos os passos adicionais adequados para ajudar a proteger o sistema. Recomendamos a utilização deste processo apenas se o mesmo for realmente necessário.

Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido).

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Sintomas

Quando tenta gerir remotamente um computador com o Microsoft Windows XP Service Pack 2 (SP2), poderá receber uma mensagem de erro semelhante a uma das mensagens de erro que se seguem:
O computador \\NOMECOMPUTADOR.EXEMPLO.COM não pode ser gerido. O caminho de rede não foi encontrado.

Escolha 'Ligar a outro computador' no menu 'Acção' para gerir outro computador.
Não foi possível aceder ao computador NomeComputador.
O erro foi: Acesso negado.
Não foi possível aceder ao computador NomeComputador.
O erro foi: O caminho de rede não foi encontrado.
Falha ao abrir o objecto de política de grupo em NomeComputador. Poderá não ter os direitos apropriados.
Detalhes: O caminho de rede não foi encontrado.
Um objecto (Computador) com o nome seguinte não foi encontrado: 2NomeComputador2. Verifique os tipos de objecto e a localização seleccionados para precisão e certifique-se de que escreveu o nome de objecto correctamente ou remova este objecto da selecção.
Ocorreu o erro de sistema 53. O caminho de rede não foi encontrado.

Causa

Este problema pode ocorrer se tentar gerir o computador remoto utilizando uma das seguintes ferramentas da Consola de Gestão da Microsoft (MMC):
  • Certificados
  • Gestão de computadores
  • Gestor de dispositivos
  • Gestão de discos
  • Visualizador de eventos
  • Política de grupo
  • Serviço de indexação
  • Monitor de segurança IP
  • Política de segurança IP
  • Utilizadores e grupos locais
  • Gestão de armazenamento amovível
  • Conjunto de políticas resultante
  • Serviços
  • Pastas partilhadas
  • Controlo WMI
Além disso, este problema pode ocorrer se tentar gerir o computador remoto utilizando a ferramenta Net.exe ou se tentar aceder ao computador remoto a partir das seguintes caixas de diálogo:
  • Seleccionar utilizadores, computadores ou grupos
  • Localizar utilizadores, contactos e grupos
  • Net.exe
Este problema ocorre porque a configuração predefinida do programa Firewall do Windows no Windows XP SP2 bloqueia o tráfego de rede de entrada na porta TCP (Protocolo de Controlo de Transmissão) 445. Para que as ferramentas administrativas aqui apresentadas consigam ligar a um computador remoto, esse computador remoto tem de permitir tráfego de rede de entrada na porta TCP 445.

Resolução

Para resolver este problema, utilize um dos seguintes métodos.

O Método 1 e o Método 2 descrevem como resolver este problema em cada computador. O Método 3 descreve como resolver este problema em vários computadores utilizando a Política de Grupo.

Utilizadores Avançados

Estes métodos destinam-se a utilizadores de computadores avançados. Se não estiver familiarizado com operações avançadas de resolução de problemas, poderá pretender contactar alguém para o ajudar ou contactar o suporte. Para obter informações sobre como contactar o suporte, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)

Método 1: Utilizar a ferramenta da linha de comandos Netsh

No computador remoto baseado no Windows XP SP2, execute um comando netsh para permitir tráfego através da Firewall do Windows na porta TCP 445:
  1. Clique em Iniciar, clique em Executar, escreva cmd na caixa Abrir e clique em OK.
  2. Escreva o seguinte comando e prima ENTER:
    netsh firewall set portopening tcp 445 smb enable
    É apresentada a seguinte mensagem:
    Ok.
  3. Feche a linha de comandos.
Para implementar esta alteração em toda a organização, execute esta linha de comandos netsh a partir de um ficheiro batch ou de um script.

Método 2: Utilizar a Interface Gráfica do Utilizador

No computador remoto baseado no Windows XP SP2, modifique as definições da Firewall do Windows para permitir tráfego de entrada na porta TCP 445:
  1. Clique em Iniciar e clique em Painel de controlo.
  2. Clique em Centro de segurança e clique em Firewall do Windows.
  3. Clique no separador Excepções, clique para seleccionar a caixa de verificação Partilha de ficheiros e impressoras e clique em Editar.
  4. Clique para seleccionar a caixa de verificação TCP 445, clique em Modificar âmbito e efectue uma das seguintes acções:
    • Clique em Apenas a minha rede (sub-rede).
    • Clique em Lista personalizada e escreva os endereços IP com que pretende gerir este computador.
  5. Clique em OK quatro vezes.

Método 3: Utilizar a Política de Grupo para definir a política Permitir Excepção de Administração Remota

Nota: estes passos pressupõem que todos os computadores que pretende gerir com esta política se encontram na mesma unidade organizacional. Para mais informações sobre como utilizar a Política de Grupo, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/windowsserver2003/technologies/management/grouppolicy/default.mspx (http://www.microsoft.com/windowsserver2003/technologies/management/grouppolicy/default.mspx)
Estes passos pressupõem que a Firewall do Windows está configurada para utilizar o perfil de domínio. O perfil de domínio é o cenário mais comum. Para mais informações sobre perfis da Firewall do Windows e sobre como o Windows selecciona o perfil a carregar, consulte o manual Deploying Windows Firewall Settings for Microsoft Windows XP with Service Pack 2. Para obter este manual, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyID=4454e0e1-61fa-447a-bdcd-499f73a637d1&DisplayLang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=4454e0e1-61fa-447a-bdcd-499f73a637d1&DisplayLang=en)
Para configurar a Política de Grupo de modo a permitir a administração remota dos computadores, siga estes passos.
  1. Crie um objecto de política de grupo para a unidade organizacional que contém os computadores baseados no Windows XP SP2 que pretende gerir:
    1. Inicie sessão num controlador de domínio.
    2. Clique em Iniciar, clique em Executar, escreva dsa.msc na caixa Abrir e clique em OK.
    3. Expanda o domínio, clique com o botão direito do rato na unidade organizacional onde pretende criar a política de grupo e clique em Propriedades.
    4. Clique no separador Política de grupo e clique em Novo.
    5. Escreva um nome para o objecto da política de grupo e prima ENTER.
    6. Clique em Fechar.
  2. Inicie sessão num computador membro do domínio que tenha o Windows XP SP2 em execução como um utilizador membro de um ou mais dos seguintes grupos de segurança:
    • Admins do domínio
    • Admins da empresa
    • Proprietários do criador de políticas de grupo
  3. Clique em Iniciar, clique em Executar, escreva mmc na caixa Abrir e clique em OK.
  4. No menu Ficheiro, clique em Adicionar/remover snap-in.
  5. No separador Autónomo, clique em Adicionar.
  6. Na caixa de diálogo Adicionar snap-in autónomo clique em Editor de objecto de política de grupo e, em seguida, clique em Adicionar.
  7. Na caixa de diálogo Seleccionar política de grupo, clique em Procurar.
  8. Clique no objecto de política de grupo que pretende actualizar com as novas definições da Firewall do Windows. Por exemplo, clique na unidade organizacional que contém os computadores com o Windows XP SP2, clique em OK e clique no objecto de política de grupo criado no passo 1.
  9. Clique em OK e clique em Concluir.
  10. Clique em Fechar e clique em OK.
  11. Em Raiz da consola, expanda o objecto de política de grupo seleccionado no passo 8, expanda Configuração do computador, expanda Modelos administrativos, expanda Rede, expanda Ligações de rede, expanda Firewall do Windows e clique em Perfil de Domínio.
  12. No lado direito, faça duplo clique em Firewall do Windows: Permitir excepção de administração remota.
  13. Clique em Activado e especifique o âmbito administrativo na caixa Permitir mensagens a receber não solicitadas de. Por exemplo, para permitir a administração remota a partir de um determinado endereço IP, escreva esse endereço na caixa Permitir mensagens a receber não solicitadas de.

    Para permitir a administração remota a partir de uma determinada sub-rede, escreva essa sub-rede utilizando o formato CIDR (Encaminhamento de domínio de Internet sem classes). Neste cenário, escreva 192.168.1.0/24 para especificar a rede 192.168.1.0 com uma máscara de sub-rede de 24 bits de 255.255.255.0. Para mais informações sobre como especificar um âmbito administrativo válido, consulte a área Sintaxe do separador Definição nesta política.
  14. Clique em OK e, em seguida, clique em Fechar no menu Ficheiro.

Mais Informação

As ferramentas administrativas de cliente são um conjunto de snap-ins da MMC que lhe permitem administrar utilizadores, computadores, serviços e outros componentes de sistema em computadores remotos e locais.

Referências

Para mais informações sobre como ligar através da Firewall do Windows, visite o seguinte Web site da Microsoft:
http://msdn2.microsoft.com/en-us/library/aa389286.aspx (http://msdn2.microsoft.com/en-us/library/aa389286.aspx)
Para mais informações sobre como activar ou desactivar a Excepção de Administração Remota, visite o seguinte Web site da Microsoft:
http://technet2.microsoft.com/windowsserver/en/library/b8057a7a-a0d3-40b5-8224-ea6a4f5e17231033.mspx?mfr=true (http://technet2.microsoft.com/windowsserver/en/library/b8057a7a-a0d3-40b5-8224-ea6a4f5e17231033.mspx?mfr=true)
Para mais informações sobre tópicos relacionados, clique no número de artigo que se segue para visualizar o artigo na Base de Dados de Conhecimento da Microsoft:
832578  (http://support.microsoft.com/kb/832578/ ) The Network Path Was Not Found2 error message when you use Delprof.exe to delete inactive profiles on a remote computer
Se estes artigos não ajudarem a resolver o problema ou se detectar sintomas diferentes dos descritos neste artigo, procure mais informações na Base de Dados de Conhecimento da Microsoft. Para efectuar procuras na Base de Dados de Conhecimento Microsoft, visite o seguinte Web site da Microsoft:
http://support.microsoft.com (http://support.microsoft.com/)
Em seguida, escreva o texto da mensagem de erro recebida, ou escreva uma descrição do problema no campo Pesquisar suporte (KB).

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
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