La aplicación de Directiva de grupo produce un error en un equipo que ejecuta Windows 2000, el Service Pack 1 de Windows XP o el Service Pack 2 de Windows XP

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Síntomas

Cuando inicia un equipo basado en Microsoft Windows 2000, el Service Pack 1 (SP1) de Windows XP o el Service Pack 2 (SP2) de Windows XP en una red con cable o en una red inalámbrica que tiene autenticación 802.11, Directiva de grupo no se puede aplicar de la forma esperada o el equipo no puede unirse al servicio de directorios Active Directory.

Cuando ve los archivos de registro en el Visor de sucesos, ve las entradas siguientes:
  • Id. del suceso: 1054
    Origen: Userenv
    Tipo: Error
    Descripción: Windows no puede obtener el nombre del controlador de dominio para la red de su equipo. (El dominio especificado no existe o no se pudo establecer conexión con él.) Se ha anulado el proceso de directiva de grupo. Datos: (no disponibles)

  • Id. del suceso: 1000
    Origen: UserInit
    Tipo: Error
    Descripción: No se pudo ejecutar la siguiente secuencia de comandos AdminPassword.bat siguiente. El sistema no puede encontrar el archivo especificado. Datos: (no disponibles)

Además, se registran las entradas siguientes en el archivo de registro Userenv.log:
  • USERENV(52c.18c) 16:36:14:597 ProcessGPOs: The DC for domain <domain> is not available at startup. Retrying.

  • USERENV(52c.18c) 16:36:14:597 RetryDCContactAtMachineStartup: Enter.

  • USERENV(52c.18c) 16:36:14:597 RetryDCContactAtMachineStartup: Failed to query GpNetworkStartTimeoutPolicyValue with 2, exit.

  • USERENV(52c.18c) 16:36:14:597 RetryDCContactAtMachineStartup: Exit with status 1355.

  • USERENV(52c.18c) 16:36:14:597 ProcessGPOs: The DC for domain <domain> is not available after retries.

  • USERENV(52c.18c) 16:36:14:597 ProcessGPOs: The DC for domain <domain> is not available. aborting

  • USERENV(52c.18c) 16:36:14:757 ProcessGPOs: No WMI logging done in this policy cycle.

  • USERENV(52c.18c) 16:36:14:757 ProcessGPOs: Processing failed with error 1355.

Causa

Este problema puede producirse si el motor de Directiva de grupo o Active Directory agota el tiempo de espera mientras espera que se inicie la red. Se puede producir una condición de carrera entre el protocolo TCP/IP y el controlador del adaptador de red cuando intentan registrarse con la Especificación de interfaz de controlador de red (NDIS) de Microsoft. Si el protocolo TCP/IP se registra con NDIS antes que el controlador del adaptador de red, durante un breve tiempo solicita más componentes de red de modo usuario que los que hay disponibles en la red. Durante este breve tiempo, no se puede descargar la secuencia de comandos de inicio de Directiva de grupo.

Es más probable que este problema ocurra en redes rápidas que utilizan adaptadores de red de 1 gigabit o en entornos de equipos donde la red utiliza varios ciclos adicionales para negociar la velocidad del vínculo.

Solución

Windows 2000

Hay disponible una revisión para la que Microsoft proporciona soporte técnico. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo en sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve gravemente afectado por este problema, recomendamos que espere a la próxima actualización del software que contenga esta revisión.

Si la revisión se puede descargar, hay una sección de descarga de revisión disponible en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con los Servicios de soporte técnico y de asistencia al cliente de Microsoft con el fin de obtener la revisión.

Nota: si se producen más problemas o si hay que solucionarlos, es posible que tenga que crear una solicitud de servicio independiente. Se aplicarán los costos de soporte habituales a las preguntas y problemas de soporte técnico adicionales que no reúnan las condiciones necesarias para esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico y de asistencia al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota: el formulario relativo a la revisión que se puede descargar muestra los idiomas en los que está disponible la revisión. Si no ve su idioma, quizá sea debido a que la revisión no esté disponible para dicho idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisitos de reinicio

Debe reiniciar el equipo después de aplicar esta revisión.

Información de sustitución de la revisión

Esta revisión no sustituye a ninguna otra.

Información sobre archivos

La versión en inglés de esta revisión tiene los atributos de archivo mostrados en la tabla siguiente (u otros posteriores). Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria del elemento Fecha y hora del Panel de control.
   Fecha       Hora   Versión        Tamaño     Nombre de archivo
   ----------------------------------------------------------
   17-Jun-2004  23:05  5.0.2195.6951     46,352  Basesrv.dll
   21-Sep-2003  00:45  5.0.2195.6824     236.304  Cmd.exe
   17-Jun-2004  23:05  5.0.2195.6945    231,184  Gdi32.dll
   17-Jun-2004  23:05  5.0.2195.6946    712,464  Kernel32.dll
   24-Mar-2004  02:17  5.0.2195.6898       37,136  Mf3216.dll
   24-Mar-2004  02:17   5.0.2195.6824     54.544  Mpr.dll
   17-Jun-2004  23:05  5.0.2195.6928    335,120  Msgina.dll
   24-Mar-2004  02:17   5.0.2195.6892     90.264  Rdpwd.sys
   06-Jan-2005  04:29  5.0.2195.7017  6,278,656  Sp3res.dll
   24-Mar-2004  02:17   5.0.2195.6897    403.216  User32.dll
   18-Jan-2005  05:44  5.0.2195.7021    396,048  Userenv.dll
   10-Aug-2004  03:51  5.0.2195.6966  1,632,624  Win32k.sys
   24-Aug-2004  22:59  5.0.2195.6970    182,544  Winlogon.exe
   17-Jun-2004  23:05  5.0.2195.6946    244,496  Winsrv.dll
   17-Jun-2004  23:05  5.0.2195.6946    712,464  Kernel32.dll
   10-Aug-2004  03:51  5.0.2195.6966  1,632,624  Win32k.sys
   17-Jun-2004  23:05  5.0.2195.6946    244,496  Winsrv.dll
Después de aplicar la revisión, agregue la entrada GpNetworkStartTimeoutPolicyValue del Registro. Esta entrada define el número de segundos que hay que esperar antes de intentar ejecutar de nuevo la secuencia de comandos de inicio de Directiva de grupo. Para encontrar el valor adecuado para su configuración, defina un valor decimal de 60 y aumente el valor hasta que se resuelva el problema. Para agregar la entrada del Registro y definir el valor, siga estos pasos:
  1. Haga clic en Inicio y en Ejecutar, escriba regedit y haga clic en Aceptar.
  2. Expanda la subclave siguiente:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  3. Haga clic con el botón secundario del mouse (ratón) en Winlogon, seleccione Nuevo y haga clic en Valor DWORD.
  4. Para asignar nombre a la nueva entrada, escriba GpNetworkStartTimeoutPolicyValue y presione ENTRAR.
  5. Haga clic con el botón secundario del mouse en GpNetworkStartTimeoutPolicyValue y, a continuación, haga clic en Modificar.
  6. En Base, haga clic en Decimal.
  7. En el cuadro Información del valor, escriba 60 y haga clic en Aceptar.
  8. Cierre el Editor del Registro y reinicie el equipo.
  9. Si la secuencia de comandos de inicio de Directiva de grupo no se ejecuta, aumente el valor de la entrada GpNetworkStartTimeoutPolicyValue del Registro.

Service Pack 1 de Windows XP

Hay disponible una revisión para la que Microsoft proporciona soporte técnico. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo en sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve gravemente afectado por este problema, recomendamos que espere a la próxima actualización del software que contenga esta revisión.

Si la revisión se puede descargar, hay una sección de descarga de revisión disponible en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con los Servicios de soporte técnico y de asistencia al cliente de Microsoft con el fin de obtener la revisión.

Nota: si se producen más problemas o si hay que solucionarlos, es posible que tenga que crear una solicitud de servicio independiente. Se aplicarán los costos de soporte habituales a las preguntas y problemas de soporte técnico adicionales que no reúnan las condiciones necesarias para esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico y de asistencia al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota: el formulario relativo a la revisión que se puede descargar muestra los idiomas en los que está disponible la revisión. Si no ve su idioma, quizá sea debido a que la revisión no esté disponible para dicho idioma. La versión en inglés de esta revisión tiene los atributos de archivo mostrados en la tabla siguiente (u otros posteriores). Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria del elemento Fecha y hora del Panel de control.
Versiones de 64 bits de Windows XP
   Fecha         Hora   Versión      Tamaño       Nombre de archivo    Plataforma
   --------------------------------------------------------------------
   04-Jun-2004  05:52  5.1.2600.1534  1,718,272  Userenv.dll   IA-64
   04-Jun-2004  05:44  5.1.2600.1534    672,256  Wuserenv.dll    x86
Windows XP, versiones de 32 bits
   Fecha       Hora   Versión        Tamaño     Nombre de archivo
   -------------------------------------------------------
   04-Jun-2004  05:44  5.1.2600.1534  672,256  Userenv.dll
Importante: esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. Sin embargo, se pueden producir graves problemas si modifica el Registro incorrectamente. Por tanto, asegúrese de que sigue estos pasos cuidadosamente. Para obtener más protección, haga una copia de seguridad del Registro antes de modificarlo. Después, puede restaurar el Registro si se produce algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo realizar una copia de seguridad, modificar y restaurar el Registro en Windows XP y Windows Server 2003


Después de aplicar la revisión, agregue la entrada GpNetworkStartTimeoutPolicyValue del Registro. Esta entrada define el número de segundos que hay que esperar antes de intentar ejecutar de nuevo la secuencia de comandos de inicio de Directiva de grupo. Para encontrar el valor adecuado para su configuración, defina un valor decimal de 60 y aumente el valor hasta que se resuelva el problema. Para agregar la entrada del Registro y definir el valor, siga estos pasos:
  1. Haga clic en Inicio y en Ejecutar, escriba regedit y haga clic en Aceptar.
  2. Expanda la subclave siguiente:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  3. Haga clic con el botón secundario del mouse en Winlogon, seleccione Nuevo y haga clic en Valor DWORD.
  4. Para asignar nombre a la nueva entrada, escriba GpNetworkStartTimeoutPolicyValue y presione ENTRAR.
  5. Haga clic con el botón secundario del mouse en GpNetworkStartTimeoutPolicyValue y, a continuación, haga clic en Modificar.
  6. En Base, haga clic en Decimal.
  7. En el cuadro Información del valor, escriba 60 y haga clic en Aceptar.
  8. Cierre el Editor del Registro y reinicie el equipo.
  9. Si la secuencia de comandos de inicio de Directiva de grupo no se ejecuta, aumente el valor de la entrada GpNetworkStartTimeoutPolicyValue del Registro.

Service Pack 2 de Windows XP

Después de aplicar el Service Pack 2 de Windows XP, debe agregar la entrada GpNetworkStartTimeoutPolicyValue del Registro. Esta entrada define el número de segundos que hay que esperar antes de intentar ejecutar de nuevo la secuencia de comandos de inicio de Directiva de grupo. Para encontrar el valor adecuado para su configuración, defina un valor decimal de 60 y aumente el valor hasta que se resuelva el problema. Para agregar la entrada del Registro y definir el valor, siga estos pasos:
  1. Haga clic en Inicio y en Ejecutar, escriba regedit y haga clic en Aceptar.
  2. Expanda la subclave siguiente:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  3. Haga clic con el botón secundario del mouse en Winlogon, seleccione Nuevo y haga clic en Valor DWORD.
  4. Para asignar nombre a la nueva entrada, escriba GpNetworkStartTimeoutPolicyValue y presione ENTRAR.
  5. Haga clic con el botón secundario del mouse en GpNetworkStartTimeoutPolicyValue y, a continuación, haga clic en Modificar.
  6. En Base, haga clic en Decimal.
  7. En el cuadro Información del valor, escriba 60 y haga clic en Aceptar.
  8. Cierre el Editor del Registro y reinicie el equipo.
  9. Si la secuencia de comandos de inicio de Directiva de grupo no se ejecuta, aumente el valor de la entrada GpNetworkStartTimeoutPolicyValue del Registro.

Crear una directiva de tiempo de espera de inicio de red de Directiva de grupo

El tiempo de espera de directiva GpNetworkStartTimeoutPolicyValue se puede especificar en dos ubicaciones del Registro:
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\Current Version\Winlogon
  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System
Puede hacerlo si agrega un valor DWORD de GpNetworkStartTimeoutPolicyValue con varios segundos entre 30 y 600.

Windows lee primero la subclave Winlogon. A continuación, Windows lee la subclave Policies. El valor de la subclave Policies reemplaza cualquier valor de la subclave Winlogon. No hay interfaz de usuario que se pueda usar para establecer este objeto de Directiva de grupo (GPO). Por tanto, tiene que implementar un archivo ADM personalizado para establecer el GPO.

El valor especificado debe tener una duración suficiente como para asegurarse de que se realiza la conexión. Durante el período de tiempo de espera, Windows examina el estado de la conexión cada dos segundos y continúa con el inicio del sistema en cuanto se confirma la conexión. Por tanto, se recomienda establecer un valor superior al valor mínimo de 30. Sin embargo, sepa que si el sistema se desconecta legítimamente, Windows se paralizará durante todo el período de tiempo de espera.

Nota: el sistema se desconecta legítimamente, por ejemplo, cuando se desconecta el cable de red o cuando el servidor se pone sin conexión.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Nota: se sabe que este problema se produce en los equipos portátiles Toshiba Dynabook que utilizan un adaptador de red de Intel. Los productos de terceros que se analizan en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, con respecto al rendimiento o la confiabilidad de estos productos.

Referencias

Para obtener más información acerca de la terminología relativa a las actualizaciones de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft
Los productos de terceros que se analizan en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, con respecto al rendimiento o la confiabilidad de estos productos.

Propiedades

Id. de artículo: 840669 - Última revisión: jueves, 14 de agosto de 2008 - Versión: 7.4
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Professional SP2
Palabras clave: 
kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB840669

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