Vous ne pouvez pas établir une connexion SSL (Secure Sockets LAYER) par le biais de Microsoft Secure Channel (SChannel) à l'aide du certificat client par défaut de Windows 2000 Server

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Numéro d'article: 840723 - Voir les produits auxquels s'applique cet article
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256986 Description de du Registre Microsoft Windows
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Sommaire

Symptômes

Un service qui s'exécute dans le contexte du système d'exploitation Microsoft Windows ne peut pas établir une connexion SSL (Secure Sockets LAYER) en utilisant l'authentification Microsoft Secure Channel (SChannel) avec un certificat client par défaut. Par exemple, ce scénario peut se produire lorsque vous configurez un connecteur Microsoft Exchange Server SMTP Simple Mail Transfer Protocol () pour utiliser le protocole TLS (Transport Layer Security).

Cause

Ce problème se produit parce que SChannel recherche le certificat client par défaut dans la sous-clé de Registre suivante :
HKEY_USERS\.Default\Software\Microsoft\SystemCertificates
Toutefois, le certificat de client par défaut figure dans la sous-clé de Registre suivante :
HKEY_LOCAL_MACHINE\Software\Microsoft\SystemCertificates

Résolution

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, soumettez une demande à Microsoft client service et support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Aucune condition préalable à l'installation ne sont nécessaires.

Demande de redémarrage

Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif ne remplace aucun autre correctif.

Informations de fichier

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en coordinated universal temps (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'outil Date et heure du Panneau de configuration.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Mar-2004  02:17  5.0.2195.6876     388,368  Advapi32.dll     
   24-Mar-2004  02:17  5.0.2195.6866      69,904  Browser.dll      
   24-Mar-2004  02:17  5.0.2195.6824     134,928  Dnsapi.dll       
   24-Mar-2004  02:17  5.0.2195.6876      92,432  Dnsrslvr.dll     
   24-Mar-2004  02:17  5.0.2195.6883      47,888  Eventlog.dll     
   24-Mar-2004  02:17  5.0.2195.6890     143,632  Kdcsvc.dll       
   11-Mar-2004  02:37  5.0.2195.6903     210,192  Kerberos.dll     
   21-Sep-2003  00:32  5.0.2195.6824      71,888  Ksecdd.sys
   11-Mar-2004  02:37  5.0.2195.6902     520,976  Lsasrv.dll       
   25-Feb-2004  23:59  5.0.2195.6902      33,552  Lsass.exe        
   11-Mar-2004  02:37  5.0.2195.6897     123,152  Msv1_0.dll       
   24-Mar-2004  02:17  5.0.2195.6897     312,592  Netapi32.dll     
   24-Mar-2004  02:17  5.0.2195.6891     371,472  Netlogon.dll     
   24-Mar-2004  02:17  5.0.2195.6896   1,028,880  Ntdsa.dll        
   24-Mar-2004  02:17  5.0.2195.6897     388,368  Samsrv.dll       
   24-Mar-2004  02:17  5.0.2195.6893     111,376  Scecli.dll       
   24-Mar-2004  02:17  5.0.2195.6903     253,200  Scesrv.dll       
   19-Apr-2004  23:20  5.1.2195.6920     147,216  Schannel.dll     
   05-Feb-2004  20:18  5.0.2195.6896   5,869,056  Sp3res.dll       
   24-Mar-2004  02:17  5.0.2195.6824      50,960  W32time.dll      
   21-Sep-2003  00:32  5.0.2195.6824      57,104  W32tm.exe        

Contournement

Avertissement Si vous utilisez l'Éditeur du Registre de façon incorrecte, vous pouvez générer des problèmes sérieuses pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantit que vous pouvez résoudre les problèmes résultant de l'utilisation incorrecte de l'Éditeur du Registre. Utilisez l'Éditeur du Registre à vos risques et périls.
Pour contourner ce problème, déplacez la sous-clé
SystemCertificates
à partir de la sous-arborescence
HKEY_LOCAL_MACHINES
vers la sous-arborescence
HKEY_USERS
. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer , puis cliquez sur Exécuter .
  2. Dans la zone Ouvrir , tapez regedit , puis cliquez sur OK .
  3. Recherchez et cliquez ensuite la sous-clé suivante :
    HKEY_LOCAL_MACHINE\Software\Microsoft\SystemCertificates
  4. Dans le menu Fichier de Registre, cliquez sur Exporter un fichier du Registre... .
  5. Dans la zone Enregistrer dans , sélectionnez un emplacement pour enregistrer le fichier .reg, tapez Certificates.reg dans la zone Nom de fichier , puis cliquez sur Enregistrer .
  6. Réduire l'Éditeur du Registre.
  7. Ouvrez le fichier Certificates.reg dans le bloc-notes.
  8. Remplacer chaque occurrence de « HKEY_LOCAL_MACHINE » avec « HKEY_USERS\.DEFAULT . »
  9. Enregistrez le fichier et quittez le Bloc-notes.
  10. Agrandissez l'Éditeur du Registre.
  11. Dans le menu Fichier de Registre, cliquez sur fichier... d'importation du Registre .
  12. Sélectionnez le fichier Certificates.reg que vous avez enregistré, puis cliquez sur Ouvrir .

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
816915 Nouveau fichier de schéma d'appellation pour les packages de mise à jour logicielle Microsoft Windows
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Propriétés

Numéro d'article: 840723 - Dernière mise à jour: mardi 4 février 2014 - Version: 2.5
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professionnel
  • Microsoft Windows 2000 Advanced Server
Mots-clés : 
kbnosurvey kbarchive kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbwin2000presp5fix KB840723 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 840723
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