Windows 2000 Server'da Microsoft Güvenli Kanal aracılığıyla varsayılan istemci sertifikası kullanılarak bir Güvenli Yuva Katmanı (SSL) bağlantısı oluşturulamıyor

Makale çevirileri Makale çevirileri
Makale numarası: 840723 - Bu makalenin geçerli olduğu ürünleri görün.
Bu makale arşivlenmiştir. "Olduğu gibi" sunulmaktadır ve bundan sonra güncelleştirilmeyecektir.
Önemli Bu makale, kayıt defterini düzenlemekle ilgili bilgiler içermektedir. Kayıt defterini değiştirmeden önce yedeklediğinizden ve bir sorun çıkması durumunda kayıt defterini geri nasıl yükleyeceğinizi anladığınızdan emin olun. Kayıt defterini yedekleme, geri yükleme ve düzenleme ile ilgili bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
256986Microsoft Windows Kayıt Defteri'nin Açıklaması
Hepsini aç | Hepsini kapa

Bu Sayfada

Belirtiler

Microsoft Windows işletim sistemi içeriğinde çalışan BIR hizmeti, varsayılan istemci sertifikasıyla Microsoft güvenli kanal (SChannel) kimlik doğrulaması'nı kullanarak bir Güvenli Yuva Katmanı (SSL) bağlantısı yapılamıyor. Örneğin, bir Microsoft Exchange sunucusu Basit Posta Aktarım Protokolü (SMTP) Bağlayıcısı, Aktarım Katmanı Güvenliği (TLS) protokolünü kullanmak üzere yapılandırırken Bu senaryoda ortaya çıkabilir.

Neden

Bu sorun, aşağıdaki kayıt defteri alt anahtarında varsayılan istemci sertifikası SChannel arar oluşur:
HKEY_USERS\.Default\Software\Microsoft\SystemCertificates
Ancak, varsayılan istemci sertifikası aşağıdaki kayıt defteri alt anahtarında depolanır:
HKEY_LOCAL_MACHINE\Software\Microsoft\SystemCertificates

Çözüm

Düzeltme bilgileri

Desteklenen bir düzeltme Microsoft'tan edinilebilir. Ancak bu düzeltmenin, yalnızca bu makalede anlatılan sorunu gidermesi amaçlanmıştır. Bu düzeltmeyi yalnızca bu sorunla karşılaşan sistemlere uygulayın.

Düzeltme karşıdan yüklenebilir ise bu Bilgi Bankası makalesinin başında "Düzeltme karşıdan yüklenebilir" bölümü bulunur. Bu bölüm görünmüyorsa, düzeltmeyi edinmek üzere Microsoft Müşteri Hizmetleri ve Destek ekibine bir istekte bulunun.

Not Ek sorunlar oluşursa veya tüm sorun giderme işlemi gerekmiyorsa, ayrı bir hizmet isteği oluşturmanız gerekebilir. Ek destek sorularına ve bu düzeltme için geçerli olmayan sorunlara normal destek ücretleri uygulanır. Microsoft Müşteri Hizmetleri ve Destek telefon numaralarının tam listesi veya ayrı bir hizmet isteği oluşturmak için, aşağıdaki Microsoft Web sitesini ziyaret edin:
http://support.microsoft.com/contactus/?ws=support
Not "Düzeltme karşıdan yüklenebilir" formunda, düzeltmenin kullanılabilir olduğu diller görüntülenir. Kendi dilinizi görmüyorsanız, bunun nedeni bu düzeltme, seçtiğiniz dil için kullanılamaz.

ÖNKOŞULLAR

Herhangi bir önkoşul bulunmamaktadır.

Yeniden başlatma gereksinimi

Bu düzeltmeyi yükledikten sonra bilgisayarınızı yeniden başlatmanız gerekir.

Düzeltme Değiştirme Bilgileri

Bu düzeltme başka bir düzeltmenin yerini almaz.

DOSYA BİLGİLERİ

Bu düzeltmenin ingilizce sürümü dosya öznitelikleri (veya daha yenisi) aşağıdaki tabloda listelenir. Bu dosyaların tarihleri ve saatleri Koordinatlı Evrensel Saat'e (UTC) göre listelenir. Dosya bilgilerini görüntülediğinizde yerel saate dönüştürülür. UTC ve yerel saat arasındaki farkı bulmak için <a0></a0>, Denetim Masası'ndaki Tarih ve Saat aracında saat dilimi sekmesini kullanın.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Mar-2004  02:17  5.0.2195.6876     388,368  Advapi32.dll     
   24-Mar-2004  02:17  5.0.2195.6866      69,904  Browser.dll      
   24-Mar-2004  02:17  5.0.2195.6824     134,928  Dnsapi.dll       
   24-Mar-2004  02:17  5.0.2195.6876      92,432  Dnsrslvr.dll     
   24-Mar-2004  02:17  5.0.2195.6883      47,888  Eventlog.dll     
   24-Mar-2004  02:17  5.0.2195.6890     143,632  Kdcsvc.dll       
   11-Mar-2004  02:37  5.0.2195.6903     210,192  Kerberos.dll     
   21-Sep-2003  00:32  5.0.2195.6824      71,888  Ksecdd.sys
   11-Mar-2004  02:37  5.0.2195.6902     520,976  Lsasrv.dll       
   25-Feb-2004  23:59  5.0.2195.6902      33,552  Lsass.exe        
   11-Mar-2004  02:37  5.0.2195.6897     123,152  Msv1_0.dll       
   24-Mar-2004  02:17  5.0.2195.6897     312,592  Netapi32.dll     
   24-Mar-2004  02:17  5.0.2195.6891     371,472  Netlogon.dll     
   24-Mar-2004  02:17  5.0.2195.6896   1,028,880  Ntdsa.dll        
   24-Mar-2004  02:17  5.0.2195.6897     388,368  Samsrv.dll       
   24-Mar-2004  02:17  5.0.2195.6893     111,376  Scecli.dll       
   24-Mar-2004  02:17  5.0.2195.6903     253,200  Scesrv.dll       
   19-Apr-2004  23:20  5.1.2195.6920     147,216  Schannel.dll     
   05-Feb-2004  20:18  5.0.2195.6896   5,869,056  Sp3res.dll       
   24-Mar-2004  02:17  5.0.2195.6824      50,960  W32time.dll      
   21-Sep-2003  00:32  5.0.2195.6824      57,104  W32tm.exe        

Pratik Çözüm

Uyarı Kayıt Defteri Düzenleyicisi'ni yanlış kullanırsanız, işletim sisteminizi yeniden yüklemenizi gerektirebilecek ciddi sorunlara neden olabilir. Microsoft, Kayıt Defteri Düzenleyicisi yanlış kullanımından kaynaklanan sorunları çözebileceğinizi garanti edemez. Kayıt Defteri Düzenleyicisi'ni kullanmak kendi sorumluluğunuzdadır.
Bu soruna geçici bir çözüm bulmak için <a0></a0>,
HKEY_LOCAL_MACHINES
subtree
SystemCertificates
alt anahtarı için
HKEY_USERS
subtree taşıyın. Bunu yapmak için şu adımları izleyin:
  1. Başlat ' ı tıklatın ve sonra da <a2>Çalıştır</a2>'ı tıklatın.
  2. kutusuna regedit yazın ve Tamam ' ı tıklatın.
  3. Aşağıdaki alt anahtarı bulup tıklatın:
    HKEY_LOCAL_MACHINE\Software\Microsoft\SystemCertificates
  4. Kayıt defteri Dosya menüsünde ... Kayıt defteri dosyası ver'i tıklatın.
  5. Konum kutusunda, .reg dosyasını kaydetmek, Certificates.reg yer <a1>Dosya adı</a1> kutusuna yazın ve sonra da <a2>Kaydet</a2>'i tıklatın, bir konum seçin.
  6. Kayıt Defteri Düzenleyicisi'ni simge durumuna küçültün.
  7. Certificates.reg dosyasını Not Defteri'nde açın.
  8. "HKEY_LOCAL_MACHINE" "HKEY_USERS\.DEFAULT." ile her geçtiği yerde değiştirmek
  9. Dosyayı kaydedin ve Not Defteri'nden çıkın.
  10. Kayıt Defteri Düzenleyicisi'ni ekranı kaplayacak şekilde büyütün.
  11. Kayıt defteri Dosya menüsünde ... Kayıt dosyasına Al'ı tıklatın.
  12. Kaydettiğiniz Certificates.reg dosyasını seçin ve ' ı tıklatın.

Durum

Microsoft, "Geçerli Olduğu Ürünler" bölümünde listelenen Microsoft ürünlerinde bu sorunun olduğunu onaylamıştır.

Daha fazla bilgi

Ek bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
816915Microsoft Windows Yazılım Güncelleştirme Paketleri için Yeni Dosya Adlandırma Şeması
824684Microsoft yazılım güncelleştirmelerini açıklamak için kullanılan standart terminolojinin açıklaması

Özellikler

Makale numarası: 840723 - Last Review: 10 Şubat 2014 Pazartesi - Gözden geçirme: 2.5
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Anahtar Kelimeler: 
kbnosurvey kbarchive kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbwin2000presp5fix KB840723 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:840723

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com