Document de fusion format texte en fonction de RTF n'est plus connecté à source de données dans Word

Traductions disponibles Traductions disponibles
Numéro d'article: 840936 - Voir les produits auxquels s'applique cet article
important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, veillez à sauvegarder et assurez-vous que vous savez comment restaurer le Registre si un problème se produit. Pour savoir comment sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
256986 Description de du Registre Microsoft Windows
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous ouvrez un Microsoft Word document principal de fusion qui est lié à une source de données, les liens peut-être ne plus fonctionner. Vous rencontrez les problèmes suivants :
  • Lorsque vous ouvrez le document principal, vous ne recevez pas un message d'avertissement semblable à celui-ci :
    Ouvrez ce document exécutera la SQL suivante commande
  • La plupart des boutons de la barre d'outils Fusion et publipostage sont indisponibles.
  • Si vous afficher le volet Fusion et publipostage, vous êtes sur étape 1 de la Mail Merge Wizard instead of sur étape 3.

    Pour afficher la fusion et publipostage volet dans Microsoft Word 2003, pointez sur Lettres et publipostage dans le menu Outils , puis cliquez sur Fusion et publipostage .

    Pour afficher le volet Fusion et publipostage dans Microsoft Office Word 2007, cliquez sur le publipostage onglet, cliquez sur Démarrer la fusion dans le groupe Démarrer la fusion , puis cliquez sur Step by Assistant Fusion et publipostage pas .

Cause

Ce problème se produit lorsque le document principal est dans Rich Text format (RTF). Office 2003 Service Pack 1 (SP1) et le Officeprograms Microsoft 2007 incluent un correctif pour empêcher les documents RTF d'avoir des liens aux sources de données.

Résolution

Pour résoudre ce problème, appliquez l'une des méthodes suivantes.

Méthode 1: Enregistrer le document principal au format Word 2003 ou au format Word 2007

Pour enregistrer le document principal au format Word 2003 ou au format Word 2007, procédez comme suit :
  1. Ouvrez le document principal de fusion et publipostage dans Word.
  2. Suivez les étapes dans la méthode 2 pour rattacher la source de données.
  3. Dans Word 2003, dans le menu Fichier , cliquez sur Enregistrer sous .

    Dans Word 2007, cliquez sur le bouton Microsoft Office , puis cliquez sur Enregistrer sous .
  4. Dans type de fichier , sélectionnez Word document .
  5. Cliquez sur Enregistrer .

Méthode 2: Rechercher la source de données

Vous pouvez rattachez la source de données chaque fois que vous ouvrez le document principal de fusion et publipostage. Pour ce faire, procédez comme suit.

Word 2003
  1. Ouvrez le document principal de fusion et publipostage.
  2. Dans le menu Outils , pointez sur Lettres et publipostage , puis cliquez sur Afficher la barre d'outils Fusion et publipostage .
  3. Dans la barre d'outils Fusion et publipostage , cliquez sur Ouvrir la source de données .
  4. Sélectionnez la source de données, puis cliquez sur Ouvrir .
Word 2007
  1. Ouvrez le document principal de fusion et publipostage.
  2. Cliquez sur l'onglet publipostage , cliquez sur Sélection des destinataires dans la Démarrer la fusion et de groupe, puis cliquez sur l'aide de la liste existante .
  3. Sélectionnez la source de données, puis cliquez sur Ouvrir .

Méthode 3: désactiver le correctif dans le Service Pack 1 Office 2003 ou Office 2007

note La méthode suivante peut ne pas fonctionne dans toutes les situations. Par exemple, si vous utilisez une feuille de calcul Microsoft Excel ou une base de données Microsoft Access comme source de données, et le document principal de fusion et publipostage est en RTF, ajouter le paramètre de Registre CalcDataFieldOnOpen peut ne pas modifier le comportement décrit dans la section Symptômes. Dans ce cas, vous devez utiliser la méthode 1 ou la méthode 2 pour résoudre le problème.

Avertissement Si vous utilisez l'Éditeur du Registre de façon incorrecte, vous pouvez générer des problèmes sérieuses pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantit que vous pouvez résoudre les problèmes résultant de l'utilisation incorrecte de l'Éditeur du Registre. Utilisez l'Éditeur du Registre à vos risques et périls.
Pour désactiver le correctif décrit dans le Service Pack 1 Office 2003 ou Office 2007, procédez comme suit :
  1. Démarrez l'Éditeur du Registre.
  2. Sur un ordinateur qui exécute Office 2003 SP1, recherchez et cliquez sur la sous-clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options
    sur un ordinateur qui exécute Office 2007, recherchez et cliquez sur la sous-clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Options
  3. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  4. Sous nom , tapez CalcDataFieldOnOpen .
  5. Double-cliquez sur CalcDataFieldOnOpen .
  6. Dans la zone données de la valeur , tapez 1 .
  7. Cliquez sur OK , puis quittez l'Éditeur du Registre.
note Détachement de la source de données d'un document principal RTF vous protège contre involontairement l'envoi de données à un utilisateur malveillant. En recherchant la source de données correctes, vous savez que vous envoyez les informations correctes.

Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
825765 Vous recevez le message ? l'ouverture de ce exécutera la suivante commande SQL ? lorsque vous ouvrez un document de principal de fusion et publipostage Word qui est lié à une source de données

Propriétés

Numéro d'article: 840936 - Dernière mise à jour: mardi 2 janvier 2007 - Version: 4.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Word 2007
  • Microsoft Office Word 2003, Service Pack 1 (SP1)
Mots-clés : 
kbmt kboffice2003sp1fix kbprb KB840936 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 840936
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com